Bug 9954 - Moving a file and answering "No" to "Replace existing?" deletes the file
: Moving a file and answering "No" to "Replace existing?" deletes the file
Status: RESOLVED DUPLICATE of bug 6882
Product: Utilities
File manager
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified critical with 1 vote (vote)
: ---
Assigned To: unassigned
: file-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-04-18 21:40 UTC by Filip Hofer
Modified: 2010-04-19 10:56 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Filip Hofer (reporter) 2010-04-18 21:40:12 UTC
SOFTWARE VERSION:
3.2010.02-8.003

EXACT STEPS LEADING TO PROBLEM: 
1. Open X-Term
2. create a new directory, e.g., mkdir d
3. go to the directory, e.g., cd d
4. create a subdirectory of the new directory, e.g., mkdir sub
5. create a file in the directory, e.g., touch f
6. create a file of the same name in the subdirectory, e.g., touch sub/f
7. open file manager and navigate to directory d
8. tap and hold on the file f and choose "Move"
9. select the subdirectory sub as the destination
10. question "Replace existing file of the same name?" appears, choose No
11. file f is deleted from directory d, file in the subdirectory remains
unchanged


EXPECTED OUTCOME:
both files remain unchanged

ACTUAL OUTCOME:
file f is deleted from directory d

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
This is quite serious bug that may lead to user data loss.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.1.9)
Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)
Comment 1 Venomrush 2010-04-19 06:34:29 UTC
Confirming PR1.1.1

Raising priority level to Critical due to loss of data.

Reproducible when creating those directories in File Manager as well and not
just through X-term.
Comment 2 Filip Hofer (reporter) 2010-04-19 08:39:46 UTC
Yes, the bug is independent of how the files and directories were created. I
have lost a camera picture when I ran into this bug for the first time.
Comment 3 Pelau Vadim 2010-04-19 09:59:11 UTC
Haven't had this issue...

But 3 comments, no votes?
Comment 4 Andre Klapper maemo.org 2010-04-19 10:56:02 UTC
Hi Filip, thanks for reporting this!
This particular issue has already been reported in our bug tracking system, but
please feel free to report any further bugs you find.

This issue will be fixed in the next public update ("PR1.2").

*** This bug has been marked as a duplicate of bug 6882 ***