Bug 993 - External memory card corrupted after disconnecting from PC
: External memory card corrupted after disconnecting from PC
Status: CLOSED DUPLICATE of bug 1204
Product: System software
File system
: unspecified
: x86 All
: High normal with 1 vote (vote)
: ---
Assigned To: Maemo QA (deprecated)
: file-system-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-01-29 18:08 UTC by Vasily
Modified: 2008-12-06 16:49 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vasily (reporter) 2007-01-29 18:08:06 UTC
After connecting to PC (Win XP fin SP2) through the USB cable PC shows 2 memory
cards as available (both Transcend 2GB 150x). After safely disconnecting from PC
(using USB-disconnect tray icon) and unplugging the USB cable N800 shows message
in the upper right that memory card is corrupted (external card gets corrupted,
internal card never gets corrupted). External card is not accessible through
File manager. After connecting to PC again, only one card is available through
My Computer. After taking memory card out of its slot and plugging it to the PC
through my card reader it seems to be fine, file system is OK, files are
accessible. 

Solution that worked for me: formatting external memory card by PC (FAT file
system). Sometimes additional reboot of N800 is required to recognize the card.
Comment 1 Eero Tamminen nokia 2007-02-06 14:57:17 UTC
So N800 complains that the card is corrupted, but PC opens it normally?
What Windows fsck tool reports on the memory card that N800 claimed to
be corrupted?
Comment 2 Vasily (reporter) 2007-02-06 17:42:27 UTC
Made some more testing (spent 2 hours!).

At first, now I can’t reproduce behavior described in my first post. N800
connects through USB to PC normally, as expected. 

Secondly, below is the step sequence I made (probably I should mention it right
now, that I can’t reproduce these steps either).

1. Insert removable memory card into N800 and format card with File manager.
File manager reports, that memory card is formatted. 
2. Click the Info icon at the bottom -> Storage memory available 0 kB.
3. Remove removable memory card -> File manager reports “No memory card
inserted” (that is OK), but now put the card back -> File manager still reports
that no memory card inserted (restarting the File manager and rebooting the
whole device doesn’t help)
4. Insert this card into the PC, open My computer, right click the card, choose
Properties. PC reports that file system is FAT, available space 1,91 Gt. Card is
OK and writable / readable.
5. In My computer, right click the card, choose Format, select file system: FAT,
click Start
6. After formatting insert the card into N800, it immediately reports “Memory
card available”. Checking in File manager proves that. Storage memory available
1,92 GB.
7. Format card with File manager. Formats OK. Storage memory available 1,92 GB.
8. Restart device. File manager reports “No memory card inserted”
9. Restart once again. Now File manager recognizes the card. Storage memory
available 1,92 GB.

As I have already mentioned, I can’t reproduce these steps. At the moment N800
functions perfectly. It seems that it improves with time, though I haven’t made
any configuration changes. As far as it works, I am satisfied.  Probably this
bug report is not a big help, since it is n not always reproducible, but I’ll
continue testing.
Comment 3 Jake Kunnari 2007-08-30 15:50:14 UTC

*** This bug has been marked as a duplicate of bug 1204 ***
Comment 4 Jake Kunnari 2007-11-30 11:29:56 UTC
Closing Duplicate bug reports. Please follow progress of issue from linked bug
report.