Bug 987 - Menu key should allow scrollup from the top most menu to go the last.
: Menu key should allow scrollup from the top most menu to go the last.
Status: RESOLVED WONTFIX
Product: Desktop platform
gtk
: 4.0
: All Maemo
: Medium enhancement with 5 votes (vote)
: ---
Assigned To: Karoliina T. Salminen
: Maemo QA (deprecated)
:
:
:
:
  Show dependency tree
 
Reported: 2007-01-28 07:27 UTC by Anuj Verma (Kevin)
Modified: 2009-11-18 18:33 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Anuj Verma (Kevin) (reporter) 2007-01-28 07:27:49 UTC
This is an enhancement to suggest for situations where soon after pressing the
menu key, user needs to roll down to the last item of the list. 

Currently this is not possible. Step to reproduce:
1. Launch any application, for e.g. Opera
2. after the application window appears, press the "menu key" (one above home)
3. Try to close the app window quickly, so press the "up key" to scroll down to
the last item in the menu list(close) 

Result: not possible
Workaround: use the "down key" instead
Comment 1 Tommi Komulainen nokia 2007-01-28 21:04:16 UTC
You can close a window by long press of the back/esc key.

Not having wrap-around in menus as suggested is explicitly specified as such,
similar to focus in treeviews. Not sure about the rationale.
Comment 2 Anuj Verma (Kevin) (reporter) 2007-01-29 14:49:45 UTC
(In reply to comment #1)
> You can close a window by long press of the back/esc key.
> 
> Not having wrap-around in menus as suggested is explicitly specified as such,
> similar to focus in treeviews. Not sure about the rationale.

Its good to know the long press function, but I guess for the rationale of this
issue, you've taken the given example wrongly. 

The suggested enhancement should be rational, where ever its about the any other
function even then the window_close.
Comment 3 Tommi Komulainen nokia 2007-01-29 18:05:11 UTC
I was referring to our current UI design which is intended not to wrap around.
I
can not recall the rationale for that decision, though.
Comment 4 Anuj Verma (Kevin) (reporter) 2007-01-29 18:11:52 UTC
(In reply to comment #3)
> I was referring to our current UI design which is intended not to wrap around. I
> can not recall the rationale for that decision, though.

Many thanks for your followup, I hope you can look into further as if you find
this any useful. 

Best Regards,
Comment 5 Roope Rainisto nokia 2007-01-30 11:16:05 UTC
Yes, this is currently intentional design to work like this, no wrapping in
menus. Meant to provide a safer and more controllable experience. 

The basic argument is that if the user long presses the scroll down key, he can
go to the end of the lists safely. 

This behaviour could certainly be improved, for instance by that scrolling like
this would stop at the end of the list, and then when pressing down again, it
would then wrap around to the first item. It's under consideration, but
unfortunately not in current plans to change, afaik. (Limited resources and all
that.)
Comment 6 Anuj Verma (Kevin) (reporter) 2007-02-04 19:44:03 UTC
(In reply to comment #5)
> Yes, this is currently intentional design to work like this, no wrapping in
> menus. Meant to provide a safer and more controllable experience. 
> 
> The basic argument is that if the user long presses the scroll down key, he can
> go to the end of the lists safely. 
> 
> This behaviour could certainly be improved, for instance by that scrolling like
> this would stop at the end of the list, and then when pressing down again, it
> would then wrap around to the first item. It's under consideration, but
> unfortunately not in current plans to change, afaik. (Limited resources and all
> that.)


Just to add a qoute Opera on N800 does the menu wraping, you might like to
experience such usage comfort with that before you are able to re-consider this
enhancement. 

Thanks
Comment 7 Roope Rainisto nokia 2007-02-05 10:37:52 UTC
Thanks for the comment, we'll check that issue.
Comment 8 Frantisek Dufka maemo.org 2007-03-13 11:32:06 UTC
I'd like to see thich changed too. It works like this on most other platforms
too (Windows, PalmOS). Even on my Nokia phone :-) I don't understand the
controllable and safer experience argument. How exactly it is safer or more
controllable? Can you provide use cases where it benefits to the user?

In fact it is less controllable for me because it is harder to get to items near
the end of the menu. By allowing it to wrap around you shorten the longest path
for accessing menu items to half.
Comment 9 Frantisek Dufka maemo.org 2007-03-13 13:33:02 UTC
Just found this
http://developer.gnome.org/doc/API/2.0/gtk/GtkSettings.html#GtkSettings--gtk-keynav-wrap-around
and when googling for gtk-keynav-wrap-around I see also some maemo pages so it
looks like it is already in process. Tried to put
gtk-keynav-wrap-around = 1
to /usr/share/themes/default/gtk-2.0/gtkrc on N800 but nothing changed so looks
like we're not there yet with current OS2007.
Comment 10 Roope Rainisto nokia 2007-03-15 10:43:21 UTC
Setting priority to enhancement. Adding CC.
Comment 11 Frantisek Dufka maemo.org 2007-04-24 22:16:44 UTC
(In reply to comment #9)
> Tried to put
> gtk-keynav-wrap-around = 1
> to /usr/share/themes/default/gtk-2.0/gtkrc on N800 but nothing changed so looks
> like we're not there yet with current OS2007.

Recently tried Sardine and it looks like this functionality is present in newer
gtk in Sardine and is turned on by default there. Let's hope it will make into
some production release.
Comment 12 Jason Carter 2007-07-18 17:26:06 UTC
Appears to have not been changed in the latest (4.2007.26-8) firmware.
Comment 13 Roope Rainisto nokia 2008-12-03 17:07:46 UTC
Wontfix, the design will be improved, but wrap-around is not a part of it
still.
Comment 14 Quim Gil nokia 2008-12-05 22:00:23 UTC
For those immediately unhappy, there are community hacks at
http://www.internettablettalk.com/forums/showthread.php?p=247130
Comment 15 Andre Klapper maemo.org 2008-12-06 20:57:51 UTC
(getting rid of "User interaction", hence changing component - this is a gtk+
issue)