Bug 9855 - (int163972/int-165785) Cannot "delete" (hide) fields (e.g. phone numbers) added by a Skype account
(int163972/int-165785)
: Cannot "delete" (hide) fields (e.g. phone numbers) added by a Skype account
Status: RESOLVED WONTFIX
Product: Contacts
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low enhancement with 4 votes (vote)
: ---
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-04-06 15:47 UTC by Chadi
Modified: 2011-01-18 15:33 UTC (History)
3 users (show)

See Also:


Attachments
The numbers that start with +961 are added by skype (107.86 KB, image/png)
2010-04-06 21:08 UTC, Chadi
Details
It is not there to delete it (102.12 KB, image/png)
2010-04-06 21:09 UTC, Chadi
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Chadi (reporter) 2010-04-06 15:47:32 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Add a skype user having put their mobile and/or home phones in their skype
account settings.
2. From the N900, connect to skype, and merge that contact with a contact of
your address book.
3. The phone numbers the user added on their skype will also be added as phone
numbers after merging.

EXPECTED OUTCOME:
Skype numbers which appear as normal callable numbers should be "deletable".
An option to disable that feature of importing numbers would be nice because..
(see below)

ACTUAL OUTCOME:
I already have this contact's numbers so they're duplicated and I can't delete
them (I can only delete the original ones associated with the contact).

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
irrrelevant

OTHER COMMENTS:
Just add that option to not import the numbers from skype, OR let me be able to
remove those numbers associated with skype (and that appear as numbers).

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/533.2 (KHTML, like Gecko) Chrome/5.0.342.8 Safari/533.2
Comment 1 Andre Klapper maemo.org 2010-04-06 18:36:14 UTC
Hi,

(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Add a skype user having put their mobile and/or home phones in their skype
> account settings.

So you manually set up a new contact? Can you please provide the exact steps,
click by click, to be able to reproduce this?

> ACTUAL OUTCOME:
> I can't delete them

So there is no way to edit that parameter of the contact, or what is the exact
behaviour?
Comment 2 Chadi (reporter) 2010-04-06 20:59:49 UTC
(In reply to comment #1)
> Hi,
> 
> (In reply to comment #0)
> > EXACT STEPS LEADING TO PROBLEM: 
> > 1. Add a skype user having put their mobile and/or home phones in their skype
> > account settings.
> 
> So you manually set up a new contact? Can you please provide the exact steps,
> click by click, to be able to reproduce this?
> 
Well, add a user from a computer, not on the N900. That particular user you add
has to specify their Mobile number in their profile info.

> > ACTUAL OUTCOME:
> > I can't delete them
> 
> So there is no way to edit that parameter of the contact, or what is the exact
> behaviour?
> 

Yes. There is no way to edit it. It is just there.

I will attach some screenshots.
Comment 3 Chadi (reporter) 2010-04-06 21:08:13 UTC
Created an attachment (id=2576) [details]
The numbers that start with +961 are added by skype
Comment 4 Chadi (reporter) 2010-04-06 21:09:31 UTC
Created an attachment (id=2577) [details]
It is not there to delete it
Comment 5 Bartosz Taudul 2010-04-06 23:12:57 UTC
Confirming. Note that "deleting" should actually be ignoring some data provided
by the Skype profile information. You can't delete information provided by
someone's else account data.
Comment 6 Chadi (reporter) 2010-04-07 21:15:34 UTC
(In reply to comment #5)
> Confirming. Note that "deleting" should actually be ignoring some data provided
> by the Skype profile information. You can't delete information provided by
> someone's else account data.
> 

Fine. Adding that feature to ignore skype numbers in the skype settings would
be nice.
Comment 7 Andre Klapper maemo.org 2010-04-22 17:51:32 UTC
"This is by design, and it's too late for changing this in Maemo5. Hence
WONTFIX for Maemo5."

Keeping this opened for Maemo6 and making it more generic as this does not only
cover phone numbers, but also other contact fields.
Comment 8 Andre Klapper maemo.org 2010-04-22 17:51:53 UTC
*** Bug 9467 has been marked as a duplicate of this bug. ***
Comment 9 Chadi (reporter) 2010-04-22 19:07:00 UTC
Why is it too late for Maemo5? Even though it is not critical, it is worth
fixing, and I find it totally pointless to have these numbers imported anyway.
I paid 600 bucks for my device and the least thing I want from it is to behave
properly. Please reconsider your decision. Thank you.
Comment 10 Andre Klapper maemo.org 2010-04-23 01:47:59 UTC
(In reply to comment #9)
> Why is it too late for Maemo5?

Because management decided so. Other stuff has higher priorities.
Comment 11 Andre Klapper maemo.org 2010-06-21 10:43:46 UTC
"This is also a behaviour that will exist in Harmattan (the software version
after Maemo5). Some services have details that cannot be edited."
Comment 12 Bartosz Taudul 2010-06-21 12:51:48 UTC
(In reply to comment #11)
> "This is also a behaviour that will exist in Harmattan (the software version
> after Maemo5). Some services have details that cannot be edited."
I think we have already came to the conclusion that you can't edit someone's
else profile and we now want a way to just hide some of them.

Reopening with adjusted summary.
Comment 13 Andre Klapper maemo.org 2010-06-21 12:56:21 UTC
I definitely prefer to have a separate request for just hiding them.
Comment 14 Chadi (reporter) 2010-06-30 13:24:04 UTC
(In reply to comment #13)
> I definitely prefer to have a separate request for just hiding them.
> 

Should I create another bug report for hiding those fields?
Comment 15 Andre Klapper maemo.org 2011-01-18 15:33:40 UTC
Internal comment:
"This is the behavioral that we will have in harmattan (the version after
Maemo5). Some services have details that cannot be edited. These protected
details will not be shown in the edit contact card view nor is the user able to
send the details in a vCard. 
These are service requirements and we cant do anything about it. setting as
WONTFIX"