Bug 9833 - maemo wiki does not allow image files to be replaced
: maemo wiki does not allow image files to be replaced
Status: VERIFIED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All All
: High major (vote)
: ---
Assigned To: Ferenc Szekely
: midgard@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2010-04-03 19:24 UTC by Ken Young
Modified: 2010-07-13 14:57 UTC (History)
2 users (show)

See Also:


Attachments
Image for the reproduction instructions in comment #3 (15.63 KB, image/jpeg)
2010-07-01 11:27 UTC, Andrew Flegg
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Ken Young (reporter) 2010-04-03 19:24:58 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. go to http://wiki.maemo.org/Orrery
2. log in
3. click on an image, for example OrreryMainMenu.png
4. Select "upload in new version of this file"
5. Upload a new version of the image
6. Refresh the page, and verify that the new image appears
7. Go back to http://wiki.maemo.org/Orrery, refresh, and verify the new
image appears as it should.
8. Roughly 1/2 hour later, the old image re-appears on the wiki page.
9. Return to http://wiki.maemo.org/Image:OrreryMainMenu.png, and examine all
versions of the file.   Now the original image is shown when each image is
selected - in other words the site will no longer display the newer version of
the image even though the newer version is listed, it has the correct
timestamp, the size differs from the original image file, etc.


EXPECTED OUTCOME:

Updated image is displayed in the wiki page

ACTUAL OUTCOME:

After about 1/2 hour, the image reverts back to the original version of the
file, ignoring the update.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

always, as far as I can tell.   I tried at least 10 times.   I also had another
individual try to replace the image file for me, and he saw the same behavior.

EXTRA SOFTWARE INSTALLED:

I'm using FIrefox.   The important thing to note is that the updated image file
*does* appear for a while - the update was successful.   It just reverts to the
original after about 1/2 hour.

OTHER COMMENTS:

Note - on the orrery wiki page, I have gotten around this problem by uploading
new versions of the images with different names, and changing the wiki text to
make it display the new images. 

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.18)
Gecko/2010020407 Red Hat/3.0.18-1.el4 Firefox/3.0.18
Comment 1 Andrew Flegg maemo.org 2010-04-03 20:07:25 UTC
Can confirm this, I've seen it with http://wiki.maemo.org/Image:Rga2.png and
http://wiki.maemo.org/Image:Mcc-andrew_flegg.jpg. They've now reverted to their
earlier versions, and you can see in the logs when I last updated them.

Note that the metadata for Image:Rag2.png has been updated, now meaning the
non-square image that was there before appears squashed. Note also the weird
information you can get in the "Revert" - it definitely looks like the DB is in
an odd state.

However, I've *not* seen this problem with
http://wiki.maemo.org/Image:Mcc-Graham_Cobb.jpg, which I also updated
yesterday.
Comment 2 Ferenc Szekely maemo.org 2010-06-30 19:26:17 UTC
Tested it here: http://wiki.maemo.org/User:Feri#Testing_.239833. Works for me.
Comment 3 Andrew Flegg maemo.org 2010-07-01 11:27:02 UTC
Nope, doesn't work for me:

STEPS TO REPRODUCE
0) Log in to wiki
1) Go to http://wiki.maemo.org/Image:Mcc-andrew_flegg.jpg
2) Click "Upload a new version of this file"
3) Select the attached file.
4) Add a summary "Testing bug #9833"
5) Check "Watch this page", leave "Ignore any warnings" unchecked.
6) Click "Upload file"
7) Click "Save" to overwrite

EXPECTED OUTCOME
Image is replaced with new image and stays there.

ACTUAL OUTCOME
Image is replaced, but 2 hours later reverts to the previous image.
Comment 4 Andrew Flegg maemo.org 2010-07-01 11:27:52 UTC
Created an attachment (id=2953) [details]
Image for the reproduction instructions in comment #3
Comment 5 Ferenc Szekely maemo.org 2010-07-12 14:15:29 UTC
I can not reproduce this bug. My 2nd test worked again:
http://wiki.maemo.org/User:Feri#Testing_.239833

I used an image with the same size as yours (256x156 px). The name of the image
was kept the same, overwriting went fine and it stayed there two hours later.

Dave, could you also please retest it?
Comment 6 Ferenc Szekely maemo.org 2010-07-12 14:18:17 UTC
> I used an image with the same size as yours (256x156 px). The name of the image

Mistake; image size was 256 x 256 pixels.
Comment 7 Andrew Flegg maemo.org 2010-07-12 14:43:43 UTC
(In reply to comment #5)
> I can not reproduce this bug. My 2nd test worked again:
> http://wiki.maemo.org/User:Feri#Testing_.239833

Reproduce it with the image in question! Is it a permissions issue on some kind
of distributed system?

> I used an image with the same size as yours (256x156 px). The name of the
> image was kept the same, overwriting went fine and it stayed there two
> hours later.

Debugging an issue without any knowledge of the system is tricky, but perhaps
there's a set of older images which are problematic and newly uploaded images
are OK?
Comment 8 Ferenc Szekely maemo.org 2010-07-12 15:24:04 UTC
Your image is now replaced with the maemo.org logo. Let's see it after 2 hours.
Comment 9 Ferenc Szekely maemo.org 2010-07-12 16:47:03 UTC
Damn.. Just realized that we have left a cron job running on the wiki server.
This script was rsyncing the images folder from the old server once an hour. It
was needed during the switchover, but we completely forgotten about it. Strange
too that the old maemo server is still up and running and we can access it.

I disabled the cron job, let's see what happens after an hour.
Comment 10 Ferenc Szekely maemo.org 2010-07-12 17:51:14 UTC
I think this issue is fixed now.
Comment 11 Andrew Flegg maemo.org 2010-07-13 14:57:31 UTC
Verified. My image seems to have updated - and stayed updated - now.