Bug 975 - (int-53084) Failure to dismount Memory Cards on MacBook/OSX
(int-53084)
: Failure to dismount Memory Cards on MacBook/OSX
Status: CLOSED FIXED
Product: Core
Kernel
: 3.0
: All other
: Medium normal with 3 votes (vote)
: 4.0
Assigned To: unassigned
: linux-kernel-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-01-27 10:52 UTC by Andy Mulhearn
Modified: 2008-12-06 16:13 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andy Mulhearn (reporter) 2007-01-27 10:52:21 UTC
When connected via USB Cable to an Apple MacBook, both internal and removable
cards are displayed in 
the finder allowing access to them.

When you eject the cards in finder, they initially dismount but then within two
or three seconds are 
remounted making it difficult to disconnect the N800.

To get round this you can eject both cards together and then immeditely
disconnect the USB cable from 
the N800. If you don't get it right though, you can posibly cause corruption on
the memory cards.

This does not occur on the N700.
Comment 1 Sean Luke 2007-02-26 06:50:29 UTC
This bug is very irritating -- it makes the N800 quite surprisingly hard to
work with when on a Mac.  
Please fix this as soon as possible.
Comment 2 Jake Kunnari 2007-03-14 15:44:17 UTC
Bug accepted.
Comment 3 Kimmo Hämäläinen nokia 2007-09-25 10:00:43 UTC
this was a kernel issue, I think it was fixed in the coming major release
Comment 4 Lou 2007-11-16 04:28:32 UTC
I have this same problem on the N800 and I believe I am on the latest release.
(OS 2007, version 4.2007.38-2). I am also on the latest Mac OS release
(Leopard). I do not have this problem with the same N800 on a Windows XP Pro
machine.

After succeeding in pulling the cable out at the right moment several times,
eventually I ended up with an SD card which the N800 thought was read-only.
This was fixed only by reformatting on a desktop.
Comment 5 Ryan Abel maemo.org 2007-11-18 20:02:25 UTC
Seems to be fixed under the N810's OS2008 firmware on my N800. My want to
change Target to 4.0.
Comment 6 Chester Andrews 2007-11-27 21:30:37 UTC
Confirmed bug fixed in Chinook. Nokia volumes do not remount after unmounting
them from Mac OS X
Comment 7 Jake Kunnari 2007-11-28 10:54:09 UTC
Closing Bug. Fixed and verified with OS2008.