Bug 9738 - Popup "Search complete" blocks view, not useful
: Popup "Search complete" blocks view, not useful
Status: RESOLVED FIXED
Product: Settings and Maintenance
Application manager
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-27 16:49 UTC by Jonas Kölker
Modified: 2010-03-31 19:01 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jonas Kölker (reporter) 2010-03-27 16:49:10 UTC
In Application Manager, when you search for packages and the results are ready,
you're shown a message "Search complete" for a little while.

This message blocks the view of the topmost application, and its coming and
going is distracting.

It also appears to serve no useful purpose: you're not presented with partial
search results or any indication of progress, so it's not likely you'll wonder
"gee, is it really done? I wish it would tell me".  The list of search results
tells you it's done.

Therefore, I think the application manager would be a better piece of software
if the message wasn't shown at all.

// Does Application Manager have super cow powers? ;-)
Comment 1 Andre Klapper maemo.org 2010-03-30 16:12:40 UTC
Hi Jonas,

can you please provide exact steps (click by click) to make it easy to
reproduce this? For future reference, using the bug template is highly welcome.
Comment 2 Jonas Kölker (reporter) 2010-03-30 17:04:58 UTC
Sure, here are some steps:

STEPS:
1. Open the Application Manager (*)
2. Click the bar in the top part of the screen where it says "Application
Manager"
3. In the pop-down menu, click the "Search" button
4. Type "todo" in the keyword field
5. Click the "Search" button
6. Wait a while

WHAT HAPPENS:
I am shown a list of search results, and (temporarily) a yellow pop-up bar
which says "Search Complete"

WHAT I WANT TO HAVE HAPPEN:
I am shown a list of search results and *no* pop-up bar.

REPRODUCIBILITY:
Always (I've tried _not_ reproducing it, and I have failed).
Comment 3 Andre Klapper maemo.org 2010-03-31 19:01:21 UTC
"Search" will not be available anymore from the title bar in the next public
update (PR1.2) because of bug 5388 being fixed.
I've tried your steps in a newer internal-only version and everything works as
expected.