Bug 9673 - (int-164695) Ad-Hoc Wifi with XP SP3 produces repeatable hard reboot
(int-164695)
: Ad-Hoc Wifi with XP SP3 produces repeatable hard reboot
Status: RESOLVED DUPLICATE of bug 7029
Product: Connectivity
WiFi
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified critical (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
: crash
:
:
  Show dependency tree
 
Reported: 2010-03-23 18:20 UTC by Andreas Bauer
Modified: 2010-04-22 13:03 UTC (History)
4 users (show)

See Also:


Attachments
Screen corruption after connection to Ad-Hoc Wifi (70.96 KB, image/png)
2010-03-23 18:21 UTC, Andreas Bauer
Details
Kernel Oops Log Wifi Ad-Hoc w. WinXP (21.95 KB, text/plain)
2010-04-04 06:28 UTC, Andreas Bauer
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Andreas Bauer (reporter) 2010-03-23 18:20:11 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
Requires: Windows XP SP3 Laptop connected to standard LAN (DSL Router, DHCP) by
100 Mbit/s Ethernet
1. Setup Ad-Hoc Wifi on XP, and bridge wireless interface to wired interface
2. Open N900 that was perfectly stable (uptime 2 days ...) and connect to said
Ad-Hoc Wifi

EXPECTED OUTCOME:

Being able to connect to the Ad-Hoc Wifi connection

ACTUAL OUTCOME:

Hard and sudden reboot, memory corruption (?)

The N900 does connect to the WIFI and does get an IP address on the ad-hoc
network (from the DSL router on the wired network). But soon after that the
connection stops working (ping does not return an answer).

Anywhere between 30s or 2 minutes later the device hard reboots suddenly
without warning. One time I saw pixel debris in the top status bar as if memory
corruption has happened (will upload a screenshot in a few minutes).

After several tries I was lucky to have enough time to start x-term. ifconfig
and route -n looked fine, but ping never came back with an answer. Seconds
later device rebooted again.

REPRODUCIBILITY:
10/10

EXTRA SOFTWARE INSTALLED:

mostly standard stuff, network related: openvpn, openssh

OTHER COMMENTS:

 - WEP or no encryption makes no difference
Comment 1 Andreas Bauer (reporter) 2010-03-23 18:21:28 UTC
Created an attachment (id=2506) [details]
Screen corruption after connection to Ad-Hoc Wifi
Comment 2 Lucas Maneos 2010-03-23 19:22:55 UTC
Thanks for the report.  It sounds a lot like bug 5712, but I hesitate to
resolve it as duplicate due to the severity.  Re-testing after an update with
the fix for that has been released would be very welcome.
Comment 3 Andreas Bauer (reporter) 2010-03-23 20:06:54 UTC
I just quick-read through the other bug - the symptoms are different. In my
case it takes only seconds, and then it is a sudden reboot. No warning. It
seemed a tad more sluggish, but this is highly subjective, as I had only
seconds to evaluate it.

Maybe one of the developpers involved that knows this stuff deeply can have a
look here and estimate if bug 5712 could possibly cause symptoms like I've
experienced or if this might be another bug.

Hard reboots are really ugly so this is why I set the priority to critical.
Comment 4 Lucas Maneos 2010-03-23 21:15:09 UTC
It would be useful if you could attach the kernel oops logs.  You can obtain
these with "sp-oops-extract /dev/mtd2".  Package sp-oops-extract can be found
in the tools repository, see
<http://wiki.maemo.org/Documentation/devtools/maemo5> for installation
instructions.
Comment 5 Andreas Bauer (reporter) 2010-04-04 06:28:26 UTC
Created an attachment (id=2568) [details]
Kernel Oops Log Wifi Ad-Hoc w. WinXP
Comment 6 Andreas Bauer (reporter) 2010-04-04 06:32:01 UTC
I am busy at the moment, and could only today find time for your recommended
additional trouble shooting.

After having a look into the oops file, it might indeed be related / same bug
as reported above, pending closer inspection by someone more involved than me.

Additional information: Laptop w. WinXP is Lenovo T61 with Intel Wifi.

Thank you.
Comment 7 Eero Tamminen nokia 2010-04-22 11:54:46 UTC
Both oopses are from rate_control_get_rate().  I think this could be duplicate
of bug 7029 which should be fixed in PR1.2.
Comment 8 Eero Tamminen nokia 2010-04-22 11:57:33 UTC
(In reply to comment #7)
> Both oopses are from rate_control_get_rate().  I think this could be duplicate
> of bug 7029 which should be fixed in PR1.2.

Bug 7029 is specific to your access point, not the operating system accessing
the device through it.

What's the exact model of your access point?
Comment 9 Andre Klapper maemo.org 2010-04-22 13:03:03 UTC
Seems to really be a dup of bug 7029.

*** This bug has been marked as a duplicate of bug 7029 ***