Bug 9628 - wlan0 still up after disconnecting from GPRS (wifi scanning interrupted), causing battery drain
: wlan0 still up after disconnecting from GPRS (wifi scanning interrupted), cau...
Status: UNCONFIRMED
Product: Connectivity
WiFi
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-03-19 23:25 UTC by Vincent Lefevre
Modified: 2010-08-30 15:10 UTC (History)
4 users (show)

See Also:


Attachments
syslog excerpt showing a "Scan failed, should not happen!" (13.72 KB, application/octet-stream)
2010-04-07 21:29 UTC, Vincent Lefevre
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Vincent Lefevre (reporter) 2010-03-19 23:25:21 UTC
SOFTWARE VERSION:
3.2010.02-8.002

EXACT STEPS LEADING TO PROBLEM: 
1. While having a GPRS connection, select "Internet connection".
2. Click on Disconnect before wifi AP's appear (not sure this was the cause).

EXPECTED OUTCOME:
wlan0 should be down.

ACTUAL OUTCOME:
ifconfig lists wlan0 as up.

REPRODUCIBILITY:
once (but see below)

OTHER COMMENTS:

I did not have the official (buggy) zz_static_ip_if_down script, but:

#!/bin/sh
#
# See https://bugs.maemo.org/show_bug.cgi?id=6615#c119

set -e

if [ "$MODE" != stop ]; then
    exit 0
fi

if [ "$ICD_CONNECTION_TYPE" = WLAN_INFRA ] || \
   [ "$ICD_CONNECTION_TYPE" = WLAN_ADHOC ]; then
    ifconfig $IFACE down
fi

However I don't think this script is the cause. The syslog information is
particularly interesting. See the "Scan failed, should not happen!" below.
Moreover in syslog information, I normally get "wl1251: down" after a scanning
when I do not connect by wifi. Here, it didn't happen.

The "Scan failed, should not happen!" message and the lack of "wl1251: down"
had occurred two other times since March 3. But I didn't have the time to
notice a battery drain due to another scanning several minutes later in both
cases.

Syslog information:

Mar 19 18:30:43 Nokia-N900-02-8 mauku[5295]: GLIB CRITICAL ** Gdk -
gdk_window_process_updates: assertion `window != NULL' failed
Mar 19 18:31:09 Nokia-N900-02-8 kernel: [107139.819305] wl1251: 151 tx blocks
at 0x3b788, 35 rx blocks at 0x3a780
Mar 19 18:31:09 Nokia-N900-02-8 kernel: [107139.835144] wl1251: firmware booted
(Rev 4.0.4.3.7)
Mar 19 18:31:09 Nokia-N900-02-8 wlancond[1130]: Scan issued
Mar 19 18:31:09 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: [GPRS] Ending
the scan (success)
Mar 19 18:31:11 Nokia-N900-02-8 iap_conndlg 2.76.1+0m5[1102]: ICd claims we are
connected, but refuses to provide state for the connected IAPs. We report the
current state
Mar 19 18:31:13 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x43580, NRJWEB, GPRS, 2)
Mar 19 18:31:13 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 2, 0) count 1
Mar 19 18:31:13 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 2, 0) still connected (1)
Mar 19 18:31:13 Nokia-N900-02-8 [1534]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xf8980, NRJWEB, GPRS, 2)
Mar 19 18:31:13 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x43580, NRJWEB, GPRS, 2)
Mar 19 18:31:13 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 2, 0) count 1
Mar 19 18:31:13 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 2, 0) still connected (1)
Mar 19 18:31:13 Nokia-N900-02-8 location-proxy[1132]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x27c18, NRJWEB, GPRS, 2)
Mar 19 18:31:13 Nokia-N900-02-8 mission-control[1023]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x39810, NRJWEB, GPRS, 2)
Mar 19 18:31:13 Nokia-N900-02-8 alarmd[958]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x31418, NRJWEB, GPRS, 2)
Mar 19 18:31:13 Nokia-N900-02-8 mce[737]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x30020, NRJWEB, GPRS, 2)
Mar 19 18:31:14 Nokia-N900-02-8 [1062]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xa45e0, NRJWEB, GPRS, 2)
Mar 19 18:31:14 Nokia-N900-02-8 iap_conndlg 2.76.1+0m5[1102]: Unable to
activate connection, canceling the dialog
Mar 19 18:31:14 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: srv type ''
unknown
Mar 19 18:31:14 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS:
context0 disconnecting from <internet68>
Mar 19 18:31:17 Nokia-N900-02-8 wlancond[1130]: Scan failed, should not happen!
Mar 19 18:31:17 Nokia-N900-02-8 wlancond[1130]: Scan results (0 APs) to :1.91
Mar 19 18:31:20 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS:
context0 ERROR 0x4, stage = 26, cause = 0x00, pipe error = 00:00:00
Mar 19 18:31:20 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS:
context0 disconnected from <internet68>: Connection timed out, error=0x40000
Mar 19 18:31:20 Nokia-N900-02-8 dnsmasq[1146]: failed to access
/var/run/resolv.conf.gprs: No such file or directory
Mar 19 18:31:20 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS:
context0 deleted
Mar 19 18:31:20 Nokia-N900-02-8 kernel: [107150.963256] gprs0: detached
Mar 19 18:31:20 Nokia-N900-02-8 ke_recv[1299]: device_removed:2638: udi:
/org/freedesktop/Hal/devices/net_computer
Mar 19 18:31:20 Nokia-N900-02-8 mission-control[1023]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x39810, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 alarmd[958]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x31418, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 mce[737]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x30020, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 location-proxy[1132]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x27c18, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x43580, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 1, 0) count 1
Mar 19 18:31:20 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 1, 0) disconnected
Mar 19 18:31:20 Nokia-N900-02-8 browserd[3827]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 1, 0) not connected (0)
Mar 19 18:31:20 Nokia-N900-02-8 [1534]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xf8980, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x43580, NRJWEB, GPRS, 1)
Mar 19 18:31:20 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 1, 0) count 1
Mar 19 18:31:20 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 1, 0) disconnected
Mar 19 18:31:20 Nokia-N900-02-8 browserd[1493]: GLIB DEBUG default -
connection_cb(0x43580, NRJWEB, GPRS, 1, 0) not connected (0)
Mar 19 18:31:20 Nokia-N900-02-8 [1062]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xa45e0, NRJWEB, GPRS, 1)
Mar 19 18:31:24 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: [GPRS]
Disconnect timeout expired, allowing connections
Mar 19 18:31:25 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS: service
suspended, status=3
Mar 19 18:31:32 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS:
detached from GPRS network, detach type = 0x01, cause=0xf5
Mar 19 18:31:49 Nokia-N900-02-8 kernel: [107179.834991] slide (GPIO 71) is now
closed
Mar 19 18:31:49 Nokia-N900-02-8 ke_recv[1299]: prop_modified:1889: udi
/org/freedesktop/Hal/devices/platform_slide modified button.state.value
Comment 1 ext-jason.rudd@nokia.com nokia 2010-03-22 16:37:12 UTC
I have investigated this log and it does apparently show some misbehavior,
however it leaves me with more questions than answers. I am unable to reproduce
the behavior myself. Could I ask you to run the following please and post the
lof if you manage to reproduce this.

gconftool-2 --set --type int
'/system/osso/connectivity/IAP/wlancond_debug_level' '2'

It is possible that your script (while syntactically and semantically correct)
is not working as you might expect, this may have created a situation whereby
the interface is in a strange state. I cannot remember the particulars, but
there was a reason we left it the way it is.

Whether the script or not, the net result is not correct, with the extending
logging it may produce some clearer information.

Assuming since last reboot, could you provide some further information:
When the error occurred were you in range of WiFi APs?
If so, had you scanned these APs prior to the problem occurring?

Had you already been connected to a WiFi AP?
If so, was it static or dynamic IP?

Thank you
Comment 2 Vincent Lefevre (reporter) 2010-03-23 00:17:23 UTC
(In reply to comment #1)
> gconftool-2 --set --type int
> '/system/osso/connectivity/IAP/wlancond_debug_level' '2'

Done.

> It is possible that your script (while syntactically and semantically correct)
> is not working as you might expect, this may have created a situation whereby
> the interface is in a strange state.

Well, I installed the script on March 19, the night before the problem
occurred.

But for the other two occurrences of the "Scan failed, should not happen!"
message and lack of "wl1251: down", my script wasn't installed yet.

> I cannot remember the particulars, but there was a reason we left it the way
> it is.

I'd like to know why. There's a clear syntax error. Perhaps the side effect is
that it solves some problem because the condition is always false, but in such
a case, it would be better to remove the condition. Anyway, the script doesn't
seem to be the cause.

> Assuming since last reboot, could you provide some further information:
> When the error occurred were you in range of WiFi APs?

I know that at this location there were normally WiFi APs, but AFAIK, when I
clicked on Disconnect, none of them was seen yet.

> If so, had you scanned these APs prior to the problem occurring?

I was connected via gprs0, and the N900 automatically initiate a WiFi scanning
when I want to disconnect via the menu -> Internet connection.

> Had you already been connected to a WiFi AP?

Yes, a 40 minutes earlier. Here are other excerpts from the log:

[...]
Mar 19 17:52:39 Nokia-N900-02-8 EAP[4946]: EAP 2.0.37+0m5 quitting.
Mar 19 17:52:39 Nokia-N900-02-8 dnsmasq[1146]: failed to access
/var/run/resolv.
conf.wlan0: No such file or directory
Mar 19 17:52:40 Nokia-N900-02-8 kernel: [104830.670959] wl1251: 151 tx blocks
at
 0x3b788, 35 rx blocks at 0x3a780
Mar 19 17:52:40 Nokia-N900-02-8 kernel: [104830.671386] wl1251: firmware booted 
(Rev 4.0.4.3.7)
Mar 19 17:52:40 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: ipv4 has not
c
onfigured interface 'wlan0'
Mar 19 17:52:40 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: no module or
s
cript found to use pid 5044
Mar 19 17:52:40 Nokia-N900-02-8 kernel: [104830.796020] wl1251: down
[...]
Mar 19 17:57:42 Nokia-N900-02-8 wlancond[1130]: Country changed to: 0
[...]
Mar 19 18:20:44 Nokia-N900-02-8 wlancond[1130]: Device country: 208
[...]
Mar 19 18:20:45 Nokia-N900-02-8 kernel: [106516.264678] wl1251: 151 tx blocks
at 0x3b788, 35 rx blocks at 0x3a780
Mar 19 18:20:45 Nokia-N900-02-8 kernel: [106516.280242] wl1251: firmware booted
(Rev 4.0.4.3.7)
Mar 19 18:20:45 Nokia-N900-02-8 wlancond[1130]: Scan failed
Mar 19 18:20:45 Nokia-N900-02-8 kernel: [106516.414306] wl1251: down
Mar 19 18:20:46 Nokia-N900-02-8 kernel: [106516.905273] wl1251: 151 tx blocks
at 0x3b788, 35 rx blocks at 0x3a780
Mar 19 18:20:46 Nokia-N900-02-8 kernel: [106516.920898] wl1251: firmware booted
(Rev 4.0.4.3.7)
Mar 19 18:20:46 Nokia-N900-02-8 wlancond[1130]: Scan failed
Mar 19 18:20:46 Nokia-N900-02-8 kernel: [106517.079925] wl1251: down
Mar 19 18:20:46 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: [GPRS] Ending
the scan (success)
Mar 19 18:20:47 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: connecting
iap 0x43e38 in state ICD_IAP_STATE_SCRIPT_PRE_UP: interface is '(null)'
Mar 19 18:20:48 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: connecting
iap 0x43e38 in state ICD_IAP_STATE_LINK_POST_UP: interface is ''
Mar 19 18:20:48 Nokia-N900-02-8 iap_conndlg 2.76.1+0m5[1102]: pending list
called, but list NULL
Mar 19 18:20:48 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: received
'com.nokia.icd_ui.passwd' (sssb) request is not recognized
Mar 19 18:20:48 Nokia-N900-02-8 icd2 0.87+fremantle6.1+0m5[1209]: connecting
iap 0x43e38 in state ICD_IAP_STATE_IP_UP: interface is ''
Mar 19 18:20:48 Nokia-N900-02-8 cellular: csd[746]: com.nokia.csd.GPRS:
context0 connecting to <internet68>
Mar 19 18:20:48 Nokia-N900-02-8 kernel: [106518.892578] gprs0: attached
[...]

then, no occurrence of wlan or wl1251 until:

Mar 19 18:31:09 Nokia-N900-02-8 kernel: [107139.819305] wl1251: 151 tx blocks
at 0x3b788, 35 rx blocks at 0x3a780
Mar 19 18:31:09 Nokia-N900-02-8 kernel: [107139.835144] wl1251: firmware booted
(Rev 4.0.4.3.7)
Mar 19 18:31:09 Nokia-N900-02-8 wlancond[1130]: Scan issued

already mentioned.

> If so, was it static or dynamic IP?

static
Comment 3 Vincent Lefevre (reporter) 2010-03-23 00:41:24 UTC
Concerning the 3 problems:

Mar  4 10:29:48 - wlancond[1108]: Scan issued
Mar  4 10:29:48 - [GPRS] Ending the scan (success)
Mar  4 10:29:57 - wlancond[1108]: Scan failed, should not happen!
Mar  4 10:29:59 - gprs0: attached

Mar  9 19:03:47 - wlancond[1108]: Scan issued
Mar  9 19:03:47 - [GPRS] Ending the scan (success)
Mar  9 19:03:49 - gprs0: attached
Mar  9 19:03:56 - wlancond[1108]: Scan failed, should not happen!

Mar 19 18:31:09 - wlancond[1130]: Scan issued
Mar 19 18:31:09 - [GPRS] Ending the scan (success)
Mar 19 18:31:17 - wlancond[1130]: Scan failed, should not happen!
Mar 19 18:31:20 - gprs0: detached

In the other cases, when I have a "Scan issued" followed by a "[GPRS] Ending
the scan", I also have: "Scan results ready -- scan active".
Comment 4 ext-jason.rudd@nokia.com nokia 2010-03-23 11:32:15 UTC
Thanks Vincent, what a great bug report.

Sadly we don not have enough to identify the problem as yet, but I now have
more information to try and reproduce it. I have seen one or two of the scan
failures in the past, but not as many as you are seeing on the one device.
Usually there are associated messages from the driver, which do no seem to be
emitted here.

We are hitting this condition because the scan is timing out.
Mar 19 18:31:17 Nokia-N900-02-8 wlancond[1130]: Scan failed, should not happen!

But the logic of the code should call ioctl to get the interface state and
again set it down. I see no errors being emitted for these two ioctl calls.

I will continue to try and reproduce the problem, if you see it again yourself
please post the logs, now you have wlancond debugging turned on it should give
a clearer picture.
Comment 5 Venomrush 2010-03-23 14:50:55 UTC
Similar issue to bug 9101?
Comment 6 ext-jason.rudd@nokia.com nokia 2010-03-23 16:21:20 UTC
Yes this look very similar to 9101, but there we can see the diver is
misbehaving (the Power save messages). Here the wlancond appears to have lost
communication with the kernel, at least for the scan and the ioctl to put the
interface down.
Comment 7 Andre Klapper maemo.org 2010-04-07 20:17:45 UTC
Jason: Do you need an internal copy of this issue?
Comment 8 Vincent Lefevre (reporter) 2010-04-07 21:29:28 UTC
Created an attachment (id=2588) [details]
syslog excerpt showing a "Scan failed, should not happen!"

Looking at syslog information, I got a "Scan failed, should not happen!"
message yesterday. No battery drain, because wl1251 went down a short time
after.

In case you're wondering, I had added

logger "zz_static_ip_if_down $ICD_CONNECTION_TYPE / $IFACE"

to /etc/network/if-post-down.d/zz_static_ip_if_down, hence the messages in
syslog.
Comment 9 Andre Klapper maemo.org 2010-05-03 15:37:31 UTC
Jason: Do you need an internal copy of this issue?
Comment 10 Andre Klapper maemo.org 2010-06-03 18:32:52 UTC
Does this still happen in 10.2010.19-1?
Comment 11 Vincent Lefevre (reporter) 2010-06-16 19:39:43 UTC
I haven't had the time to upgrade yet (in case something goes wrong and I need
to reflash -- I hope to find some time next week-end), but with
3.2010.02-8.002, the last time the problem occurred was on May 23 (still
according to syslog information).
Comment 12 Vincent Lefevre (reporter) 2010-07-18 18:18:23 UTC
With 10.2010.19-1, I got a "Scan failed, should not happen!" message in
/var/log/syslog on July 14, 03:35:42, but "wlan0 is DOWN" and "w11251: down"
immediately after. So, the battery drain problem may be solved (however I can
be sure only after a few more months). But I don't know whether the "Scan
failed..." error can be seen as normal.
Comment 13 Vincent Lefevre (reporter) 2010-08-30 14:34:11 UTC
Other scan failed messages...

[...]
Aug 10 18:22:57 Nokia-N900-02-8 cellular: csd[741]: com.nokia.csd.GPRS:
context0 connected to <internet68>: type=IP iface=<gprs0> IP=<10.189.57.106>
DNS=<172.20.2.39>,<172.20.2.10>
Aug 10 18:22:57 Nokia-N900-02-8 dnsmasq[1179]: failed to access
/var/run/resolv.conf.wlan0: No such file or directory
Aug 10 18:22:57 Nokia-N900-02-8 dnsmasq[1179]: reading
/var/run/resolv.conf.gprs
Aug 10 18:22:57 Nokia-N900-02-8 dnsmasq[1179]: using nameserver 172.20.2.10#53
Aug 10 18:22:57 Nokia-N900-02-8 dnsmasq[1179]: using nameserver 172.20.2.39#53
Aug 10 18:22:57 Nokia-N900-02-8 dnsmasq[1179]: read /etc/hosts - 1 addresses
Aug 10 18:22:57 Nokia-N900-02-8 icd2 0.87+fremantle9+0m5[1214]: connecting iap
0x4fc50 in state ICD_IAP_STATE_IP_UP: interface is ''
Aug 10 18:22:57 Nokia-N900-02-8 icd2 0.87+fremantle9+0m5[1214]: srv type ''
unknown
Aug 10 18:22:57 Nokia-N900-02-8 [1099]: Unknown state 15 received from ICd2
Aug 10 18:22:58 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.icd.status_changed
Aug 10 18:22:58 Nokia-N900-02-8 last message repeated 3 times
Aug 10 18:23:01 Nokia-N900-02-8 mauku[10655]: GLIB CRITICAL ** Gdk -
gdk_window_process_updates: assertion `window != NULL' failed
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Scan failed, should not happen!
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Sending empty results
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Scan results (0 APs) to :1.88
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Wlancond scan change,
old_state: SCANNING, new_state: SCAN_IDLE
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: wlan0 is DOWN
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Wlancond state change,
old_state: WLAN_INITIALIZED_FOR_SCAN, new_state: WLAN_NOT_INITIALIZED
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.icd.status_changed
Aug 10 18:23:01 Nokia-N900-02-8 last message repeated 7 times
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.wlancond.request.set_powersave
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Received set_powersave
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: wlan0 is DOWN
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: Wlancond state change,
old_state: WLAN_NOT_INITIALIZED, new_state: WLAN_NOT_INITIALIZED
Aug 10 18:23:01 Nokia-N900-02-8 wlancond[1148]: WLAN powersave on
Aug 10 18:23:01 Nokia-N900-02-8 kernel: [108424.133361] wl1251: down
Aug 10 18:23:01 Nokia-N900-02-8 icd2 0.87+fremantle9+0m5[1214]: disconnect
requested for WLAN_INFRA/5000521/fc4037b0-f507-40a2-a675-765a8b678e5c, but no
matching IAP
[...]
Aug 17 18:30:21 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.icd.status_changed
Aug 17 18:30:22 Nokia-N900-02-8 last message repeated 7 times
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.wlancond.request.scan
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Received scan
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Got scan request from :1.88
Aug 17 18:30:22 Nokia-N900-02-8 kernel: [58321.709075] wl1251: 151 tx blocks at
0x3b788, 35 rx blocks at 0x3a780
Aug 17 18:30:22 Nokia-N900-02-8 kernel: [58321.724792] wl1251: firmware booted
(Rev 4.0.4.3.7)
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: wlan0 is UP
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Wlancond state change,
old_state: WLAN_NOT_INITIALIZED, new_state: WLAN_INITIALIZED
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Wlancond state change,
old_state: WLAN_INITIALIZED, new_state: WLAN_INITIALIZED_FOR_SCAN
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Wlancond scan change,
old_state: SCAN_IDLE, new_state: SCANNING
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Scan issued
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.icd.status_changed
Aug 17 18:30:22 Nokia-N900-02-8 last message repeated 3 times
Aug 17 18:30:22 Nokia-N900-02-8 icd2 0.87+fremantle9+0m5[1214]: [GPRS] Ending
the scan (success)
Aug 17 18:30:22 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.icd.status_changed
Aug 17 18:30:22 Nokia-N900-02-8 last message repeated 3 times
Aug 17 18:30:24 Nokia-N900-02-8 iap_conndlg 2.86+0m5[1143]: ICd claims we are
connected, but refuses to provide state for the connected IAPs. We report the
current state
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Scan failed, should not happen!
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Sending empty results
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Scan results (0 APs) to :1.88
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Wlancond scan change,
old_state: SCANNING, new_state: SCAN_IDLE
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: wlan0 is DOWN
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Wlancond state change,
old_state: WLAN_INITIALIZED_FOR_SCAN, new_state: WLAN_NOT_INITIALIZED
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.icd.status_changed
Aug 17 18:30:30 Nokia-N900-02-8 last message repeated 7 times
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Received
com.nokia.wlancond.request.set_powersave
Aug 17 18:30:30 Nokia-N900-02-8 kernel: [58330.092407] wl1251: down
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Received set_powersave
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: wlan0 is DOWN
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: Wlancond state change,
old_state: WLAN_NOT_INITIALIZED, new_state: WLAN_NOT_INITIALIZED
Aug 17 18:30:30 Nokia-N900-02-8 wlancond[1148]: WLAN powersave on
Aug 17 18:30:30 Nokia-N900-02-8 icd2 0.87+fremantle9+0m5[1214]: disconnect
requested for WLAN_INFRA/5000521/fc4037b0-f507-40a2-a675-765a8b678e5c, but no
matching IAP
[...]
Comment 14 Andre Klapper maemo.org 2010-08-30 14:38:20 UTC
(In reply to comment #12)
> the battery drain problem may be solved (however I can be sure only after a 
> few more months). 

==> moreinfo

> "Scan failed..."

Please file a separate report for this.
Comment 15 Vincent Lefevre (reporter) 2010-08-30 15:10:43 UTC
(In reply to comment #14)
> > "Scan failed..."
> 
> Please file a separate report for this.

Bug 11218.

Concerning the battery drain problem, I haven't noticed any since May 23.