Bug 9621 - Cannot perform a new search after an initial search in Uninstall section
: Cannot perform a new search after an initial search in Uninstall section
Status: CLOSED FIXED
Product: Settings and Maintenance
Application manager
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-19 15:17 UTC by Robert Andrzejuk
Modified: 2010-05-25 18:42 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Robert Andrzejuk (reporter) 2010-03-19 15:17:56 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Bring up the Application Manager.
2. Choose to Uninstall.
3. Open menu by tapping on title bar
4. Choose search
5. Type in search string (I type in "Ad" - finds at least adblock)
   - displays OK results
6. Type in search string which does not contain text from (5.) (I used
"alpine")

EXPECTED OUTCOME:
Should only display from LAST search result (6.) - (alpine)

ACTUAL OUTCOME:
List is not filtered.
All installed packages are displayed.

REPRODUCIBILITY:
always.

EXTRA SOFTWARE INSTALLED:
alpine - A Hildon theme
AdBlock Plus

and others ...

OTHER COMMENTS:
-

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1;
Trident/4.0; BES_UA; WHITE_UA; InfoPath.1; BES_UA; WHITE_UA)
Comment 1 Venomrush 2010-03-19 21:59:48 UTC
Confirming.

All searches after the initial search failed, only return full list of
packages.

Only seem to apply for Uninstall only.
Comment 2 Andre Klapper maemo.org 2010-03-30 19:42:50 UTC
"Search" will not be available anymore from the title bar in the next public
update (PR1.2) because of bug 5388 being fixed.
I've tried your steps in a newer internal-only version and everything works as
expected.
Comment 3 Venomrush 2010-05-25 18:42:45 UTC
Confirm fixed in PR1.2

Note original test case no longer valid as there is no 'Search' option.
You can now type the application directly instead.