Bug 957 - N800 fails to boot
: N800 fails to boot
Status: RESOLVED FIXED
Product: System software
File system
: unspecified
: All All
: Medium major with 1 vote (vote)
: ---
Assigned To: Maemo QA (deprecated)
: file-system-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2007-01-20 18:59 UTC by Clive Oldfield
Modified: 2008-12-06 16:49 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Clive Oldfield (reporter) 2007-01-20 18:59:39 UTC
Latest 2.2006-51.6 firmware, second time this has happened in first week of 
use. Using normally (email/browsing), then shutdown normally using power 
button. Then fails to reboot when turned on. 'NOKIA' on white background shown 
for 30seconds, then blanks, then 'NOKIA' again. No progress, no progress bar, 
no icons. Repeats forever. Only way to halt is to pull the battery. Connecting 
charger fails to display 'Charging icon'.
Reflashing first time was successful to restore unit operation.
Since first reflashing, then installed:-
MediaPlayer
osso-xterm 0.13
configured Email for POP3 account and IMAP account
1GB SD card Internal, 128MB Virtual Memory
1GB SD Card External
Comment 1 Clive Oldfield (reporter) 2007-01-20 19:00:28 UTC
Follow thread at http://www.internettablettalk.com/forums/showthread.php?t=4160
Comment 2 Jakub Pavelek nokia 2007-01-22 10:46:42 UTC
*** Bug 958 has been marked as a duplicate of this bug. ***
Comment 3 Tor 2007-01-22 13:13:38 UTC
(In reply to comment #0)
I have the same software version. My unit is made in Finland.
I noticed on the second day that it would not boot (as described by OP).
The first time it helped to remove the battery for 1 minute. This did
not resolve the problem the next times this happened, however it always
works to remove the internal SD card (incidentally I'm using the micro-SD
card that came with the unit). The card can be replaced after boot-up.
I have used the card only for the 'backup' function.

In short:
- Fails to boot if there is an internal SD card mounted (contains backup only)
- Consistently boots if there is no internal SD card installed
- Occasionally it will boot (but not always) if the battery is removed for a 
minute, even with the card installed
- Software version: 2.2006.51-6
- Unit: Made in Finland
Comment 4 Clive Oldfield (reporter) 2007-01-22 16:48:45 UTC
I can confirm I tried removing the internal/external 1GB SD cards and removing 
the battery for some time on both occasions. Unit still failed to boot and 
required reflashing to restore operation. My unit says 'Made in Korea' inside 
the battery door.
Comment 5 Jakub Pavelek nokia 2007-01-24 14:20:02 UTC
Can you check how much is the internal storage full? 

This might be related to a mis-behaved application filling the internal memory
up so much that the filesystem causes continuous reboots.

Should not have anything to do with internal SD, that does not get involved in
boot at any point.
Comment 6 Clive Oldfield (reporter) 2007-01-24 18:21:44 UTC
How do I check the internal storage after the failure happens? Reflashing is 
the only fix at that point - there is no UI. I personally did not create lots 
of files in the internal memory, just installed the two apps.
To date, I have not had a further failure without osso-xterm 0.13 installed. I 
will try and recreate with that version.
Comment 7 Tor 2007-01-27 21:14:16 UTC
(In reply to comment #5)
I should mention that in my version of the problem (comment #1) there's no 
reboot loop, it simply doesn't boot - it stays in the white Nokia screen until 
it switches off (no progress bar). And stays off. I try to boot it again with 
the switch. I don't have to reflash. So there may be two different boot 
problems around, at the end of the day (for reference: My unit is m.i. Finland)

For me, there are no issues with internal full flash etc.  And although the 
boot problem is not happening all the time (some days it _will_ boot, 
repeatedly, with internal card installed), on the days when it won't boot it 
won't boot, consistently, and likewise it will consistenly boot _if_ the 
internal card is removed.  So I don't immediately buy into that the internal 
card isn't involved somehow.
Comment 8 Neil MacLeod maemo.org 2007-01-31 13:48:13 UTC
See also bug #999, which is probably a duplicate of this bug.
Comment 9 Adam Vazquez 2007-02-01 07:29:30 UTC
This problem is more of a corruption of a data structure used in the Linux OS
and the enhanced use of persistant flash in the Nokia N800. 

A suggestion until the solution is found: add some code in the Home/USB routine
so after holding the buttons for a period of five seconds, you can jump to a
minor menu to either wipe the persistant flash clean to a pristine state/ do a
RAMTEST/ or run a simple monitor. 

Adam Vazquez
Comment 10 Eero Tamminen nokia 2007-02-06 15:23:47 UTC
(In reply to comment #7)
> I should mention that in my version of the problem (comment #1) there's no 
> reboot loop, it simply doesn't boot - it stays in the white Nokia screen until 
> it switches off (no progress bar). And stays off. I try to boot it again with 
> the switch. I don't have to reflash. So there may be two different boot 
> problems around, at the end of the day (for reference: My unit is m.i.
> Finland)

There's a potential reason found for this.  In the case there have been earlier
>=10 consecutive reboots, the device doesn't clear the reboot count ever and 
thinks that an error has occured too often in a row.  As a result it always
powers the device off.

If this is the cause of the bug, enabling the R&D mode (where this check is
not done) with flasher should allow the device to boot up completely.


> For me, there are no issues with internal full flash etc.  And although the 
> boot problem is not happening all the time (some days it _will_ boot, 
> repeatedly, with internal card installed), on the days when it won't boot it 
> won't boot, consistently, and likewise it will consistenly boot _if_ the 
> internal card is removed.  So I don't immediately buy into that the internal 
> card isn't involved somehow.
>
> I can confirm I tried removing the internal/external 1GB SD cards and
> removing the battery for some time on both occasions. Unit still failed
> to boot and required reflashing to restore operation.

In case these are different issues:
- Did you have low charge in the battery?
- If you fsck the MMC/SD card, does that report any errors with FAT filesystem?
  The card is mounted so late in the bootup process that it's very unlikely
  to be able to trigger this, but I would just like to be able to rule this
  possibility out, so please test it...
- Could you give also exact contents ("ls -laR <dir>") of the card and
  the exact model, manufactorer etc for it?
Comment 11 Daniel Stone nokia 2007-02-28 23:23:55 UTC
the infinite-reboot-loop has been fixed, and the fix will be available with the
next firmware release.
Comment 12 Jake Kunnari 2007-03-14 12:40:26 UTC
Fis is in next firmaware update
Comment 13 Eero Tamminen nokia 2007-04-11 15:48:46 UTC
> Latest 2.2006-51.6 firmware, second time this has happened in first week of 
> use. Using normally (email/browsing), then shutdown normally using power 
> button. Then fails to reboot when turned on. 'NOKIA' on white background shown 
> for 30seconds, then blanks, then 'NOKIA' again. No progress, no progress bar,
> no icons. Repeats forever.

This was most likely an issue in the JFFS2 kernel driver, it kept device too
busy at bootup while doing garbage cleaning so the device HW watchdog rebooted
the device (the device should also shutdown after 10 successive reboots) which 
is indeed fixed in the latest release.

This was most likely to happen after a lot of data was written to and removed
from the device, but the Flash was left quite full when reboot was done.
Comment 14 Eero Tamminen nokia 2007-04-24 11:49:09 UTC
Should be fixed in latest release.  QA?
Comment 15 Jake Kunnari 2007-04-24 12:39:28 UTC
Fixed in IT OS3.2007.10-7. See comment #11
Comment 16 Clive Oldfield (reporter) 2007-08-28 17:20:02 UTC
This failure mode appears the same as an issue I'm having with 770 with
3.2006.49-2. 
Has this fix been implemented in the latest Nokia 770 release?
Comment 17 Clive Oldfield (reporter) 2007-08-28 17:23:59 UTC
(In reply to comment #13)
> > Latest 2.2006-51.6 firmware, second time this has happened in first week of 
> > use. Using normally (email/browsing), then shutdown normally using power 
> > button. Then fails to reboot when turned on. 'NOKIA' on white background shown 
> > for 30seconds, then blanks, then 'NOKIA' again. No progress, no progress bar,
> > no icons. Repeats forever.
> This was most likely an issue in the JFFS2 kernel driver, it kept device too
> busy at bootup while doing garbage cleaning so the device HW watchdog rebooted
> the device (the device should also shutdown after 10 successive reboots) which 
> is indeed fixed in the latest release.
> This was most likely to happen after a lot of data was written to and removed
> from the device, but the Flash was left quite full when reboot was done.

Can the "garbage cleaning" be initiated manually using xterm before shutting
down, therefore avoiding the HW watchdog issue during bootup?
Comment 18 Eero Tamminen nokia 2007-08-28 18:07:03 UTC
> Can the "garbage cleaning" be initiated manually using xterm before shutting
> down, therefore avoiding the HW watchdog issue during bootup?

No it's completely internal to the kernel JFFS2 file system.