Bug 9566 - (int-155955) Browser doesn't stop flash or another plugins while device is locked
(int-155955)
: Browser doesn't stop flash or another plugins while device is locked
Status: RESOLVED FIXED
Product: Browser
MicroB engine
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified major with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: microb-bugs
:
: use-time
:
:
  Show dependency tree
 
Reported: 2010-03-16 06:04 UTC by egoshin
Modified: 2010-03-23 19:09 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description egoshin (reporter) 2010-03-16 06:04:57 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Start browser and find some page with flash or java script which have some
"blinking" content - constantly changing picture
2. Lock device
3. After while - unlocm device

EXPECTED OUTCOME:

Battery usage is normal

ACTUAL OUTCOME:

Battery depletes very fast.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

Always in some web pages.

EXTRA SOFTWARE INSTALLED:

Nothing in browser and battery or X11 control

OTHER COMMENTS:

After some research I conclude that fast battery discharge is related with
complex web pages which has some moving pictures. Browser doesn't stop it while
device is locked and that work depletes a battery.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8)
Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-03-16 11:13:01 UTC
Hi,

(In reply to comment #0)
> Battery depletes very fast.
> 
> EXTRA SOFTWARE INSTALLED:
> Nothing in browser and battery or X11 control

> After some research

Please share your research because I don't see any proof yet that it's the
browser. For example did you SSH on the device when it's locked and checked the
CPU consumption of browser / Flash and can provide some data?
Any Extra software can shorten battery life so the list would be interesting.
Anything from Extras-Testing or Extras-Devel installed?
Comment 2 timeless 2010-03-16 11:36:53 UTC
there's an option in browser settings:

"Allow Javascript pausing" (or something like it).

What is yours set for?
Comment 3 egoshin (reporter) 2010-03-16 19:41:53 UTC
"Allow Javascript pausing" option is set to 15 secs. JS is enabled.

"Please share your research because I don't see any proof yet that it's the
browser. For example did you SSH on the device when it's locked and checked the
CPU consumption of browser / Flash and can provide some data?
Any Extra software can shorten battery life so the list would be interesting.
Anything from Extras-Testing or Extras-Devel installed?"

I suspect a browser because:

1.  I browsed, then changed a window and put device on lock. The battery level
was 1/2. Around three hours later I found device hot and battery near zero -
actually I had a problem with device wakeup, it was very slow. I don't
remember, how I waked it up - connected power first or just continued work with
lock slider button but I did both and even pressed the "power" button (small
button on top). There was only 1 X-Term application running + 1 browser window,
no SSH, no any another CLI apps in background. I even did not run video in any
form before (gst-video-thumbnailerd was killed and media player was not used). 


2.  It was actually a 2nd (or 3rd) time and at least 2 times I browsed some
"suspicious" web-sites, which offer some flushing pictures with questionable
context (actually - popup window/side pictures with "hot girls"). I have no
idea which technology is used for that - JS, flush, TIFF or something else.
Because battery was very low I switched it OFF ASAP. I didn't run powertop.

I have something from Extra-devel/Extra but no daemons besides OpenSSHD - I am
very careful about extra daemons because of resources.

After reboot anything was normal besides very low battery.
Comment 4 Eero Tamminen nokia 2010-03-23 16:53:49 UTC
Most likely this is issue with JS animated images which is fixed in Microb in
PR1.2 (same issue is also in upstream Firefox & Fennec).  Setting as fixed for
PR1.2.


> "Allow Javascript pausing" option is set to 15 secs. JS is enabled.

By default it should be 1/2min I think?
Comment 5 egoshin (reporter) 2010-03-23 19:09:47 UTC
> By default it should be 1/2min I think?

I never changed it.