Bug 9557 - (int-160721) DST start: Calendar Events created before are now an hour ahead
(int-160721)
: DST start: Calendar Events created before are now an hour ahead
Status: CLOSED FIXED
Product: Calendar
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: High blocker with 21 votes (vote)
: 5.0/(20.2010.36-2)
Assigned To: unassigned
: calendar-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-15 20:22 UTC by H. Can Celik
Modified: 2010-11-20 11:18 UTC (History)
15 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description H. Can Celik (reporter) 2010-03-15 20:22:33 UTC
My timezone is GMT -8 (I live in San Diego). After DST(last Sunday 3/14/2010)  
the all calender events are one hour ahead. I had an event set up at 7:30am but
the calendar app shows me at 8:30am instead.
Comment 1 Andre Klapper maemo.org 2010-03-15 21:14:04 UTC
Hi H., thanks for reporting this!
For future reference, please use the bug template.

Does the clock still displays the correct time though you have not changed the
time manually?

When you start the "Clock" application, click the time ("12:34"), is "Update
automatically" checked? If not, what are your settings there?
Comment 2 H. Can Celik (reporter) 2010-03-15 21:19:02 UTC
(In reply to comment #1)
> Hi H., thanks for reporting this!
> For future reference, please use the bug template.
> 
> Does the clock still displays the correct time though you have not changed the
> time manually?
> 
> When you start the "Clock" application, click the time ("12:34"), is "Update
> automatically" checked? If not, what are your settings there?
> 

The time is correct. I didn't changed it at all.
Date and time setting as follows:

24-hr clock (not checked)
Update Automatically (checked)

Time Zone: GMT-7
Date Monday,March 15 2010
Time 11:59am
Comment 3 Andre Klapper maemo.org 2010-03-15 21:49:33 UTC
*** Bug 9561 has been marked as a duplicate of this bug. ***
Comment 4 N. Graves 2010-03-15 21:52:11 UTC
I'm having the same issue in GMT -8. My clock was set to "update automatically"
and was displaying the correct time before and after DST. (I've unchecked the
"update automatically" and set the time manually since then.)

My old events show their original time on the "Edit Event" page, but show up
with +1 hour under all other calendar views.

If I create a new event, it is displayed as expected.

Because there seems to be no way to manually set the timezone settings for an
individual event, it seems that the only current workaround I see is to
manually delete and recreate all of my events.
Comment 5 Andre Klapper maemo.org 2010-03-15 22:11:20 UTC
(In reply to comment #2)
> Time Zone: GMT-7

I think that "GMT -7" does not exist. There's always a cityname after.

Does the problem only happen for calendar entries that were entered before DST
started, or does this also happen for new entries that you enter after the DST
start?
Comment 6 H. Can Celik (reporter) 2010-03-15 22:32:01 UTC
(In reply to comment #5)
> (In reply to comment #2)
> > Time Zone: GMT-7
> 
> I think that "GMT -7" does not exist. There's always a cityname after.
> 
> Does the problem only happen for calendar entries that were entered before DST
> started, or does this also happen for new entries that you enter after the DST
> start?
> 

It only happens for the entries created before DST. I also tried to change the
Time zone manually but all events still have the wrong time. 

Btw, my old and current event don't show the correct time even I go to the
"edit event" screen.
Comment 7 egoshin 2010-03-15 22:34:25 UTC
> egoshin: Can you please post your exact timezone data (city/area) on the N900?
> 

Settings/Date and Time

24-hr clock - disabled
Update automatically - enabled
Time Zone GMT-7  (but should be GMT-8 in accordance with US post office: San
Francisco time == UTC - 8 plus DST difference)
Date Monday, March 15.2010
Time 1:07pm
Comment 8 Andre Klapper maemo.org 2010-03-16 10:51:38 UTC
To those that are affected by this:
1. Were events synchronized (Mail for Exchange, or PC Suite)?
2. Is it possible to provide the file ~/.calendar/calendardb for analysis (for
example by private email as it includes all your calendar appointments)?
Comment 9 Andre Klapper maemo.org 2010-03-16 12:26:44 UTC
Additional question to everybody facing this problem:
Can you please list the provider you are using?
Comment 10 N. Graves 2010-03-16 13:08:24 UTC
(In reply to comment #9)
> Additional question to everybody facing this problem:
> Can you please list the provider you are using?

T-mobile.

(In reply to comment #8)
> To those that are affected by this:
> 1. Were events synchronized (Mail for Exchange, or PC Suite)?
> 2. Is it possible to provide the file ~/.calendar/calendardb for analysis (for
> example by private email as it includes all your calendar appointments)?

1. All of my events were created directly on the phone, no synching.
2. I'll look into this tomorrow if I get a chance.
Comment 11 H. Can Celik (reporter) 2010-03-16 18:44:12 UTC
Exactly same situation. 

(In reply to comment #10)
> (In reply to comment #9)
> > Additional question to everybody facing this problem:
> > Can you please list the provider you are using?
> 
> T-mobile.
> 
> (In reply to comment #8)
> > To those that are affected by this:
> > 1. Were events synchronized (Mail for Exchange, or PC Suite)?
> > 2. Is it possible to provide the file ~/.calendar/calendardb for analysis (for
> > example by private email as it includes all your calendar appointments)?
> 
> 1. All of my events were created directly on the phone, no synching.
> 2. I'll look into this tomorrow if I get a chance.
>
Comment 12 egoshin 2010-03-16 18:47:21 UTC
1. Any events are local or private, no sync with outside.
2. OK, I will attach.
Comment 13 egoshin 2010-03-16 18:54:54 UTC
I sent it by private mail.

My provider is T-mobile. No issue with it on Nokia 6133 in past.
Comment 14 egoshin 2010-03-16 19:16:03 UTC
New info: browsing syslog I found a message:

Mar 15 20:29:57 Nokia-N900-42-11 clockd: Date now is 2010-03015 20:29:57 (DST
OFF), TZ=:Etc/GMT+7, offset 25200/25200, timezone=25200, tzname=GMT+7/GMT+7

But Mar 15 should have DST ON.
Comment 15 Andre Klapper maemo.org 2010-03-16 19:23:05 UTC
(In reply to comment #12)
> 1. Any events are local or private, no sync with outside.
> 2. OK, I will attach.

Please don't attach all your messages in public here.
Private email much prefered.
Comment 16 Don Barrett 2010-03-16 20:38:28 UTC
I set an alarm in the Clock App Saturday night (for Sunday morning) and it
worked just fine. (The clock moved ahead one hour, and the alarm sounded at the
correct time.) 
So I am sure it is something in the Calendar App.  All of my calendar entries
were put in manually Friday and Saturday (I just got my N900 Thursday evening),
and all of my meetings/appointments were shifted one hour when I noticed it
Monday morning.  I have not sync'd with any computer yet.
My provider is iWireless (affiliated with T-Mobile).
Comment 17 Josh Triplett 2010-03-16 21:34:34 UTC
Experiencing this problem as well.

1. Created directly on the phone, no syncing.
2. Sure, I can send my calendardb via private mail, if you need another one.

Provider: AT&T
Comment 18 Timo Eikkula 2010-03-30 10:26:20 UTC
I had the same issue at Finnish DST change last weekend.
But this time shift happened only for some items not for all.
It seems that items synchronized with Outlook are ok.
"Manually" created events were moved by one hour ahead, but repeatable events
kept the time ok.
I have several private calendars that are not synchronized with outlook and
this happened with those.
Just noticed, that also manually entered events in the past have changed the
time one hour ahead.
Anyway DST change should not move the calendar events.
Comment 19 Mikko Kortelainen 2010-03-30 17:46:07 UTC
I can confirm this for the Finnish time zone, too. I rebooted the device, which
adjusted the device time, but also moved my calendar events one hour later.
Comment 20 Andre Klapper maemo.org 2010-03-30 18:05:05 UTC
(Removing "in USA" from summary as this is not US specific)
Comment 21 Andre Klapper maemo.org 2010-03-30 18:05:22 UTC
*** Bug 9697 has been marked as a duplicate of this bug. ***
Comment 22 John Veness 2010-03-31 00:16:03 UTC
This happened to me too. To answer the questions:

I'm in UK, so was in GMT time zone, now in GMT+1. The clock is set to update
automatically and did do so on Sunday morning without me having to do anything.

I'm using Vodafone provider. (Why is this relevant?)

I only have one calendar event that has a time on it (other events are "All
Day)! I created that event before DST happened. After DST the start and end
time were one hour later than when I created the event. After I noticed the
problem I manually changed the times back to what they should be.

My calendar is synced with MS Exchange 2007. It was synced both before the DST
change and afterwards. I did not notice immediately that the calendar event had
the wrong time, so I do not know if it was wrong immediately on the device when
DST started on Sunday morning, or if it went wrong after the next Exchange sync
on Monday morning. Also, I did not check how the event was displayed in Outlook
or Outlook Web Access either before or after DST - the only place I ever looked
at the event is on the device. This is a shame as that might have been useful
troubleshooting info.

I will email my calenderdb to Andre as requested, although I'm not sure how
useful it will be, as I have fixed the start times already.
Comment 23 James Ellis 2010-04-18 15:26:41 UTC
Hi

I had this too on my N900 except it's the other way around. My local timezone
is Australia/Sydney and on the DST switch on 4th April the offset went from
UTC+11 to UTC+10. The clock switched automatically and correctly but all the
events I entered into the device before the 4th April but scheduled after that
date moved 1 hour ahead.

For instance an appt on the 19th April scheduled at 0800 is now 0700.

Side effect of this is that I've been 1hr early for an appt which is not as
annoying as being late, I guess.

My thinking is that the calendar is storing times in UTC then just adding or
subtracting the current offset  - which could possibly explain that when I
viewed the 19th April appt before the 4th April it said 0800 as the start time.

Obviously, if an appt is scheduled at 0800 in a timezone it should stay that
time regardless of whether DST is on or not.

Device stats:
N900 Maemo 5
Extras-devel enabled
24hr clock on
Time - update automatically on
Timezone - "GMT+10" currently, GMT+11 when on DST
Device language -  English (UK)
Regional Settings - English (Australia)
Firmware : 3.2010.02-8.002

While we're on the subject of DST, you may want to note down somewhere for
testing or otherwise that the state of Queensland in Australia doesn't observe
DST. It would be interesting to note if any N900 users from QLD experienced
this 1hr calendar offset ?

Thanks
J
Comment 24 Andre Klapper maemo.org 2010-06-17 13:51:44 UTC
This has been fixed in package
clockd 0.0.40+0m5
which is part of the internal build version
2010.23-6
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 25 Andre Klapper maemo.org 2010-10-25 17:13:17 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.
Comment 26 James Ellis 2010-10-26 02:23:16 UTC
(In reply to comment #25)
> The problem reported here should be fixed in the update that was released today
> for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
> sometimes). Please leave a comment if the problem is not fixed for you in this
> update version.
> 

AUS/NSW went on to summer time (daylight saving) about 3 weeks ago so the fix
came just a bit too late. All my post-DST start appointments lodged before the
start of DST jumped one hour ahead. 
Let's see if this fixes the issue come DST end.
Comment 27 Timo Eikkula 2010-11-01 10:42:48 UTC
DST ended here in Finland and it seems that all my appointments in calendar
have correct string and ending time. Issue seems to be fixed now.
Comment 28 Teemu Korhonen 2010-11-01 12:36:20 UTC
I have fairly new phone, arrived with V 20.2010.36-2 firmware.
I'm in Finland and DST ended and most of my recurring calendar entries have
jumped one hour earlier. It seems that entries that were imported from my old
phone (N96) are ok and all that I created with n900 are wrong. I think thus bug
is still not fixed in this firmware.
Comment 29 Teemu Korhonen 2010-11-01 19:27:00 UTC
(In reply to comment #28)
> I have fairly new phone, arrived with V 20.2010.36-2 firmware.
> I'm in Finland and DST ended and most of my recurring calendar entries have
> jumped one hour earlier. It seems that entries that were imported from my old
> phone (N96) are ok and all that I created with n900 are wrong. I think thus bug
> is still not fixed in this firmware.
> 

Also seems that the calendar entries are fine before DST ended. Maybe times are
recorded in UTC and it's converted to current timezone. While this is correct
in some way, it's not how I expect a calendar to work.

Checked also clockd version is which is 0.0.41+0m5.
Comment 30 Chris Bigelow 2010-11-07 14:20:05 UTC
My N900 switched off DST last night and all of my appointments are now 1 hour
early.  I had looked at a future appointement a couple of weeks ago and noticed
the same thing, but assumed when the time changed it would correct itself.  It
did not.  I rebooted to see if that would correct the issue but it did not.  So
the latest Maemo update has not fixed this issue with calendar.  My clock
alarms remained correct, however.

Specs:
- Maemo version 20.2010.36-2.002 
- Date/time settings have 24-hr clock unchecked and update automatically
checked
- Carrier is T-Mobile
- Time zone: America/New_York
Comment 31 Chris Bigelow 2010-11-07 14:49:56 UTC
As a follow on to my last post, it seems that NON-repeating future appointments
are fine, time-wise - - it is all of the REPEATING appointments that moved an
hour earlier.  Guess I'll have to re-enter those.
Comment 32 derekn 2010-11-07 20:18:04 UTC
I'm also seeing weird behavior after switching off DST.  It appears that all
events -- repeating and non-repeating -- got moved back by an hour.

When I edit a repeating event, the time shown in the edit window is correct,
but it subtracts an hour when it actually displays it on the calendar.  This
only seems to apply to existing repeating events.  Creating a new repeating
event from scratch works correctly.

I wonder if turning off the automatic DST update (in the Date & Time settings)
and then manually resetting the clock twice a year would work around the
problem?  (Ugly, but better than having all of my events change times twice a
year.)
Comment 33 egoshin 2010-11-07 20:25:20 UTC
Shift all events (at a moment I have a repeated ones only) - confirmed. 

- Maemo version 20.2010.36-2.002 
- Date/time settings have 12-hr clock and update automatically
- Carrier is T-Mobile
- Time zone: CA/Los Angeles
Comment 34 derekn 2010-11-07 20:52:23 UTC
(In reply to comment #32)
> I wonder if turning off the automatic DST update (in the Date & Time settings)
> and then manually resetting the clock twice a year would work around the
> problem?  (Ugly, but better than having all of my events change times twice a
> year.)

To answer my own question...  Turning off automatic DST update doesn't help at
all.  I looked through an exported .ics file, and the calendar is doing
something really weird in its attempt to support DST.

Can we please (pretty please!) have an option to tell the calendar to simply
use local time for all events?  I.e., all events should be stored with a simple
local time (no timezone, no DST indication), and displayed at that time in
whatever the current timezone/DST happens to be.

I think that would fix the calendar for 95% of users.  And then you can work on
a more sophisticated approach for people who need to schedule meetings across
timezones, etc.
Comment 35 Timo Eikkula 2010-11-08 09:57:00 UTC
Strange. For me all events including repeating events (started way before DST
ended) have correct time even after the DST ended (events not moved). I also
checked what time they have in calendar before the DST end day, and event time
there was also okay.

I start to thinking what I did. And I did not make any backup of the phone
before update. I wanted to start from scratch
I flashed my phone with Ovi Suite (didn't use OTA).
Even with that my calendar was there, as well as my contact book.

I didn't create any new events with new firmware version before DST end (as it
was day before DST end day).

Maybe there is something with Calendar settings (I mean if you have made backup
and restore)?
Comment 36 Chris Bigelow 2010-11-08 14:44:19 UTC
In response to Timo, I have backed up my N900 using PC Suite.  I have a 64-bit
laptop and Ovi Suite didn't like it.  My single occurrence appointments seemed
to have made the time transition fine, but the repeating ones all seem to be
off by 1 hour post-time change.  Yet, as others have noted, if I open up the
appointment to edit it the start/end times are correct.  I have a lot of
repeating appointments - manually deleting and re-creating them will be a
chore.  Hopefully a s/w patch is forthcoming from Nokia.
Comment 37 A.Pajula 2010-11-08 20:51:34 UTC
The DST just changed a few weeks ago here in Finland. I had a recurring weekly
appointment in the calendar which was magically an hour too early after the
change. 

So, the calendar event created before DST change are now an hour ahead.

I tested this a bit, and if I create a new event in the past, say 25.10. and
make that repeat to 25.11., the times are correct. So the issue is only there
when the event is created during DST.

I'm on latest, PR1.3.
Comment 38 A.Pajula 2010-11-10 15:58:29 UTC
(In reply to comment #37)
> The DST just changed a few weeks ago here in Finland. I had a recurring weekly
> appointment in the calendar which was magically an hour too early after the
> change. 
> 
> So, the calendar event created before DST change are now an hour ahead.
> 
> I tested this a bit, and if I create a new event in the past, say 25.10. and
> make that repeat to 25.11., the times are correct. So the issue is only there
> when the event is created during DST.
> 
> I'm on latest, PR1.3.
> 

Sorry for the bugclutter, but I think this is relevant:

The event was on monday, the same day the time changed (04:00 to 03:00, event
at 12.45). I have other events that were not affected.

Both events were created in the phone.
Comment 39 Andre Klapper maemo.org 2010-11-20 00:06:22 UTC
If there are still problems, please fill a new bug report with exact steps and
information (settings, timezones etc). Thanks!
Comment 40 egoshin 2010-11-20 02:44:57 UTC
The problem is still here and it was not fixed.
I don't see a reason for setting this bug resolved - same issue, with the same
symptoms - during DST change the calendar events change time one hour.
Comment 41 Andre Klapper maemo.org 2010-11-20 11:18:38 UTC
(In reply to comment #40)
> I don't see a reason for setting this bug resolved

Ask Nokia... They prefer new bugs.