Bug 9532 - Search: can input numbers and other "blue" characters only with -holding- "alt" key
: Search: can input numbers and other "blue" characters only with -holding- "al...
Status: RESOLVED FIXED
Product: Map
General
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified minor (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: map-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-14 13:37 UTC by Roman Polach
Modified: 2010-03-15 20:55 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Roman Polach (reporter) 2010-03-14 13:37:37 UTC
SOFTWARE VERSION:
maemo 3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Run Maps, go to searching
2. use a hardware keyboard for next step:
3. press "alt" button, press (any) digit button or e.g. "g"

EXPECTED OUTCOME:
should display a digit or "alternate" character ("_" for "g")

ACTUAL OUTCOME:
there is english letter displayed - like if I haven't "alt" key pressed.
To achieve expected result, I must HOLD the "alt" key while typing digits etc.
This is incompatible behavior with the rest of Maemo.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
no relevant

OTHER COMMENTS:
I am using czech version of N900 - with czech hardware keyboard layout
Comment 1 Andre Klapper maemo.org 2010-03-14 16:25:42 UTC
Hi Roman,
I have tried this in the newer, internal (non-public) version 2010.10-2 and it
works for me. I press ↗, release the key, and then press G. I get a _ in the
Search field.

Hence the next public update will include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 2 Andre Klapper maemo.org 2010-03-15 20:55:13 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).