Bug 9501 - Phone UI not rotating to portrait mode
: Phone UI not rotating to portrait mode
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-11 22:18 UTC by Radu Capitanu
Modified: 2010-03-17 03:45 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Radu Capitanu (reporter) 2010-03-11 22:18:19 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. Open the slide and type a contact.
2. Select it and pick the number to make a call
3. The call is initiated
4. Close the slide

EXPECTED OUTCOME:

The UI is rotating to portrait mode

ACTUAL OUTCOME:

The UI remains in the landscape mode

REPRODUCIBILITY:
Almost every time.  

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS: After a fresh restart the first phone-call initiated in this
way turns the UI to portrait. After that all the phone-calls made like I
described don't turn the UI, remaining in landscape mode. To turn the UI I need
to cover the proximity sensor with the ear or finger. Please test this while
you are watching at the screen.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ro; rv:1.9.2)
Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-03-12 00:05:37 UTC
Works fine here, running the internal version 2010.10-2.

What are your settings in the Phone title bar menu? Here it's:
Turning control > Display orientation  == Automatic
Turning control > Launch by turning    == disabled
Comment 2 Radu Capitanu (reporter) 2010-03-12 00:12:50 UTC
(In reply to comment #1)
Same:
> Turning control > Display orientation  == Automatic
> Turning control > Launch by turning    == disabled

2010.10-2? Are you using a newer firmware?

Offtopic: What is the use of "Launch by turning" setting?
Comment 3 Andre Klapper maemo.org 2010-03-12 00:18:43 UTC
(In reply to comment #2)
> 2010.10-2? Are you using a newer firmware?

I wrote "internal" in my previous comment.
Comment 4 Radu Capitanu (reporter) 2010-03-12 00:26:09 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > 2010.10-2? Are you using a newer firmware?
> 
> I wrote "internal" in my previous comment.
> 

I sow "internal". This internal 2010.10-2 is different than 3.2010.02-8
firmware or is the same. Please make me understand.

What about my offtoping question.

Thanks in advance!
Comment 5 Andre Klapper maemo.org 2010-03-12 00:33:51 UTC
(In reply to comment #4)
> I sow "internal". This internal 2010.10-2 is different than 3.2010.02-8
> firmware or is the same. Please make me understand.

Not the same because a different name. It's a later internal release, as Nokia
has some weekly internal non-public builds for internal testing.

> What about my offtoping question.

Please go to talk.maemo.org for that as it's unrelated to this bug report.
Comment 6 Andre Klapper maemo.org 2010-03-14 19:53:36 UTC
I'd love to see a confirmation for this by a second user.
moreinfo for the time being.
Comment 7 Valério Valério maemo.org 2010-03-16 20:30:40 UTC
Can't reproduce, works as expected.

Running 2010.02-8.
Comment 8 Radu Capitanu (reporter) 2010-03-16 20:48:19 UTC
(In reply to comment #7)
> Can't reproduce, works as expected.
> 
> Running 2010.02-8.
> 

did you folowed described steps?

don'l lunch the call from contact aplication.
when you are in stand by screen type to found a contact. that will open your
contact aplication. than choose your contact and make the call. close the
slider and the ui doesn't rotate to portrait mode. note that this is not
happening always so try many times like described previously. can you do some
more test please?
Comment 9 Valério Valério maemo.org 2010-03-16 21:16:10 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Can't reproduce, works as expected.
> > 
> > Running 2010.02-8.
> > 
> 
> did you folowed described steps?
> 
> don'l lunch the call from contact aplication.
> when you are in stand by screen type to found a contact. that will open your
> contact aplication. than choose your contact and make the call. close the
> slider and the ui doesn't rotate to portrait mode.

Yes I did that, following your steps.

 note that this is not
> happening always so try many times like described previously. can you do some
> more test please?
> 

Did a bit more testing, worked 10 out of 10 tries here.

What are your settings for the "Turning control" option ?
Comment 10 Venomrush 2010-03-16 21:23:12 UTC
(In reply to comment #8)

> did you folowed described steps?
> 
> don'l lunch the call from contact aplication.
> when you are in stand by screen type to found a contact. that will open your
> contact aplication. than choose your contact and make the call. close the
> slider and the ui doesn't rotate to portrait mode. note that this is not
> happening always so try many times like described previously. can you do some
> more test please?
> 

Confirming following the steps you've given.
To simplify for other users:

1. Go to Desktop
2. Slide out the keyboard and start typing in a name of a contact
3. Select and call that contact
4. Close the keyboard
5. Rotate the phone
6. Observe behavior
Comment 11 Venomrush 2010-03-16 21:24:56 UTC
(In reply to comment #10)

> 
> Confirming following the steps you've given.
> To simplify for other users:
> 
> 1. Go to Desktop
> 2. Slide out the keyboard and start typing in a name of a contact
> 3. Select and call that contact
> 4. Close the keyboard
> 5. Rotate the phone
> 6. Observe behavior
> 

I would like to add the following settings were used:
1. Turning Control = Launch by turning
2. Display orientation = Portrait
Comment 12 Radu Capitanu (reporter) 2010-03-16 21:29:18 UTC
(In reply to comment #8)

Now: Display Orientation - Portrait
     Launch by turning - disabled

note that this is my second N900 phone and the first one had the same issues.

the bug could be reproduced even the display orientation is set to Portrait.
Comment 13 Andre Klapper maemo.org 2010-03-17 03:45:55 UTC
Tried several times but I cannot reproduce this problem in the internal, newer
version 2010.10-10 with the steps in comment 10 (thanks for them!) and both
with the settings in comment 11 and comment 12, so I assume that this has been
fixed internally in the meantime, and that the fix will be in the next public
update PR1.2.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/