Bug 9498 - Media Player won't recognize ogg files as media
: Media Player won't recognize ogg files as media
Status: RESOLVED WORKSFORME
Product: Media player
General
: unspecified
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-03-11 17:54 UTC by William Peterson
Modified: 2010-12-02 06:07 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description William Peterson (reporter) 2010-03-11 17:54:25 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Media player won't recognize .ogg files as media and make the accessable in
player
2. Media player plays .ogg files once located and selected via file manager
3. Can't play an entire album or create a playlists of .ogg file it will only
play one song at a time.

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1;
Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Comment 1 Andre Klapper maemo.org 2010-03-11 18:43:28 UTC
Thanks for reporting this, but unfortunately this report isn't very useful
because it doesn't describe the issue well. If you have time and can still
reproduce the problem, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug.
Comment 2 Andre Klapper maemo.org 2010-03-11 18:44:27 UTC
...and especially use the bug template, all fields, and provide steps, click by
click.
Comment 3 William Peterson (reporter) 2010-03-12 21:21:27 UTC
1. Using my Umbuntu Harty Heron configured PC I ripped audio CDs into .ogg
format.
2. I connected my N900 to said PC using the USB connection and transfered the
.ogg files to the N900.
3. I opened the standard Media player that is resident on my N900.
4. None of the .ogg files I copied are visible within the Media player.
5. I opened the file manager program that comes with the N900 and found the
.ogg files that I transfered.
6. I selected one of the .ogg files and it began to play on the resident Media
player indicating that the player could indeed play the .ogg files.
7. The Player will only play the .ogg files using this method.  In other words
one file at a time individually selected by the user utilizing the file manager
program.
8. There is no way to play a whole .ogg album or to create a play list
utilizing the method discribed above.
9. The issue remains repeatable as none of the .ogg files are accessable
utilizing the Media Player.
Comment 4 Andre Klapper maemo.org 2010-03-14 14:52:54 UTC
> EXTRA SOFTWARE INSTALLED:
> 

So I assume that ogg-support is installed?

This problem also remains after a reboot?
Comment 5 William Peterson (reporter) 2010-03-15 03:41:28 UTC
1. Yes, as I stated in my amended report once I selected .ogg files utilizing
the file manager program they ran fine and sounded great indicating  that the
Media player was successfully updated to play the .ogg files.

2. I have also tried numerous re-boots to no avail. The condition remains.
Comment 6 Andre Klapper maemo.org 2010-03-16 14:34:53 UTC
CC'ing Tuomas - maybe he has an idea how to debug and what might be wrong.
Comment 7 Tuomas Kulve 2010-03-16 15:41:01 UTC
(In reply to comment #6)
> CC'ing Tuomas - maybe he has an idea how to debug and what might be wrong.
> 

The only idea that comes to mind is that Tracker (file indexer) can take quite
a while to index all the new files, espcially if there are a lot of them. And
Media Player shows only the files reported by the Tracker.

If waiting some hours doesn't help, try removing ogg-support and installing it
again. There are also command line tools that can be used to debug the actual
problem.
Comment 8 Timur Kristóf 2010-04-03 14:07:10 UTC
This is interesting, since my Media Player recognises and plays .ogg files
correctly. (Although I only have a few of them.)
Comment 9 Andre Klapper maemo.org 2010-04-28 21:02:10 UTC
William, was comment 7 helpful?
Comment 10 Tuomas Kulve 2010-05-02 14:31:01 UTC
I think this belongs to Ogg Support. If this is moved there, I'll resolve this
as WORKSFORME.
Comment 11 William Peterson (reporter) 2010-05-02 19:06:06 UTC
Thank you for your suggestion, but it was one of the first things I tried, and
the problem still remains.  I've tried everything without success.
Comment 12 Andre Klapper maemo.org 2010-05-14 14:02:47 UTC
Which mime type do these ogg files have?
application/ogg? audio/ogg? Something else?
Comment 13 Will 2010-06-11 00:30:25 UTC
Hi,

I too think I have this bug, or at least, I am now suffering the same issue.

In short I am on PR1.2, I have extra codecs enabled and all has been well till
this evening. Last night I copied ALL 3172 of my Ogg music across to the N900
and it all appeared in Media Player just fine. I was listening to them today in
fact. Then tonight, when I noticed some duplicate entries of songs, I did the
following steps:


THE STEPS TO REPRODUCE IT:
--------------------------
tracker-processes -r
/usr/lib/tracker/trackerd -r &

It then counts down for about 10 minutes till tracker indexing is done
(I check using tracker-status too)


THE PROBLEM:
------------
Now I have just 26 music files visible in Media Player, and these are all MP3
files. :(


EVIDENCE IN LOGS:
-----------------
I ran trackerd with debug 2 and then verbose debug 3 and it definitely sees and
indexes ALL my Ogg files, BUT, it looks like it categorises them as Other
instead of Music.

Here is the evidence in the log (debug 2):

10 Jun 2010, 20:16:42: Tracker: State change from 'Indexing' --> 'Paused'
10 Jun 2010, 20:16:42: Tracker: Stopping disk space check
10 Jun 2010, 20:16:45: Tracker: Checking for statistics changes and signalling
clients...
10 Jun 2010, 20:16:45: Tracker: Updating 'Images' with new count:143, old
count:0, diff:143
10 Jun 2010, 20:16:45: Tracker: Updating 'Music' with new count:26, old
count:0, diff:26
10 Jun 2010, 20:16:45: Tracker: Updating 'Other' with new count:3172, old
count:2783, diff:389
10 Jun 2010, 20:16:45: Tracker: Updating 'Folders' with new count:366, old
count:308, diff:58
10 Jun 2010, 20:16:45: Tracker: Updating 'Videos' with new count:11, old
count:0, diff:11
10 Jun 2010, 20:16:45: Tracker: Updating 'Text' with new count:9, old count:1,
diff:8
10 Jun 2010, 20:16:45: Tracker: Updating 'Files' with new count:3756, old
count:3092, diff:664
10 Jun 2010, 20:16:45: Tracker: Updating 'Documents' with new count:29, old
count:0, diff:29
10 Jun 2010, 20:16:45: Tracker: State change from 'Paused' --> 'Indexing'
10 Jun 2010, 20:16:45: Tracker: Starting disk space check for every 10 seconds

I saw NO errors in the log by the way.

So I only see 26 Music files, but those 3172 Other files are my Ogg music
file!!!  They WERE visible in Media Player yesterday, but after
tracker-processes -r they won't come back. :(

The Ogg files playback ok if you open them manually, but I want to use media
player of course.

I tried uninstalling extra codecs and resinstalling it, to no avail.

I have rebooted the N900 many times and run tracker-processes -r many times
too, and I just cannot get my Ogg music to appear again. :(

Please help!
Comment 14 Will 2010-06-11 00:42:51 UTC
If it helps, here is the list of relevant packages I have installed:

ii  tracker                   0.6.95-25maemo1+0m5       All-in-one indexer,
search tool and metadata database.
ii  tracker-distutils         0.1-1                     Helper scripts to
un/register new mimetypes in tracker
ii  tracker-extractor-vorbis  0.1-2maemo2               Add vorbis format
metadata extraction in tracker
ii  tracker-utils             0.6.95-25maemo1+0m5       Tracker command line
applications to lookup data

ii  mediaplayer               1.2-18+0m5                Media Player
ii  mediaplayer-l10n-cscz     6.0+r7611+0m5             language files for
mediaplayer (cs_CZ)
ii  mediaplayer-l10n-dadk     6.0+r7611+0m5             language files for
mediaplayer (da_DK)
ii  mediaplayer-l10n-dede     6.0+r7611+0m5             language files for
mediaplayer (de_DE)
ii  mediaplayer-l10n-engb     6.0+r7611+0m5             language files for
mediaplayer (en_GB)
ii  mediaplayer-l10n-enus     6.0+r7611+0m5             language files for
mediaplayer (en_US)
ii  mediaplayer-l10n-eses     6.0+r7611+0m5             language files for
mediaplayer (es_ES)
ii  mediaplayer-l10n-esmx     6.0+r7611+0m5             language files for
mediaplayer (es_MX)
ii  mediaplayer-l10n-fifi     6.0+r7611+0m5             language files for
mediaplayer (fi_FI)
ii  mediaplayer-l10n-frca     6.0+r7611+0m5             language files for
mediaplayer (fr_CA)
ii  mediaplayer-l10n-frfr     6.0+r7611+0m5             language files for
mediaplayer (fr_FR)
ii  mediaplayer-l10n-itit     6.0+r7611+0m5             language files for
mediaplayer (it_IT)
ii  mediaplayer-l10n-mr0      6.11+0m5                  mediaplayer marketing
release package
ii  mediaplayer-l10n-nlnl     6.0+r7611+0m5             language files for
mediaplayer (nl_NL)
ii  mediaplayer-l10n-nono     6.0+r7611+0m5             language files for
mediaplayer (no_NO)
ii  mediaplayer-l10n-plpl     6.0+r7611+0m5             language files for
mediaplayer (pl_PL)
ii  mediaplayer-l10n-ptpt     6.0+r7611+0m5             language files for
mediaplayer (pt_PT)
ii  mediaplayer-l10n-ruru     6.0+r7611+0m5             language files for
mediaplayer (ru_RU)
ii  mediaplayer-l10n-svse     6.0+r7611+0m5             language files for
mediaplayer (sv_SE)
ii  mediaplayer-restore       1.2-9+0m5                 restore mediaplayer
original settings
ii  mediaplayerhomeapplet     1.2-10+0m5                Fremantle Media Player
Home Applet

i  mafw-dbus-daemon          0.2.2010.06-1+0m5         MAFW UI library
ii  mafw-gst-renderer         0.2.2010.07-2+0m5         MAFW gst renderer
plugin
ii  mafw-iradio-source        0.2.2010.06-1+0m5         MAFW internet radio
source
ii  mafw-iradio-source-bookma 1.3.2010.07-1+0m5+10.2010 MAFW internet radio
bookmarks
ii  mafw-playlist-daemon      0.2.2010.06-1+0m5         MAFW Playlist daemon
ii  mafw-tracker-source       0.2.2010.06-1+0m5         MAFW source based on
tracker
ii  mafw-upnp-source          0.2.2010.07-2+0m5         MAFW UPnP source plugin

ii  gstreamer0.10-nokia-speech                          1.0-0maemo11+0m5       
            Provides GStreamer wrappers for p
ii  gstreamer0.10-ogg                                   0.10.23-0maemo4+0m5-tk1
            GStreamer ogg plugin from the "ba
ii  gstreamer0.10-openmax                               0.10.0.6~1-0maemo17+0m5
            gst-openmax is a GStreamer plug-i
ii  gstreamer0.10-plugins-bad                          
0.10.14-git265-0maemo10+0m5         GStreamer plugins from the "bad" 
ii  gstreamer0.10-plugins-bad-extra                    
0.10.14-git265-0maemo10+0m5         Extra GStreamer plugins from the 
ii  gstreamer0.10-plugins-base                          0.10.25-0maemo14+0m5   
            GStreamer plugins from the "base"
ii  gstreamer0.10-plugins-camera                        0.79-1+0m5             
            GStreamer plugins for camera appl
ii  gstreamer0.10-plugins-good                         
0.10.16-git276-0maemo18+0m5         GStreamer plugins from the "good"
ii  gstreamer0.10-rm                                    0.10.10.2-1maemo2-5    
            Realmedia gst plugin from the ugl
ii  gstreamer0.10-theora                                0.10.23-0maemo4+0m5-tk1
            GStreamer theora plugin from the 
ii  gstreamer0.10-tools                                 0.10.25-0maemo2+0m5    
            Tools for use with GStreamer     
ii  gstreamer0.10-vorbis                                0.10.23-0maemo4+0m5-tk1
            GStreamer vorbis plugin from the 
ii  gstreamer0.10-wma         



i
Comment 15 Will 2010-06-11 09:19:39 UTC
Just to note that before PR1.2, I had used tracker-processes -r many times to
clean up the list of my music (almost all Ogg) and that always worked fine.

Since PR1.2, this is the first time I have run tracker-processes -r.  

Also of note is that I now have a 32GB microSD card in my N900, formatted to
ext3 (type 83) and it automounts just fine.  This all works as the trackerd
lists the Ogg files in the verbose debug 3 log as being indexed ok.  I also put
an Ogg file on the main MyDocs/ folder just in case, and trackerd doesn't add
that one as Music either, so it's not the microSD card.

So, I think something in PR1.2 caused the problem, as a guess.

Thanks.
Comment 16 Will 2010-06-12 00:24:44 UTC
(In reply to comment #12)
> Which mime type do these ogg files have?
> application/ogg? audio/ogg? Something else?

How do you find out the Mime type of a file on the N900?

Anyway, I used Nautilus file manager on my Ubuntu PC to look at the file
properties and that says the Mime type is:

Ogg Vorbis Audio  ( audio/x-vorbis+ogg )

I have looked and looked for Mime type display on the N900 but still cannot
find anything to tell me the mime type on the N900.  I'll keep looking.
Any more ideas?

Btw, I have made tracker ignore my directory of Ogg files and have copied just
one of them to MyDocs/  in case there was a corrupt one somewhere causing the
problem.  However, even with just the one Ogg file, Media Player still doesn't
show it because the trackerd does not call it Music, it calls it Other.



Filemanager on the N900 just says  Ogg Vorbis audio
when I click and hold on the file and then choose Details.
Comment 17 Will 2010-06-12 00:28:26 UTC
It MUST be trackerd that is the problem.

I have just used Media Player on the N900 to browse the Ogg files on my PC via
MediaTomb UPNP server and they show up fine on Media Player.

I'm really stumped now and just want to listen to my music.  

Any suggestions on how I can get it all working again?
Comment 18 Will 2010-06-12 00:35:22 UTC
Finally, I used file --mime to get the mime type (had to install it first):

~/MyDocs/Music $ sudo gainroot
/home/user/MyDocs/Music # apt-get install file

/home/user/MyDocs/Music # file --mime 01-keep_on.ogg 
01-keep_on.ogg: application/ogg

So, that looks fine to me.  What next?
Comment 19 Tuomas Kulve 2010-06-12 14:37:10 UTC
(In reply to comment #16)
> (In reply to comment #12)
> > Which mime type do these ogg files have?
> > application/ogg? audio/ogg? Something else?
> 
> How do you find out the Mime type of a file on the N900?

Problem is that there is no global way for checking mime type. Applications use
different methods for that. For remote locations (like UPnP or HTTP), the
server reports the mime type, so that cannot be affected locally.

"file" command has its own database, so does gstreamer. GnomeVFS uses the
information in /usr/share/mime/ where ogg-support adds its mime types
(/usr/share/mime/packages/00_ogg-support.xml). I think Tracker gets its
information from there as well.

You can ask Tracker to print out the metadata and mimetype with this command:

/usr/lib/tracker/tracker-extract -v 3 -f <file.ogg>

This prints something as well (not sure if that's taken from the database or
extracted from the file):

tracker-info <file.ogg>

You can list all files in Music category:

tracker-files -s Music

Or you can list all files having the ogg/vorbis mimetype:

tracker-files -m audio/x-vorbis+ogg
Comment 20 Will 2010-06-12 16:17:54 UTC
Thank you very much Tuomas! :)

So, it turns out that tracker really does think my Ogg files should be put into
the category 'Other' rather than 'Music'. I wonder why? 

Anyway, here are the output results of me running those commands:

~/MyDocs/Music $ tracker-info 01-keep_on.ogg 
Defaulting to 'files' service
Results: 13 for '/home/user/MyDocs/Music/01-keep_on.ogg'
  'File:Name' = '01-keep_on.ogg'
  'File:Path' = '/home/user/MyDocs/Music'
  'File:Mime' = 'audio/x-vorbis+ogg'
  'File:Size' = '6855014'
  'File:Modified' = '1276200702'
  'File:Accessed' = '1276128000'
  'File:Added' = '1276280597'
  'Audio:Title' = 'Keep On'
  ...

~/MyDocs/Music $ tracker-files -s Music
Results: 25
  /home/user/MyDocs/.sounds/Closer To Where You Want Me.mp3
  /home/user/MyDocs/.sounds/Waiting For The Time.mp3
  /home/user/MyDocs/.sounds/Love Sounds.mp3
  /home/user/MyDocs/.sounds/Total Fantasy.mp3
  /home/user/MyDocs/.sounds/10brief-gain5.mp3
  /home/user/MyDocs/.sounds/15-any_second_now-ph.mp3
  /home/user/MyDocs/.sounds/You Think You Want It.mp3
  /home/user/MyDocs/.sounds/oldPhone5.mp3
  ...
  NOTE: Limit was reached, there are more items in the database not listed here


~/MyDocs/Music $ tracker-files -s Other
Results: 512
  /home/user/MyDocs/.documents/Cc.note.html
  /home/user/MyDocs/trackerd03.log
  /home/user/MyDocs/trackerd02.log
  /home/user/MyDocs/trackerd01.log
  /home/user/MyDocs/Video/playmovie.sh
  /home/user/MyDocs/Video/playmovie.sh.bak
  /home/user/MyDocs/Music/01-keep_on.ogg
  /media/mmc1/music/OggEncodeAFLACAlbum.sh
  /media/mmc1/music/james_morrison/undiscovered/11-how_come.ogg
  /media/mmc1/music/james_morrison/undiscovered/03-wonderful_world.ogg
  /media/mmc1/music/james_morrison/undiscovered/09-this_boy.ogg
  /media/mmc1/music/james_morrison/undiscovered/05-one_last_chance.ogg
  ...
  NOTE: Limit was reached, there are more items in the database not listed here

~/MyDocs/Music $ tracker-files -m audio/x-vorbis+ogg
Results: 512
  /home/user/MyDocs/Music/01-keep_on.ogg
  /media/mmc1/music/abba/gold/01-dancing_queen_1976.ogg
  /media/mmc1/music/abba/gold/02-knowing_me_knowing_you_1977.ogg
  /media/mmc1/music/abba/gold/03-take_a_chance_on_me_1978.ogg
  /media/mmc1/music/abba/gold/04-mamma_mia_1975.ogg
  ...
  NOTE: Limit was reached, there are more items in the database not listed here

The above output proves the problem is with tracker then, I'd say.  

So, my next question is, how do I configure tracker to place Ogg files in the
category Music rather than Other?  Rename them all to *.oga? Surely not. :)

Thanks in advance!  

P.S. Please excuse the taste in music, I never listen to those particular songs
pasted above, tracker just happened to find those first. :)
Comment 21 Will 2010-06-12 16:23:13 UTC
Oh, and the first command I accidentally omitted reports this:

~/MyDocs/Music $ /usr/lib/tracker/tracker-extract -v 3 -f 01-keep_on.ogg 
Initializing tracker-extract...
Setting IO priority
Setting process priority
Loading extractor modules
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-xmp.so' with:
  Specific match for mime:'application/rdf+xml'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-playlist.so'
with:
  Specific match for mime:'audio/x-mpegurl'
  Specific match for mime:'audio/mpegurl'
  Specific match for mime:'audio/x-scpls'
  Specific match for mime:'audio/x-pn-realaudio'
  Specific match for mime:'application/ram'
  Specific match for mime:'application/vnd.ms-wpl'
  Specific match for mime:'application/smil'
  Specific match for mime:'audio/x-ms-asx'
  Specific match for mime:'application/x-ms-asx'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-tiff.so' with:
  Specific match for mime:'image/tiff'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-ps.so' with:
  Specific match for mime:'application/x-gzpostscript'
  Specific match for mime:'application/postscript'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-vorbis.so' with:
  Specific match for mime:'audio/x-vorbis+ogg'
  Specific match for mime:'application/ogg'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-mp3.so' with:
  Specific match for mime:'audio/mpeg'
  Specific match for mime:'audio/x-mp3'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-oasis.so' with:
  Generic  match for mime:'application/vnd.oasis.opendocument.*'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-pdf.so' with:
  Specific match for mime:'application/pdf'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-png.so' with:
  Specific match for mime:'image/png'
  Specific match for mime:'sketch/png'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-gstreamer.so'
with:
  Generic  match for mime:'audio/*'
  Generic  match for mime:'video/*'
  Generic  match for mime:'image/*'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-jpeg.so' with:
  Specific match for mime:'image/jpeg'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-abw.so' with:
  Specific match for mime:'application/x-abiword'
Adding extractor:'/usr/lib/tracker/extract-modules/libextract-html.so' with:
  Specific match for mime:'text/html'
  Specific match for mime:'application/xhtml+xml'
Setting memory limitations: total is 239.8 MB, virtual/heap set to 121.6 MB
(100.0 MB buffer)
OOM score has been set to 15
<--- [1] Command line request to extract metadata,
path:'/home/user/MyDocs/Music/01-keep_on.ogg', mime:(null)
---- [1]   Guessing mime type as 'audio/x-vorbis+ogg' for
path:'/home/user/MyDocs/Music/01-keep_on.ogg'
---- [1]   Extracting with
module:'/usr/lib/tracker/extract-modules/libextract-vorbis.so'
---- [1]   Found 12 metadata items
---- [1]   Found 'Audio:Title'='Keep On'
---- [1]   Found 'Audio:Genre'='Other'
---- [1]   Found 'Audio:ReleaseDate'='2005'
---- [1]   Found 'Audio.Samplerate'='44100'
---- [1]   Found 'Audio:TrackNo'='01'
---- [1]   Found 'Audio:Album'='Keep On'
---- [1]   Found 'Audio.Bitrate'='192'
---- [1]   Found 'Audio:Artist'='Will Young'
---- [1]   Found 'Audio.Duration'='284'
---- [1]   Found 'Audio.CodecVersion'='0'
---- [1]   Found 'Audio.Channels'='2'
---- [1]   Found 'Audio.Codec'='vorbis'
---> [1] Success, no error given
~/MyDocs/Music $ 

It seems to be guessing, but otherwise looks ok to me.

Any suggestions on how to fix my Ogg problem?

Thanks in advance.
Comment 22 Tuomas Kulve 2010-06-12 16:26:41 UTC
(In reply to comment #20)
> Thank you very much Tuomas! :)

> So, my next question is, how do I configure tracker to place Ogg files in the
> category Music rather than Other?  Rename them all to *.oga? Surely not. :)

Files are registered to categories by mimetype, not by extension. The following
command should do it and it's run by the ogg-support's postinst script:

tracker-register-mimetype -c Music -a audio/x-vorbis+ogg

-a for add and -d for delete.
Comment 23 Will 2010-06-12 16:50:44 UTC
Thanks!  Unfortunately this did not fixed the problem, I don't know why not.
Hang on may be I need to reboot, but first let me try again...

Ah, second time it worked!!!  Not sure why I needed to run it twice, but the
first time it did not touch any files.  I ran it first as user user by mistake
then I ran as user root btw.  But the first time I ran as user root the command
ran ok but clearly did not work.  I just ran it again as root (without needing
to reboot) and this time it works and this time it touched files too  So I had
to run it twice as user root.  

Thanks a million!!!  Fantastic support and really quick too!!!  Thank you so
much.  Wouldn't get this level of support with iPhone I bet. ;)   

So, I now have almost 3000 songs in Media Player!  Phew! :)

For the record, here is the output:

~ $ sudo gainroot
Root shell enabled

BusyBox v1.10.2 (Debian 3:1.10.2.legal-1osso30+0m5) built-in shell (ash)
Enter 'help' for a list of built-in commands.

/home/user # tracker-register-mimetype -c Music -a audio/x-vorbis+ogg
Found 165 pids...
Found process ID 2320 for 'trackerd'
  Terminated process 2320


NOTE: Limit was reached, there are more items in the database not listed here
touch /media/mmc1/music/abba/gold/01-dancing_queen_1976.ogg
touch /media/mmc1/music/abba/gold/02-knowing_me_knowing_you_1977.ogg
touch /media/mmc1/music/abba/gold/03-take_a_chance_on_me_1978.ogg
touch /media/mmc1/music/abba/gold/04-mamma_mia_1975.ogg
touch ...
tracker-update-ontology -c Music -a audio/x-vorbis+ogg
Tracker status is 'Idle'
/home/user # 


So, I don't know why this Ogg problem occurred for me (it doesn't occur for my
friend who has an almost identical installation on his N900) but I am wondering
if perhaps it is a permissions problem because I have set a password for user
user.  I did this a few weeks ago, but Nokia said it was safe to do so.

I set the password for user so that I could ssh in as user user and also
disallow ssh in by user root, for security reasons.

Anyway, it's probably not that but there would appear to be a bug somewhere as
running the following command has fixed it:

  tracker-register-mimetype -c Music -a audio/x-vorbis+ogg

I can only assume it did not get run successfully by the ogg-support's postinst
script for me, for some reason, during the PR1.2 upgrade.  I do recall the
extra codecs package being installed in addition to PR1.2 at the time, which I
thought was odd  as it was for PR1.1, but I have reinstalled it since anyway
and still no joy.  Perhaps it need to run twice like it did for me just now,
not sure why the first time failed to work.

Anyway, all working now, thank you VERY much for all your help!!! :)
Comment 24 Will 2010-06-13 11:18:09 UTC
And finally, just in case it helps anyone...  

After all this I noticed that some of my music (a lot of it, about 2000 songs)
had been placed in artist 'unknown' as shown in Media Player.  

All I needed to do to fix this was to run again the command:

  tracker-processes -r

wait 10 minutes for it to index the lot, and then ALL my ogg file were properly
listed in Media Player. :)

Hope that helps someone.
Comment 25 Andre Klapper maemo.org 2010-09-27 12:56:04 UTC
Will, glad that it works for you now.
Closing this bug report as the issue could not be reproduced. Please feel free
to reopen this report if you can provide better steps to reproduce this. :-/
Comment 26 Will 2010-11-03 23:48:08 UTC
Hi!

Just to say I have just updated to PR1.3 over my WLAN today.

And unfortunately my 3000 Ogg Vorbis music files are no longer listed in Media
Player. Yep, trackerd thinks they are 'Other' rather than 'Music', again.

So, I've just fixed this (again) by doing the following:

> sudo gainroot
> tracker-register-mimetype -c Music -a audio/x-vorbis+ogg
> tracker-processes -r

Finally, click on Media Player and then wait while it spends 10 minutes or so
Retrieving information on the new media files...

I now have my 3066 Ogg Vorbis songs back :)

Phew! :)
Comment 27 James Ellis 2010-12-02 06:07:02 UTC
Hi 

Thanks for the solutions posted here. After the PR1.3 release all of my oggs
showed up in Media Player as "Unknown - 1 album / 603 tracks" ! even though
tracker-info etc was correctly identifying them as oggs and showing the
album/track metadata. My music is on an SD card.

I went through all the solutions posted but what worked for me was:

1. associate the mime type with Music as posted (audio/x-vorbis+ogg) - just to
be sure.
2. tracker-processes -r to completely rebuild the database and let trackerd
reindex your files.
3. be patient with the reindex, espec if you have thousands of oggs. use
tracker-status and tracker-stats to show how the indexing is going.

These should be run as user, *not root* (because you run Media Player as user).
As root I was getting all kinds of segmentation faults.

Thanks
James