Bug 9452 - (int-159770) Incorrect TDC GPRS APN leads to IMAP connectivity problems
(int-159770)
: Incorrect TDC GPRS APN leads to IMAP connectivity problems
Status: RESOLVED DUPLICATE of bug 9272
Product: Connectivity
Operator Setup Wizard
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: phone-settings-wizard-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-08 14:45 UTC by kdebjp
Modified: 2010-03-08 20:06 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description kdebjp (reporter) 2010-03-08 14:45:37 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM:
Preconditions: Internet connections not created automatically and emails or not
checked automatically, either.
1. Connected to the Internet over WIFI (my home WLAN).
2. Started Modest to connect to my IMAP server and checked my mail. This
worked.
3. Disconnected from my WLAN and connected to the Internet over 3G (by means of
"TDC www 3G+GPRS"). This worked.
4. Tried to open a SSH connection to my IMAP server. This worked.
5. Started Modest again to connect to my IMAP Server. This connection very
often failed (and without warning - the only sign of failure was that the "Last
Updated" time stamp for my email accounts wasn't chanced). Lately, it started
to fail consistently.

EXPECTED OUTCOME:
Connecting to my IMAP server to check my emails should succeed as I've opened
the appropriate port (993 for IMAPS) in my firewall. And if not, an appropriate
warning should be provided.

ACTUAL OUTCOME:
Connecting to my IMAP server on port 993 failed without warning.

REPRODUCIBILITY:
A week ago: 1/5. Now: Always.

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
I found that /etc/operator_settings contained the following line:
238     1       TDC Mobil       INTERNET        TDC www 3G+GPRS wap

That is, the APN for my provider has been set up to be "wap". Unfortunately,
this is the APN for WAP access and not for general internet access (some
operators apparently block select ports on WAP access points). Once I corrected
the APN to be "internet", everything worked as expected.

I can see that several other operation settings in /etc/operation_settings have
been set to use "wap" or something similar as the APN. Seems odd for a device
that doesn't feature a WAP browser. It would be good if Nokia could check that
this is actually correct as many other N900 users will otherwise potentially
experience mail problems and similar.

Also, I would recommend that Modest is changed to report *all* connection
problems. The absence of any warnings in the described scenario increases the
severity of the problem.
Comment 1 Andre Klapper maemo.org 2010-03-08 15:11:10 UTC
Hi Bjarne, thanks for reporting this!
Comment 2 Venomrush 2010-03-08 19:53:25 UTC
Duplicate of bug 9272?
Comment 3 Andre Klapper maemo.org 2010-03-08 20:06:57 UTC
Argh, true. Thanks for finding it!

*** This bug has been marked as a duplicate of bug 9272 ***