Bug 9429 - (int-159786) Viewing specific photos in Image Viewer does not follow the correct order shown in thumbnail mode
(int-159786)
: Viewing specific photos in Image Viewer does not follow the correct order sho...
Status: RESOLVED DUPLICATE of bug 7559
Product: Images and Camera
Image viewer
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: image-viewer-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-06 20:35 UTC by Cláudio F. Gil
Modified: 2010-03-09 22:45 UTC (History)
2 users (show)

See Also:


Attachments
Photo 1 (1.11 MB, image/jpeg)
2010-03-07 17:01 UTC, Cláudio F. Gil
Details
Photo 2 (605.64 KB, image/jpeg)
2010-03-07 17:03 UTC, Cláudio F. Gil
Details
Photo 3 (638.10 KB, image/jpeg)
2010-03-07 17:04 UTC, Cláudio F. Gil
Details
Photo 4 (876.67 KB, image/jpeg)
2010-03-07 17:07 UTC, Cláudio F. Gil
Details
syslog of issue (94.92 KB, text/plain)
2010-03-07 19:33 UTC, Venomrush
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Cláudio F. Gil (reporter) 2010-03-06 20:35:59 UTC
SOFTWARE VERSION:
N900, PT, Maemo 5 3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Go to applications and open Image Viewer
2. Memorize the position of sequencial photos: 1, 2, 3, 4.
3. Preas number 2 to view it
4. Swipe to the left to see number 3.
5. Swipe to the right to go back.
6. Swipe to the left again.

EXPECTED OUTCOME:
Photos should be shown with the order: 2, 3, 2, 3.

ACTUAL OUTCOME:
Photos are shown in the order: 2, 3, 1, 4.

REPRODUCIBILITY:
always, for a certain photo but when I start from a different one I have
different behaviors. Some lead to a normal usecase, others lead to a 2, 3, 1, 3
order.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; pt-PT; rv:1.9.2a1pre)
Gecko/20091127 Firefox/3.5 Maemo Browser 1.5.6 RX-51 N900
Comment 1 Venomrush 2010-03-07 03:16:49 UTC
I'm unable to reproduce the case here.
Can you please upload the sample photos you are experiencing this issue with?

Thanks
Comment 2 Cláudio F. Gil (reporter) 2010-03-07 17:01:39 UTC
Created an attachment (id=2447) [details]
Photo 1
Comment 3 Cláudio F. Gil (reporter) 2010-03-07 17:03:14 UTC
Created an attachment (id=2448) [details]
Photo 2
Comment 4 Cláudio F. Gil (reporter) 2010-03-07 17:04:15 UTC
Created an attachment (id=2449) [details]
Photo 3
Comment 5 Cláudio F. Gil (reporter) 2010-03-07 17:07:13 UTC
Created an attachment (id=2450) [details]
Photo 4
Comment 6 Cláudio F. Gil (reporter) 2010-03-07 17:14:47 UTC
I've uploaded the photos in the order deacribed. All of them are in the default
camera folder and have no additional tags or description other than the camera
defaults. I've noticed that between pictures 1 and 2 are two videos withe the
sequential names ...003 and ...004.
Comment 7 Venomrush 2010-03-07 19:32:09 UTC
Confirming with the images you've supplied.

With only those 4 images attached in this bug on phone.

I restarted the phone to try and get a syslog but it seems to fixed itself for
a while. But then after several more attempts I was able to reproduce the bug.

Not only was it skipping images, but sometimes swipe left then right gave the
exact same image.

Thanks for reporting! Definitely interesting bug.
Comment 8 Venomrush 2010-03-07 19:33:17 UTC
Created an attachment (id=2451) [details]
syslog of issue

Issue occurred around 17:10 to 17:13
Comment 9 Andre Klapper maemo.org 2010-03-08 16:12:09 UTC
Thanks for reporting this (and thanks to Venomrush for reproducing)

(In reply to comment #7)
> Not only was it skipping images, but sometimes swipe left then right gave the
> exact same image.

That might be a different issue: bug 7559...
Comment 10 Andre Klapper maemo.org 2010-03-09 22:45:37 UTC
This is considered as a duplicate of bug 7559 internally.

*** This bug has been marked as a duplicate of bug 7559 ***