Bug 9420 - Menu updating message is not localizable
: Menu updating message is not localizable
Status: RESOLVED WONTFIX
Product: Catorise
General
: 0.7.3
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: Andrew Flegg
: general
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-05 20:43 UTC by Todor Tsankov
Modified: 2010-03-13 23:03 UTC (History)
0 users (show)

See Also:


Attachments
localized postinst (1.15 KB, patch)
2010-03-05 20:44 UTC, Todor Tsankov
Details
The needed POT file (114 bytes, text/plain)
2010-03-05 20:46 UTC, Todor Tsankov
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Todor Tsankov (reporter) 2010-03-05 20:43:32 UTC
SOFTWARE VERSION:
catorise-0.7.5

EXACT STEPS LEADING TO PROBLEM: 
Install the application and wait for the "Updating menu structure..." message -
it is not localized, even though a different system language is configured.

EXPECTED OUTCOME:
Ability to localize the message

ACTUAL OUTCOME:
The message is "hard" coded

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
-

OTHER COMMENTS:
I'm attaching a possible change to postinst script in the package which will
allow the message to be localized. It expects the localized files in the normal
for this app location - /opt/catorise/share/locales/


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; bg; rv:1.9.1.8)
Gecko/20100216 Fedora/3.5.8-1.fc12 Firefox/3.5.8
Comment 1 Todor Tsankov (reporter) 2010-03-05 20:44:45 UTC
Created an attachment (id=2442) [details]
localized postinst

This adds localization to the notification message sent out when regenerating
the menu
Comment 2 Todor Tsankov (reporter) 2010-03-05 20:46:05 UTC
Created an attachment (id=2443) [details]
The needed POT file

This is the base pot file needed for the localizations of the package
Comment 3 Andrew Flegg maemo.org 2010-03-07 12:20:25 UTC
We can lose the "echo"s and so remove the need for a "done." message.

However, with the performance improvements recently, I wonder if there's a need
for the message at all.

However, having a translation file means we could provide customised versions
of the HAM strings for certain locales to avoid the "Location & navig" problem
reported in bug 8955.
Comment 4 Todor Tsankov (reporter) 2010-03-07 17:18:21 UTC
> However, with the performance improvements recently, I wonder if there's a need
> for the message at all.
Yes - KISS is a good strategy to go! Indeed with all the caching done on the
menu, the regeneration is very fast.


> However, having a translation file means we could provide customised versions
> of the HAM strings for certain locales to avoid the "Location & navig" problem
> reported in bug 8955.
> 

Yes, but the actual translation is done by hildon-desktop which is responsible
for menu rendering (at least I think it is) and there you do not have control
over the text domain used for the localization. I've read the bug report and
can tell you that this is fixable with using proper strings in the localization
file itself like:

msgstr "Location &\n Navigation"

I had similar problems with the Bulgarian localization as some of the app names
became to long. Actually this is the main challenge to all translators - to be
able to properly change the strings and they still fit in the required space
:-)
Comment 5 Andrew Flegg maemo.org 2010-03-07 17:40:11 UTC
(In reply to comment #4)
> 
> > However, having a translation file means we could provide customised versions
> > of the HAM strings for certain locales to avoid the "Location & navig" problem
> > reported in bug 8955.
> 
> Yes, but the actual translation is done by hildon-desktop which is responsible
> for menu rendering (at least I think it is) and there you do not have control
> over the text domain used for the localization.

Ah, but you can. Which is how I'm using the hildon-application-manager strings
in the first place:

~ $ cat /opt/catorise/share/system.directory 
[Desktop Entry]
Type=Directory
Name=ai_category_system
Icon=app_install_system
X-Text-Domain=hildon-application-manager
Comment 6 Todor Tsankov (reporter) 2010-03-07 19:34:20 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > 
> > > However, having a translation file means we could provide customised versions
> > > of the HAM strings for certain locales to avoid the "Location & navig" problem
> > > reported in bug 8955.
> > 
> > Yes, but the actual translation is done by hildon-desktop which is responsible
> > for menu rendering (at least I think it is) and there you do not have control
> > over the text domain used for the localization.
> 
> Ah, but you can. Which is how I'm using the hildon-application-manager strings
> in the first place:
> 
> ~ $ cat /opt/catorise/share/system.directory 
> [Desktop Entry]
> Type=Directory
> Name=ai_category_system
> Icon=app_install_system
> X-Text-Domain=hildon-application-manager
> 

Yes, I completely forgot that the directory files are distributed with the
package. But still - the reason I've started using catorise is that it was as
standard as possible, because it was using the package manager categories. This
means that the package benefits from the already localized in many languages
app manager. 
Anyway, if you decide on providing different localizations for the categories
I'll be glad to translate them to Bulgarian.
Comment 7 Andrew Flegg maemo.org 2010-03-13 23:03:34 UTC
As discussed in the comments, I've removed these strings in 0.8.0 so the patch
isn't needed.