Bug 941 - Clock application locking when using alarm
: Clock application locking when using alarm
Status: RESOLVED FIXED
Product: Desktop platform
general
: 3.0
: All Maemo
: Medium normal with 2 votes (vote)
: ---
Assigned To: unassigned
: HAF QA mailing list
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2007-01-12 23:59 UTC by Laurent GUERBY
Modified: 2008-09-30 14:01 UTC (History)
1 user (show)

See Also:


Attachments
modified systemui.xml (1.24 KB, text/plain)
2007-03-14 14:13 UTC, Laurent GUERBY
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Laurent GUERBY (reporter) 2007-01-12 23:59:50 UTC
(OS is 2.2006.51-6, came with my N800 out of the box)

Display settings: bright 30 seconds, switch off 1 minutes, lock screen checked

I set up an Clock "Alarms" Daily at 0800am with one of my MP3, when the alarm
rang I let it cycle a few times (mornings... :), then I touched "close" and went
off to real life. After coming back home, I pressed the screen, it proposed me
the usual press on/off, I pressed, the "Now press BOX", pressed the middle of
dpad but without any effect. Repeated many times, but I finally had to remove
the battery to get back to normal.

Details: 

- my MP3 is long (Right Here, Right Now by Fat Boy Slim) and is silenced after a
few dozen seconds, silence lasts a while and then it plays again from start. I'm
surprised by this behaviour ("silence"), would have thought that it would play
it in loop until I press snooze, is the behaviour I describe as planned?

- tried to reproduce but could not after the reboot.
Comment 1 Laurent GUERBY (reporter) 2007-01-13 14:59:26 UTC
Found out a way to make this bug happen on demand: 

1. edit /etc/systemui/systemui.xml and enable "soft power off" at priority 100
(set locktouchscreen at 95 to make it easier)
2. reboot
3. press on/off and choose soft power off, press middle of dpad
4. screen is off, press on/off a long time
5. press on/off a short time to bring the advice "Now press dpad"
6. press dpad, it should work
7. repeat 3 to 6 but this time 6 will no longer work 
8. remove and replug the battery to get back to normal

=> bug on the second time out of poweroff, some state not properly restored?

Hope this helps.
Comment 2 Laurent GUERBY (reporter) 2007-01-13 15:14:48 UTC
Note: you have to set the display menu option "Lock screen and keys" on to see
the problem.
Comment 3 Peter Seebach 2007-01-13 15:43:42 UTC
Verified/reproduced, with some caveats.  Most specifically, you must have "lock
touchscreen and keys" set in Display control panel, or it won't happen.  Also
"soft power off" is actually spelled "Soft poweroff" in the systemui.xml file.

That said, does work, and I could not escape it without pulling the battery.
Comment 4 Jake Kunnari 2007-03-14 11:10:29 UTC
Hi, could you attach your modified systemui.xml file to this bug report.
Comment 5 Laurent GUERBY (reporter) 2007-03-14 14:13:21 UTC
Created an attachment (id=252) [details]
modified systemui.xml

--- systemui.xml.orig	2007-03-14 13:12:45.000000000 +0100
+++ systemui.xml	2007-03-14 13:11:57.000000000 +0100
@@ -23,7 +23,6 @@
    <po>osso-powerup-shutdown</po>
   </disabled_reason>
  </menuitem>
-<!--
  <menuitem priority="20" name="Reboot">
   <return>6</return>
   <po>osso-powerup-shutdown</po>
@@ -32,7 +31,6 @@
   <return>7</return>
   <po>osso-powerup-shutdown</po>
  </menuitem>
--->
  <menuitem priority="0" name="powerup_memainmenu_poweroff">
   <return>5</return>
   <po>osso-powerup-shutdown</po>
Comment 6 Laurent GUERBY (reporter) 2007-11-28 01:05:03 UTC
Interestingly, with unmodified systemui.xml from OS2008 if you do as described
in the "Description" it will also deactivate the dpad on press on/off.
Hopefully I had a remote shell and I could do a proper shutdown instead of
removing the battery.

Long lived bug :).
Comment 7 Laurent GUERBY (reporter) 2007-11-28 21:45:44 UTC
For the lock problem in OS2008 even if there's a workaround
that worked at least once (wait until screen is off)
I got into a situation where I was unlocked
but all the physical buttons (pad, home, the three buttons, +/-/full size)
where not doing anything whereas power and stylus+thumb
where still working perfectly. I tried sysklogd but saw nothing, I launched xev
and no event were generated for not working buttons.
Comment 8 Laurent GUERBY (reporter) 2007-11-28 21:45:57 UTC
Any suggestion on what to look at if this happens again?
Comment 9 Philippe De Swert nokia 2008-03-10 13:01:40 UTC
(In reply to comment #8)
> Any suggestion on what to look at if this happens again?

Does this bug still occur? There used to be issues with the keys getting
disabled by a kernel bug, which is fixed now. Thank you.
Comment 10 Karsten Br├Ąckelmann 2008-05-23 14:58:17 UTC
Re-setting the assignee, since Carlos moved on to other tasks.

Please note that this does not affect the legitimacy of the bug in any way.
It's a purely administrative operation. Sorry for the noise.
Comment 11 Andre Klapper maemo.org 2008-09-23 13:51:28 UTC
Laurent, can you please answer comment 9?
Can you test this again with Diablo on your N800, please?
Comment 12 Laurent GUERBY (reporter) 2008-09-29 23:56:35 UTC
I updated my diablo install a few hours ago via the icon then graphical updater
 and right now the wifi dialog doesn't detect anymore any signal and doesnt
have the GSM pairing either, it just get stuck on "Searching".

As soon as I can solve the update issue I'll recheck this bug
Comment 13 Laurent GUERBY (reporter) 2008-09-30 14:01:17 UTC
Hopefully I survived:

https://bugs.maemo.org/show_bug.cgi?id=3749

Seems that this problem is gone