Bug 9400 - N900 version displayed as <unknown>
: N900 version displayed as <unknown>
Status: RESOLVED DUPLICATE of bug 8148
Product: Desktop platform
general
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: HAF QA mailing list
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-04 21:39 UTC by spam
Modified: 2010-03-05 16:38 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description spam (reporter) 2010-03-04 21:39:43 UTC
SOFTWARE VERSION:
<unknown>

EXACT STEPS LEADING TO PROBLEM: 
1) Goto Settings => Product Info

EXPECTED OUTCOME:
1) See current version

ACTUAL OUTCOME:
Display reads
Nokia
<unknown>
<unknown>
Version: <unknown>
WLAN MAC: EC:XXXXXXXXXXX (X instead of actual number)
Bluetooth-Adress: EC: XXXXXX (X instead of actual number)
IMEI: XXXXXX (X instead of actual number)

*#0000# reads
V <unknown>
<unknown>, <unknown>
C Nokia

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
- Currency Converter
- rdesktop
- rootsh
- vncviewer
- python-tk (via apt-get to get IDLE to work) (Installed after <unknown> bug
started)
- OpenSSH Server+Client (Installed after <unknown> bug started)
- vim (Installed after <unknown> bug started)

I also installed these but have uninstalled them via the package manager:
- PyQt4 Demo (removed because some documentation was missing)
- PyQt4 Full Install
- Mclock

OTHER COMMENTS:
I purchased the N900 last month and installed whatever system update was
available around the beginning of February.
I was planning on developing a few QT Apps but I am still reading the book so I
have not started.
I have not modified the phone, I use the limited E-Mail client that comes with
the phone, SSH into my Server when required and browse the web. I don't even
use the phone feature often.
I will reload the OS it if necessary but it broke on it's own so I don't want
to have to reload the OS every couple of months.

User-Agent:       Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.2.15
Version/10.10
Comment 1 Venomrush 2010-03-05 01:15:38 UTC
This doesn't happen on factory settings.

I believe the hacks/mods & apps you have might have caused this.

Can you backup the device and flash it?
Comment 2 Lucas Maneos 2010-03-05 08:35:30 UTC
Have you ever installed fmtx-faker (known to cause this, see bug 8148 for
details)?  If so, "dpkg --purge fmtx-faker" (as root) and a reboot should fix
it.

If that's not the case, what is the output of the command "osso-product-info"?

(Tentatively setting version to the latest available at the beginning of
February).
Comment 3 spam (reporter) 2010-03-05 15:09:42 UTC
(In reply to comment #1)
> I believe the hacks/mods & apps you have might have caused this.

What hacks? I have listed the software I have installed. I am getting ready to
install a different E-Mail application but have not done so.... too busy at
work :)

> Can you backup the device and flash it?

Yes I can but I'd rather help track down this issue.


(In reply to comment #2)
> Have you ever installed fmtx-faker (known to cause this, see bug 8148 for
> details)?  If so, "dpkg --purge fmtx-faker" (as root) and a reboot should fix
> it.

Never, I have only installed what I listed in the initial report. I just
checked 8148 and I have never used the FM transmitter, I use headphones.

> If that's not the case, what is the output of the command "osso-product-info"?

Note, I don't have wireless here at work (not allowed) so I am writing this by
hand (can't ssh in). I will try my best to reproduce the output as it is on the
screen.

OSSO_PRODUCT_HARDWARE='RX-51'
OSSO_PRODUCT_NAME='N900'
OSSO_PRODUCT_FULL_NAME='Nokia N900'
OSSO_PRODUCT_RELEASE_NAME='Meamo 5'
OSSO_PRODUCT_FULL_NAME='Meamo 5'
OSSO_PRODUCT_RELEASE_VERSION='3.2010.02-8'
OSSO_PRODUCT_WLAN_CHANNEL='fcc/us'
OSSO_PRODUCT_KEYBOARD='German'
OSSO_PRODUCT_REGION='Germany'
OSSO_PRODUCT_SHORT_NAME='Nokia N900'
OSSO_VERSION='RX-51_2009SE_3.2010.02-8_PR_MR0'
Comment 4 spam (reporter) 2010-03-05 15:16:42 UTC
(In reply to comment #2)
> Have you ever installed fmtx-faker (known to cause this, see bug 8148 for
> details)?  If so, "dpkg --purge fmtx-faker" (as root) and a reboot should fix
> it.

One more thing, I just tried enabling the FM transmitter and it enabled without
a problem. This N900 was an openbox product, maybe the sales rep installed it
to demo the thing.
I just ran dpkg --purge fmtx-faker and it is working now... that'll teach me 
to re-flash any open box device.

Sorry for the trouble, thanks for the help, bug can be closed/deleted
Comment 5 Lucas Maneos 2010-03-05 16:38:33 UTC

*** This bug has been marked as a duplicate of bug 8148 ***