Bug 9373 - Steals focus when package is installed
: Steals focus when package is installed
Status: RESOLVED DUPLICATE of bug 6060
Product: Settings and Maintenance
Application manager
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-03 06:34 UTC by Vincent Lefevre
Modified: 2010-03-03 13:20 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vincent Lefevre (reporter) 2010-03-03 06:34:39 UTC
SOFTWARE VERSION:
3.2010.02-8.002

EXACT STEPS LEADING TO PROBLEM: 
1. Start X Terminal
2. Start Application manager
3. From the Application manager, select any package to download and start the
installation (the installation mustn't be immediate for the following steps).
4. Go back to the X Terminal.
5. Type something until...

EXPECTED OUTCOME:
One should be able to type any long string, i.e. the focus should never be
lost.

ACTUAL OUTCOME:
The cursor, which was a completely black rectangle, is now a rectangle with a
black border and white inside, and the typed characters no longer appear. This
problem seems to occur once the package has been installed (the Application
manager has displayed "1 application successfully installed).

REPRODUCIBILITY:
always
Comment 1 Ryan Abel maemo.org 2010-03-03 08:56:01 UTC
Not just XTerm, but anything that accepts input. Rumor is that this may be
fixed in PR1.2, but confirmation would be appreciated.
Comment 2 Lucas Maneos 2010-03-03 13:20:44 UTC
Pointing to the rumor ;-)

*** This bug has been marked as a duplicate of bug 6060 ***