Bug 9345 - Media Player in unusable state after opening invalid H.264 file
: Media Player in unusable state after opening invalid H.264 file
Status: RESOLVED DUPLICATE of bug 6823
Product: Media player
General
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-01 22:19 UTC by Oskar
Modified: 2010-03-03 16:55 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Oskar (reporter) 2010-03-01 22:19:56 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Encode H.264 video inside MP4 container. Use parameters unsupported by N900.
My example: 704x416, bitrate 1000
2. Transfer video file to N900 and tap on it in file manager
3. Media Player opens and issues error message about unsupported file format
4. Close Media Player
5. Tap on other video that you know played well before. AVI or MP4 doesn't
matter.

EXPECTED OUTCOME:
Videos plays as it did before you opened the out-of-spec H.264 file.

ACTUAL OUTCOME:
Media Player displays all controls on black background, doesn't play the video
but doesn't give an error message either.
You have to kill a process named
/usr/bin/mafw-dbus-wrapper mafw-gst-renderer
to get things working again. (or restart device of course)

REPRODUCIBILITY:
always (with the H.264 files I had)


OTHER COMMENTS:
There's bug #8661 with a similar effect (error condition, then Media Player
doesn't play anything any more)... But the steps that lead to the problem are
different there. Don't know if it's the same.


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.9.1.8)
Gecko/20100228 Gentoo Shiretoko/3.5.8
Comment 1 Andre Klapper maemo.org 2010-03-02 15:18:08 UTC
Hi,
what exactly is out of spec for that file? Any chance to provide a testcase?
Comment 2 Oskar (reporter) 2010-03-02 19:46:42 UTC
(In reply to comment #1)
> Hi,
> what exactly is out of spec for that file? Any chance to provide a testcase?
> 

With "out of spec" I mean "it doesn't play on the N900", in other words it's
"out of the N900's specs". - I don't know if it's a valid file according to the
H.264 spec and, if not, why it isn't. 
The point is that after the Media Player says it doesn't support the file
format for whatever reason (which is OK and not a bug), something gets stuck
and *all* subsequent attempts to play any file fail. 

I cannot provide the files that caused this bug. I'll try to reproduce it with
a video that's - ah - ... oh, that's short enough ;)
(BTW: Does bugzilla support videos as bug attachments? Size-wise? Or is it
generally discouraged?)
Comment 3 Andre Klapper maemo.org 2010-03-02 20:08:07 UTC
Ah. Now this sounds a lot like a duplicate of bug 6823 to me. :)
Comment 4 Andre Klapper maemo.org 2010-03-03 16:55:30 UTC
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 6823 ***