Bug 9330 - Cannot redial a skype contact in the phone UI
: Cannot redial a skype contact in the phone UI
Status: RESOLVED DUPLICATE of bug 8159
Product: Telephony
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-03-01 01:07 UTC by Jeremy Gillespie
Modified: 2010-03-01 18:00 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jeremy Gillespie (reporter) 2010-03-01 01:07:53 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Connect to skype
2. Open up the phone application
3. Navigate to a contact who you previously talked to via skype (skype icon
clearly in list to the left of the contacts avatar picture) using their
telephone number (not their skype name)
4. Click the contact, you now only get the cellular methods to call or SMS. 

EXPECTED OUTCOME:
After clicking the contact you should get an option to call them via skype out.
 It is great that skype is built into the phone but it should be fully
integrated into the phone application allowing quick redialing of contacts via
skype out.  There should be a "Call with Skype" button similar to the button
you get in the phone contacts.

ACTUAL OUTCOME:
There is no option to redial a contact via skype only cell or SMS.  If you want
to call them back you have to take the additional steps of pulling up the
contact, clicking on them and then selecting "Call with Skype".  

REPRODUCIBILITY:
Always

OTHER COMMENTS:
This is likely an enhancement as the functionality works perfectly, it seems to
be a bit of oversight given how integrated skype is into the n900 though. 
Without the option to "Call with skype" from the phone applications contacts
menu it is a little clunky to redial a contact via skype.
Comment 1 Andre Klapper maemo.org 2010-03-01 13:22:00 UTC
Hi Jeremy, thanks for reporting this!
This particular issue has already been reported in our bug tracking system, but
please feel free to report any further bugs you find.

This will be fixed in the next update, see bug 8159.

*** This bug has been marked as a duplicate of bug 8159 ***
Comment 2 Jeremy Gillespie (reporter) 2010-03-01 18:00:08 UTC
Thanks Andre - great news!  I did a search first but must have missed 8159.