Bug 9308 - (int-153351) Media Player doesn't allow to search russian tags
(int-153351)
: Media Player doesn't allow to search russian tags
Status: RESOLVED FIXED
Product: Media player
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-27 14:04 UTC by Dedaulus
Modified: 2010-04-06 23:15 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Dedaulus (reporter) 2010-02-27 14:04:54 UTC
SOFTWARE VERSION:
(Settings > General > About product)
3.2010.02-8
EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Media Player
2. Type "Music"
3. Start typing any russian letters

EXPECTED OUTCOME:
Filter of songs list as you typing letters

ACTUAL OUTCOME:
Nothing happens

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:
Extra Decoders Pack

OTHER COMMENTS:
When I type in english all works fine. I think it's not only russian problem,
but I have only english and russian songs :)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.89 Safari/532.5
Comment 1 Andre Klapper maemo.org 2010-03-01 13:08:01 UTC
Hi,

> 3. Start typing any russian letters

That is missing exact steps. As written, explain in detail what you do (e.g.
tap on OK) and what you see. Please also provide your setting from "Settings >
Text input > Hardware keyboard layout"
Comment 2 Dedaulus (reporter) 2010-03-01 13:35:31 UTC
Hi,

After a songs list has loaded, I open hardware keyboard. "Settings > Text input
> Hardware keyboard layout" is Russian. Then I start typing any word (in
Russian, of course). At the bottom of screen appears text box, in which I can
see what I type now. But nothing happens with the song list. Filter doesn't
work.
Comment 3 Andre Klapper maemo.org 2010-03-01 13:39:50 UTC
So you can successfully enter the first Cyrillic letter in that search field? 
That surprises me. I'm asking because there is one bug that blocks the very
first letter in Cyrillic currently - see bug 8390. The other characters work.

Does the filtering work when removing the first letter again that you had
originally entered?
Comment 4 Dedaulus (reporter) 2010-03-01 14:18:35 UTC
(In reply to comment #3)
> So you can successfully enter the first Cyrillic letter in that search field? 
> That surprises me. I'm asking because there is one bug that blocks the very
> first letter in Cyrillic currently - see bug 8390. The other characters work.
> 
> Does the filtering work when removing the first letter again that you had
> originally entered?
> 

Unfortunately no, removing the first letter doesn't help. And yes, I can start
type with the very first letter in Cyrillic.
Comment 5 Andre Klapper maemo.org 2010-03-01 15:55:57 UTC
Could you send me two such MP3 files by private email so I can test? :)
Comment 6 Dedaulus (reporter) 2010-03-01 16:08:18 UTC
(In reply to comment #5)
> Could you send me two such MP3 files by private email so I can test? :)
> 

Done :)
Comment 7 Andre Klapper maemo.org 2010-03-03 18:04:44 UTC
Thanks. I stored the two music files in the audio clips folder. They were
listed in Media Player afterwards. Then I set my hardware keyboard layout and
also Language to Russian and rebooted.

I can confirm that this does not work.
Comment 8 Alexander Bokovoy 2010-03-03 20:35:55 UTC
Andre, could you get tags from the Tracker and see if they are not damaged?
Comment 9 Andre Klapper maemo.org 2010-03-03 20:50:01 UTC
Alex: This is not a tracker, but an input issue - see the Alias field.

If you still want me to do that, please post the exact command. Thanks :)
Comment 10 Alexander Bokovoy 2010-03-03 22:07:42 UTC
(In reply to comment #9)
> Alex: This is not a tracker, but an input issue - see the Alias field.
> 
> If you still want me to do that, please post the exact command. Thanks :)
> 
I see now, thanks. Let's follow up on the aliased bug.
Comment 11 Andre Klapper maemo.org 2010-03-15 15:04:19 UTC
This has been fixed in package
mediaplayer 1.2-16+0m5
which is part of the internal build version
10.2010.10-9
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 12 Andre Klapper maemo.org 2010-04-06 14:24:38 UTC
*** Bug 9843 has been marked as a duplicate of this bug. ***