Bug 9296 - (int-167903) Exchange event invitations scheduled without a prompt
(int-167903)
: Exchange event invitations scheduled without a prompt
Status: RESOLVED FIXED
Product: Synchronization
Mail for Exchange
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-26 16:40 UTC by lukash
Modified: 2010-05-12 15:43 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description lukash (reporter) 2010-02-26 16:40:25 UTC
SOFTWARE VERSION:
2.2009.51-1.003

EXACT STEPS LEADING TO PROBLEM: 
1. I receive a new email with an event notification from the MfE account

EXPECTED OUTCOME:
I get asked whether I want to attend the event.

ACTUAL OUTCOME:
The event is scheduled for me, whether I want to attend it or not.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Some, nothing related.

OTHER COMMENTS:
In my company, public presentation invitations are sent through Exchange.
However, I'm not interested in most of them. I would like to make the choice
whether to insert the meeting to my calendar myself.

I don't know much about these applications and I don't know what's the expected
behavior for most. But my friend with an iphone can make this choice (some
notification may be sent to the meeting creator, I'm not sure).

A configuration option "Schedule events automatically / Schedule events
manually" and a button on the bottom bar while viewing the invitation email
would be totally sufficient.

For the record, the version of Microsoft Exchange in question seems to be 2007
(guessing just from the year in the copyright...).
Comment 1 Andre Klapper maemo.org 2010-03-01 17:53:33 UTC
Hi, does this also still happen in 3.2010.02-8?
Comment 2 lukash (reporter) 2010-03-03 14:51:41 UTC
Hi, short answer: yes.

Long answer: I had the package mp-frematle-003-pr uninstalled, because I
uninstalled hildon-welcome-default-logo. Therefore the version in system info
didn't update (I reckon). However, I had the underlying packages updated
through apt-get. I installed the mp-frematle-003-pr (version 3.2010.02-8.003)
because of you now and no other packages got updated, so it should be the same.
I didn't test the bug since then, but since there were no changes to the
packages, I don't expect any change in behavior.
Comment 3 Andre Klapper maemo.org 2010-03-12 18:19:26 UTC
Vitaly, do you know if the current behaviour is expected (=unsupported feature
request) or should a prompt be displayed here (=valid bug)?
Comment 4 Andre Klapper maemo.org 2010-04-22 17:18:38 UTC
Vitaly, do you know if the current behaviour is expected (=unsupported feature
request) or should a prompt be displayed here (=valid bug)?
Comment 5 lukash (reporter) 2010-04-23 00:28:56 UTC
If I get your point, you're asking whether the prompt should be there and just
doesn't get displayed due to a bug or the functionality is missing completely?

Well, I do not know. But if I was to make a guess I'd say since its just not
there its most probably because nobody implemented it. Though it is unexpected
behavior for me.
Comment 6 Andre Klapper maemo.org 2010-05-03 19:26:38 UTC
Testing again with 3.2010.02-8 is highly welcome.
Comment 7 lukash (reporter) 2010-05-08 15:03:46 UTC
Why? You wanna keep me entertained? :)

I did. There's no change. I just have one more information:

I turned the calendar synchronization on (I had to turn it off before, the
notifications were bothering me constantly) and tried to force it to schedule
the upcoming meetings for which I already received the invitations. I tried
syncyng the email manually and opening the emails in question. Nothing
happened. Then some time later (about 1 day, though I'm not sure if I checked
the calendar inbetween) all my meetings (upcoming and about 2 weeks back)
appeared in the calendar.

So the meetings get apparently synced to the calendar all at once on some event
unknown to me (or maybe I failed somewhere in the process and its more simple).

However, I believe it should be easy to find in the source code and
implementation of some confirmation should not be too time-consuming either.
Comment 8 Andre Klapper maemo.org 2010-05-08 22:41:45 UTC
(In reply to comment #7)
> Why? You wanna keep me entertained? :)

Not really, looks like I'm too stupid to read my previous comments before
asking. Sorry...
Comment 9 Andre Klapper maemo.org 2010-05-12 15:43:23 UTC
"3.2010.02-8 doesn't have "meeting invitations" feature. All invitations are
shown as regular emails. It is implemented on the next public update (PR1.2).

Even when it is not implemented, Exchange server/Outlook can be configured with
"auto-accept" feature or with a feature when it creates all unconfirmed events
as "tentative" events in user's calendar. This is not controlled by activesync
protocol at all."

Closing as FIXED.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/