Bug 9272 - (int-158524) TDC (Denmark) GPRS settings are "incorrect" (or could be better)
(int-158524)
: TDC (Denmark) GPRS settings are "incorrect" (or could be better)
Status: RESOLVED FIXED
Product: Connectivity
Operator Setup Wizard
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: phone-settings-wizard-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-25 16:19 UTC by Lasse Aagren
Modified: 2010-05-19 17:20 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Lasse Aagren (reporter) 2010-02-25 16:19:36 UTC
SOFTWARE VERSION: 2.2010.02-8
EXACT STEPS LEADING TO PROBLEM: 
1. Connect to internet via GPRS, using prefilled TDC-gprs operator settings.

EXPECTED OUTCOME:

Successful unblocked connection

ACTUAL OUTCOME:

Successful blocked connection. Only port 80 and 443 allowed outgoing to the
best of my knowledge. Nevertheless many ports are blocked.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
irrelevant

OTHER COMMENTS:

The danish mobile operator TDC operates with two different APN settings: "wap"
and "internet". The first one has many outgoing ports blocked, the other is
unblcoked. I think that it would be prefered by many to have APN set to
"internet" by default.

Current settings are:
APN:wap
username: <none>
password: <none>

as seen in /etc/operator_settings

Correct settings are:
APN:internet
username: <none>
password: <none>

As seen here:
http://kundeservice.tdc.dk/privat/faq.php?id=20063







SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. 
2. 
3. 

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.2) Gecko/20100115 Firefox/3.6
Comment 1 Lasse Aagren (reporter) 2010-02-25 16:26:06 UTC
sadly I mistyped software version. Correct version is 3.2010.02-8.

And I forgot to delete the buttom 20-25 lines before submitting, sorry.
Hopefully someone with the right rights can change those errors.

/Lasse
Comment 2 Andre Klapper maemo.org 2010-02-25 22:39:54 UTC
Hi Lasse, thanks for reporting this!
Comment 3 Per Wille 2010-02-26 00:05:52 UTC
I can confirm this. APN for TDC is indeed wrong.
Comment 4 Lasse Aagren (reporter) 2010-03-04 13:38:55 UTC
Another correction:

This seems only to a problem with firmwares other than the newest. A friend
with a TDC account, just tested it after a flash with:

RX-51_2009SE_1.2009.41-1.VANILLA_PR_EMMC_MR0_ARM.bin
and
RX-51_2009SE_3.2010.02-8_PR_COMBINED_MR0_ARM.bin

he got a connection curiously called "Telmore Internet" (Telmore are a virtual
operator, piggybacking on TDC network), but with the correct APN settings.
Comment 5 Venomrush 2010-03-04 19:49:44 UTC
(In reply to comment #4)
> Another correction:
> 
> This seems only to a problem with firmwares other than the newest. A friend
> with a TDC account, just tested it after a flash with:
> 
> RX-51_2009SE_1.2009.41-1.VANILLA_PR_EMMC_MR0_ARM.bin
> and
> RX-51_2009SE_3.2010.02-8_PR_COMBINED_MR0_ARM.bin
> 
> he got a connection curiously called "Telmore Internet" (Telmore are a virtual
> operator, piggybacking on TDC network), but with the correct APN settings.
> 

Is this problem for firmwares prior/before PR1.1.1 (3.2010.02) only?
Comment 6 Lasse Aagren (reporter) 2010-03-04 19:54:26 UTC
> 
> Is this problem for firmwares prior/before PR1.1.1 (3.2010.02) only?
> 

Yes - the GPRS/3g connections works as it should in PR1.1.1 (3.2010.02) (other
than a wrong name - should be something with TDC, not Telmore)

I previous versions there was the problem with the "wrong" APN.
Comment 7 Andre Klapper maemo.org 2010-03-08 20:06:57 UTC
*** Bug 9452 has been marked as a duplicate of this bug. ***
Comment 8 kdebjp 2010-03-08 21:36:25 UTC
I've copied the following from bug #9452:

"I can see that several other operator settings in /etc/operation_settings have
been set to use "wap" or something similar as the APN. Seems odd for a device
that doesn't feature a WAP browser. It would be good if Nokia could check that
this is actually correct as many other N900 users will otherwise potentially
experience mail problems and similar.
"
Comment 9 Andre Klapper maemo.org 2010-03-17 04:47:02 UTC
This has been fixed in package
operator-wizard-settings 2.0.49+0m5
which is part of the internal build version
10.2010.11-2
(Note: 2009/2010 is the year, and the number after is the week.)

It is now:
238 1 TDC Mobil INTERNET TDC www 3G+GPRS internet

The next public update will include the fix. (This is not always already the
next public update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/