Bug 9268 - FAX numbers show as "Phone (unsupported)" and is missing field
: FAX numbers show as "Phone (unsupported)" and is missing field
Status: RESOLVED DUPLICATE of bug 5742
Product: Contacts
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-25 14:19 UTC by Rüdiger Schiller
Modified: 2010-02-25 18:46 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Rüdiger Schiller (reporter) 2010-02-25 14:19:39 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Import contact with FAX number to Phone or enter number via Nokia PC-Suite

2. Enter FAX number in Contacts-App

EXPECTED OUTCOME:
1. Contacts-App shows imported or entered FAX number as "FAX [,([home,work])]"
with button in edit-mode.

2. You press "Add field" in Contacts-App contact edit-mode and get the context
for "FAX [,([home,work])]".

ACTUAL OUTCOME:
1. FAX numbers show as "Phone (unsupported)" with no button in edit-mode.

2. Fields "FAX [,([home,work])]" are missing. (only addable with PC-Suite or
with importing of contacts file, within GUIs)

REPRODUCIBILITY:
always

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.8)
Gecko/20100202 Firefox/3.5.8 (.NET CLR 3.5.30729)
Comment 1 Lucas Maneos 2010-02-25 17:15:21 UTC
The "(unsupported)" part is not a bug, as it doesn't make sense to dial those
numbers - see bug 5742 for background.

Andre, do you know if the implementation of bug 5742 allows editing the field
type and/or entering fax numbers on-device?
Comment 2 Andre Klapper maemo.org 2010-02-25 17:44:41 UTC
(In reply to comment #1)
> The "(unsupported)" part is not a bug, as it doesn't make sense to dial those
> numbers - see bug 5742 for background.
> 
> Andre, do you know if the implementation of bug 5742 allows editing the field
> type and/or entering fax numbers on-device?

Internal testing for bug 5742 wrote "I am able to change the field type in Edit
contact dialog."
Does this make this report a duplicate of bug 5742?
Comment 3 Lucas Maneos 2010-02-25 18:20:26 UTC
I guess.  The descriptions are a bit different (new vs imported contact, plus 
fax number handling changed in PR1.1 a bit) but if the implementation of bug
5742 covers what is requested here it makes sense to mark it as such.

Rüdiger: feel free to re-test once PR1.2 is released and reopen it doesn't
cover this bug report.

*** This bug has been marked as a duplicate of bug 5742 ***
Comment 4 Rüdiger Schiller (reporter) 2010-02-25 18:46:34 UTC
(In reply to comment #3)
> I guess.  The descriptions are a bit different (new vs imported contact, plus 
> fax number handling changed in PR1.1 a bit) but if the implementation of bug
> 5742 covers what is requested here it makes sense to mark it as such.
> 
> Rüdiger: feel free to re-test once PR1.2 is released and reopen it doesn't
> cover this bug report.
> 
> *** This bug has been marked as a duplicate of bug 5742 ***
> 

solution would be to have not dial-able editable Fax entries "FAX
[,([home,work])] (unsupported)" , at least. 
Sounds like you already have this in your internal release somewhere, don't
you? we will see in PR1.2 ;)

thanks

maybe a fax plugin for telepathy will popup some day