Bug 922 - Reboots with full flash
: Reboots with full flash
Status: RESOLVED FIXED
Product: System software
File system
: 2.0
: All Maemo
: Medium normal with 1 vote (vote)
: 3.0
Assigned To: unassigned
: file-system-bugs
:
: ITOS2007HE-garage
:
:
  Show dependency tree
 
Reported: 2006-12-29 19:02 UTC by Laurent GUERBY
Modified: 2008-12-06 16:49 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Laurent GUERBY (reporter) 2006-12-29 19:02:17 UTC
For the past few days, my Nokia 770 (purchased one year ago) has been quite
flakey, sometimes it freezes without reason, when I reboot it freezes quickly, I
even had a few reboots in a row (I had to remove the battery).

After a while it came back to normal, and I noticed the following in dmesg:

[  835.383911] JFFS2 notice: (445) check_node_data: wrong data CRC in data node
at 0x06734000: read 0xb535e9c0, calculated 0x31b18693.

Note that when it was flakey, I managed once to get a working XTerm and noticed
that "df -h" gave only a few kB free on / whereas I have about 30MB free (as it
shows now). I haven't installed a new package in the past few weeks (I have IT
2006.2)

Any idea of what's going on?
Comment 1 Eero Tamminen nokia 2007-01-02 16:51:32 UTC
> [  835.383911] JFFS2 notice: (445) check_node_data: wrong data CRC in data 
> node at 0x06734000: read 0xb535e9c0, calculated 0x31b18693.

AFAIK this means that the device was booted without unmounting the filesystem
and because some Flash block wasn't fully written, it's CRC checksum is 
incorrect.  That block needs just to be garbage collected, it's not a "serious" 
error (the error disappears when that block is GCed).


> "df -h" gave only a few kB free on /

Full flash means that JFFS2 filesystem takes more memory and CPU.


> when I reboot it freezes quickly, I even had a few reboots in a row

If the flash has been full and then stuff is removed, on reboot JFFS2
will need to do garbage collecting to be able to use that space.
AFAIK while this is being done, writes to the Flash are blocked.
Maybe something blocking on write at bootup causes the reboot?

Flash full issues have been discussed on the maemo mailing list.
Comment 2 Laurent GUERBY (reporter) 2007-01-02 21:20:17 UTC
Ok, your explanations makes sense, thanks!

Note that I didn't add anything, so it's probably the unclean mount that created
the "full disk" state, I didn't remove anything and now it's back to 30MB free
and my Nokia looks stable again.

May be the situation could be handled more gracefully at boot in some future
version: window with progressbar mentionning "cleaning the file system", plus
warning to the user to free some space if after cleanup it's still near full.
Comment 3 Eero Tamminen nokia 2007-01-25 17:37:42 UTC
(In reply to comment #2)
> May be the situation could be handled more gracefully at boot in some future
> version: window with progressbar mentionning "cleaning the file system", plus
> warning to the user to free some space if after cleanup it's still near full.

This happens completely inside the kernel, Linux filesystem drivers don't have
any "doing garbage collecting" notification API to the user space and there's
no UI (X server etc) running when the device boots up.
Comment 5 Eero Tamminen nokia 2008-01-15 13:53:57 UTC
I'm not sure what this should be marked.

The JFFS2 messages are not a bug, just information in a scary format. ->
invalid?

The reboots with full flash are prevented with later releases, this concerns
only (early?) 770 releases. -> fixed?
Comment 6 Eero Tamminen nokia 2008-02-29 15:49:12 UTC
(In reply to comment #5)
> I'm not sure what this should be marked.
> 
> The JFFS2 messages are not a bug, just information in a scary format. ->
> invalid?
> 
> The reboots with full flash are prevented with later releases, this concerns
> only (early?) 770 releases. -> fixed?

Marking as fixed.