Bug 9210 - 'USB already in use' message even when nothing is using it
: 'USB already in use' message even when nothing is using it
Status: RESOLVED WORKSFORME
Product: System software
mmc-and-usb
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: Kimmo Hämäläinen
: mmc-and-usb-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-02-22 15:10 UTC by Venomrush
Modified: 2010-03-03 22:03 UTC (History)
1 user (show)

See Also:


Attachments
Syslog (228.90 KB, text/plain)
2010-02-22 20:00 UTC, Venomrush
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Venomrush (reporter) 2010-02-22 15:10:05 UTC
SOFTWARE VERSION:
1.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Connect USB cable to the N900
2. Select Mass Memory on the pop-up prompt

EXPECTED OUTCOME:
Device connect to PC as mass memory mode

ACTUAL OUTCOME:
Device shown 'USB already in use'

REPRODUCIBILITY:
3/10

OTHER COMMENTS:
Unplugging cable and replugging did not help when the issue occurs, but
restarting does.

I have checked nothing (including applications) unusual were running in the
background.
Comment 1 Andre Klapper maemo.org 2010-02-22 16:12:17 UTC
Hi, what additional software is installed?

If this happens again, can you please provide a syslog and the output of:
* cat /sys/devices/platform/musb_hdrc/mode 
* cat /sys/devices/platform/musb_hdrc/charger 
for both when it does not work and when it does work?
Comment 2 Kimmo Hämäläinen nokia 2010-02-22 16:49:09 UTC
please attach the syslog, it would tell why it failed to unmount it...
Comment 3 Venomrush (reporter) 2010-02-22 19:35:33 UTC
Only OpenSSH client+server was installed as I've just flashed the device.

Could you remind me by giving some instructions on how to install, run and
extract syslog logs please?
Comment 4 Andre Klapper maemo.org 2010-02-22 19:39:18 UTC
See http://wiki.maemo.org/Documentation/devtools/maemo5/syslog and
http://wiki.maemo.org/Documentation/devtools/maemo5#Installation for more
information.
If you are not used to Linux, after creating the syslog file you can copy the
syslog file to those folders that are visible in the Maemo File Manager by:
  * Starting X Terminal
  * cp /var/log/syslog /home/user/MyDocs/.documents/
After that you can find the file in the Maemo File Manager by going to Nokia
N900 > Documents.
Comment 5 Venomrush (reporter) 2010-02-22 20:00:16 UTC
Created an attachment (id=2343) [details]
Syslog

Syslog from newly flashed 2.2009.51-1 

I attempted to plug and unplug multiple times, roughly 10, in which 2 failed.
After the first failed, it worked again for serveral plug/unplug then failed
again which at this point I stopped and extract the log.
Comment 6 Kimmo Hämäläinen nokia 2010-02-23 10:06:58 UTC
There is one case when unmounting fails because of someone using the card,
possibly tracker, and another case when it fails because the USB cable was
disconnected too early.  Nothing indicative of a bug...
Comment 7 Venomrush (reporter) 2010-02-23 10:12:55 UTC
(In reply to comment #6)
> There is one case when unmounting fails because of someone using the card,
> possibly tracker, and another case when it fails because the USB cable was
> disconnected too early.  Nothing indicative of a bug...
> 

What do you mean by card?
I don't use any external card and the phone was in Desktop with nothing running
in the background.

Cable disconnect too early shouldn't affect when the cable is plugged back in?
Comment 8 Kimmo Hämäläinen nokia 2010-02-23 10:24:26 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > There is one case when unmounting fails because of someone using the card,
> > possibly tracker, and another case when it fails because the USB cable was
> > disconnected too early.  Nothing indicative of a bug...
> > 
> 
> What do you mean by card?

The 32GB internal, non-removable memory card that is inside your device...  We
have a 28GB FAT partition on it that is shown to the PC if (and only if) it can
be unmounted first.

> I don't use any external card and the phone was in Desktop with nothing running
> in the background.

There is always lots of processes running, "trackerd" is one of them. You can
see the running processes of the system by issuing "ps xau" in X Terminal.

> Cable disconnect too early shouldn't affect when the cable is plugged back in?

It makes the earlier effort to fail of course, which shows in the syslog.
Nothing more serious.
Comment 9 Venomrush (reporter) 2010-03-01 10:50:28 UTC
Can we somehow reduce the possibility of this error from popping up for
aggressive users?
Comment 10 Venomrush (reporter) 2010-03-03 22:03:26 UTC
Closing as WORKSFORME