Bug 9107 - (int-157521) Telenor (Sweden) not automatically syncing time at all
(int-157521)
: Telenor (Sweden) not automatically syncing time at all
Status: RESOLVED INVALID
Product: Telephony
General
: 5.0/(3.2010.02-8)
: All Maemo
: Unspecified normal with 3 votes (vote)
: ---
Assigned To: unassigned
: telephony-general-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-02-17 15:49 UTC by Pierre Ossman
Modified: 2010-06-28 13:17 UTC (History)
6 users (show)

See Also:


Attachments
UI with telia (works) (88.97 KB, image/png)
2010-05-27 14:12 UTC, Pierre Ossman
Details
UI with Telenor (doesn't work) (84.74 KB, image/png)
2010-05-27 14:13 UTC, Pierre Ossman
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Pierre Ossman (reporter) 2010-02-17 15:49:57 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Open Settings->Date and time
2. Click "Update automatically"

EXPECTED OUTCOME:
Clock is correct.

ACTUAL OUTCOME:
Clock is several minutes out of sync.

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I'm assuming it is syncing against the GSM/UMTS network, so I'm filing this
under the Telephony component. Feel free to move if that is wrong.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.1.6)
Gecko/20100107 Fedora/3.5.6-1.fc12 Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2010-02-17 18:14:39 UTC
Hi,
which provider and country is this about?
Comment 2 Pierre Ossman (reporter) 2010-02-17 19:06:52 UTC
This is Telenor in Sweden.
Comment 3 Andre Klapper maemo.org 2010-02-18 15:46:01 UTC
Do you have any other phone to check this with Telenor too?
Might be a provider issue instead of a software bug...
Is the time of SMS sending/receiving correct or also several minutes wrong?
Comment 4 Pierre Ossman (reporter) 2010-02-19 00:44:04 UTC
The time sync feature is fairly rare, and I don't have any other such phones to
test with.

Haven't checked the sms times, but I'll have a look at that.

Is there any log to see when/if it syncs and what time it is getting from the
network?
Comment 5 Andre Klapper maemo.org 2010-04-23 21:59:59 UTC
"We cant help if swedish operators have wrong time. we just show time that
comes
from network"
Comment 6 Pierre Ossman (reporter) 2010-04-23 22:58:16 UTC
It is not syncing at all though, not to an incorrect time. If I manually
readjust to any offset (compared to the correct time), that offset will remain.
Comment 7 Andre Klapper maemo.org 2010-04-23 23:13:47 UTC
(In reply to comment #6)
> It is not syncing at all though

That sounds new. What does that mean exactly?
Comment 8 Pierre Ossman (reporter) 2010-04-23 23:24:50 UTC
If I disable the sync, adjust the clock to be 30 minutes behind, and reenable
sync, it will still be 30 minutes behind the next day. If the sync was working,
but Telenor is sending out crud, then I'd expect the phone to jump back to the
same error (initially the phone was off by just a few minutes).

I also notice I forgot to answer this: "Is the time of SMS sending/receiving
correct or also several minutes wrong?"

The SMS times also exhibit problems. My sending times seem to be based on the
phones clock, but the receiving times come from something external. So when the
clock on the phone is ahead, the timestamps will make it look like the reply
came before the outgoing message. Fortunately the phone doesn't sort based on
time...
Comment 9 Andre Klapper maemo.org 2010-05-05 15:36:21 UTC
Did you try to ask Telenor if they support this at all?
Comment 10 Xavier Bestel 2010-05-10 19:42:15 UTC
Maybe the phone should warn that it can't sync agains the phone provider
because it doesn't even hint that it's a GSM time sync, and I naively thought
it would sync against GPS signals (at least ig GSM time is unavailable).
Experience showed it's not the case.
Comment 11 Xavier Bestel 2010-05-10 19:43:32 UTC
*** This bug has been confirmed by popular vote. ***
Comment 12 Neil MacLeod maemo.org 2010-05-11 01:10:15 UTC
SOFTWARE VERSION:
3.2010.02-8

"Update automatically" enabled and it has no effect whatsoever (T-Mobile UK -
my N900 is running 5 minutes fast, uptime 6 days 20 hours).

Either T-Mobile UK don't enable the time to be synced, or the N900 isn't
attempting the sync - how can we tell? How often does it sync? Do we even know
that the N900 syncs against the mobile network, or does it sync against an ntp
time server?

There don't appear to be any relevant ntp entries in syslog - should there be?
Comment 13 j.wender 2010-05-11 09:58:22 UTC
I can confirm this problem with t-mobile in Germany. With my former E61 the
system time was set correctly from GSM, with the N900 it is about 2-3 mins in
the future.
Comment 14 Pierre Ossman (reporter) 2010-05-12 21:08:01 UTC
(In reply to comment #9)
> Did you try to ask Telenor if they support this at all?
> 

Nope, I haven't. The support tends to be anything but helpful so I've found
that you generally need to do a lot of research yourself first as you will get
lied to. Which is why it would be nice to get some logs from the phone to know
if they're sending out crap, or nothing at all.
Comment 15 Chris Samuel 2010-05-27 11:18:35 UTC
In my experience you can tell if the provider is sending NITZ information you
go to the Clock application, then click on the time to get the settings.  When
you click the "Update automatically" you will see the headings appear for "Time
zone", "Date" and "Time".

If there is no information next to those then there is no NITZ information
being broadcast, if NITZ is in use you should see the settings from the phone
there.

Whether or not NITZ is available can apparently differ from region to region
within the same provider.

Here on Vodafone in Australia there is no NITZ information, but when I was in
the US recently AT&T was broadcasting that (hence I know what it looks like
when NITZ is available).
Comment 16 Pierre Ossman (reporter) 2010-05-27 11:51:46 UTC
That's very interesting. In that case the UI should preferably be a bit more
friendly and show something like "Not available" instead of just blank fields.

Now that I know what to expect, and what the system is called, I've started
contacting my provider to see if I can get this fixed. Many thanks.
Comment 17 Pierre Ossman (reporter) 2010-05-27 14:12:12 UTC
Created an attachment (id=2756) [details]
UI with telia (works)
Comment 18 Pierre Ossman (reporter) 2010-05-27 14:13:23 UTC
Created an attachment (id=2757) [details]
UI with Telenor (doesn't work)
Comment 19 Pierre Ossman (reporter) 2010-05-27 14:15:21 UTC
Tested with another provider here (Telia) and you see the mentioned UI changes
there. I've attached screen shots so that other people can see how it's
supposed to look.

Telenor is blaming the phone, but I think they're just full of shit and just
trying to avoid doing anything. I'll try and find some more decent way of
getting this issue noticed over there...
Comment 20 Xavier Bestel 2010-05-27 15:07:41 UTC
Okaye, now I know why it doesn't work !
I'd like to be sure it's because of the provider and not because of the phone
though. And if it's the former, a clearer indication in the UI would be very
welcome.
Comment 21 Simon Josefsson 2010-05-27 16:21:26 UTC
This happens with Swedish operator Tele2 as well.  Time sync was working when I
was visiting Ă…land (Finland) recently.

I suggest using NTP for time syncing as an option.  And to clarify that today
it synchronize against GSM/UMTS, which isn't clear now.  Before reading this
bug report, I assumed "time sync" was for NTP and that there were some problem
with NTP.

/Simon
Comment 22 Neil MacLeod maemo.org 2010-05-27 18:01:52 UTC
(In reply to comment #16)
> That's very interesting. In that case the UI should preferably be a bit more
> friendly and show something like "Not available" instead of just blank fields.
> 
> Now that I know what to expect, and what the system is called, I've started
> contacting my provider to see if I can get this fixed. Many thanks.
> 

Agreed - it's not available from T-Mobile in the UK. Also, it seems odd that
ntpd syncing with an internet time server isn't available by default too. Even
if the current timezone information isn't available, it would be useful to have
a correct clock (as this is what I took "Update automatically" to mean).

Right now, I have to set the time manually, and the N900 real-time clock is not
that accurate.
Comment 23 Xavier Bestel 2010-05-27 19:28:30 UTC
Classic ntp is perhaps a bit too network-intensive. But some kind of sync with
the GPS time once per day would be already very good.
Comment 24 Neil MacLeod maemo.org 2010-05-27 19:35:15 UTC
(In reply to comment #23)
> Classic ntp is perhaps a bit too network-intensive. But some kind of sync with
> the GPS time once per day would be already very good.
> 

ntp once a day wouldn't be an issue, even once a week would be fine. If no data
connection is available, then the the N900 could grab the time from GPS,
assuming it's available. These are all viable alternatives to the network time
option, which is clearly not universally supported, and the option "Update
automatically" is thus very misleading/confusing without alternative time
sources.

It's not as if the clock has to be synced often, just often enough to
counteract the drift due to the inaccuracy of the hardware.
Comment 25 Andre Klapper maemo.org 2010-06-28 13:17:27 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > It is not syncing at all though
> 
> That sounds new. What does that mean exactly?

Please file a new report.
This one was and is INVALID as per comment 5.