Bug 9085 - (int157911/int-214666) Camera lens is returned too hard back to home position
(int157911/int-214666)
: Camera lens is returned too hard back to home position
Status: RESOLVED FIXED
Product: Images and Camera
Camera
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified major with 6 votes (vote)
: Harmattan
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-16 21:57 UTC by Anttu Koski
Modified: 2015-01-09 08:49 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Anttu Koski (reporter) 2010-02-16 21:57:55 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Start the camera application
2. Activate macro mode
3. Focus to an object as near as possible and half-press to focus
4. Ensure that the focus indicator is screen, if not try again from step 3
5. Full-press to take a photo
6. Listen what happens after taking a photo

EXPECTED OUTCOME:

Picture is taken and there's no or very little sound from moving the focus lens
back to home position.

ACTUAL OUTCOME:

The focusing lens is moved back to home position with full speed and it makes a
clearly audible click.

REPRODUCIBILITY:
Always when focused near enough. The sound can be heared also when focusing to
normal distance, but it's not so loud and critical.

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
This is a common problem with some camera phones. Moving the focusing lens back
to home position too quickly will cause it bump the mechanical stop too hard.
Repeating this many times will cause the camera lens to break quickly. This
needs to be fixed or else there will be a lot of broken camera modules soon...

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fi; rv:1.9.2)
Gecko/20100115 Firefox/3.6
Comment 1 Andre Klapper maemo.org 2010-02-17 14:24:49 UTC
Hi,
I can confirm this, but Maemo is a software platform, hence bug reports about
hardware bugs or enhancement requests are invalid in bugs.maemo.org.
Please contact Nokia Care services via www.nokia.com. If your report is about
an enhancement idea for the hardware, please file a ticket in the Maemo
Brainstorm at http://maemo.org/community/brainstorm/ instead as hardware is out
of scope for maemo.org Bugzilla. Thanks!
Comment 2 Anttu Koski (reporter) 2010-02-17 18:58:20 UTC
This is not a hardware fault, but a camera driver bug.

The camera driver can control the speed which the focus lens is moved. It
should work so that it uses lower speed when moving the lens towards the home
position for a longer distance.

The focusing lens is controlled by a voice coil. There's a spring that keeps
the lens in a home position (mechanical stop) when no power is used. When more
power is given, the farther from the home position the lens will move. When
lens is in macro mode, maximum power is needed to keep the lens farthest away
from the home position. Now, when exiting the macro mode, it seems that the
camera driver sets the power to zero immediately, which causes the spring to
violently smash the lens towards the mechanical stop. Instead the camera driver
should slow down the power gently, so that there's an opposing force to the
spring that slows the lens movement down.

I can try to create a picture and explain better, if this is not sufficient :)
I think the people responsible for the camera driver autofocus driver should
understand the problem.
Comment 3 Mohammad Abu-Garbeyyeh 2010-03-16 23:26:26 UTC
I can confirm this bug, it was also present in preproduction models.
Comment 4 Anttu Koski (reporter) 2010-04-19 16:02:45 UTC
Any plans for fixing this?
Comment 5 mail 2010-09-30 13:52:28 UTC
Yay, my phone seems to be a victim of this bug. -_-
Is there any way to prevent this (presuming it can be fixed any way again)?
Like "when you use macro mode, first switch to landscape before closing camera
app"?
Comment 6 Andre Klapper maemo.org 2011-05-05 17:32:31 UTC
This issue has been FIXED for Harmattan (the software version after Maemo5).

According to Nokia this unfortunately is a WONTFIX for Maemo5.