Bug 9077 - Redialling a saved contact's SIP call from the calls log dials using a cell connection
: Redialling a saved contact's SIP call from the calls log dials using a cell c...
Status: RESOLVED DUPLICATE of bug 8159
Product: Telephony
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-16 13:21 UTC by Christian Sarrasin
Modified: 2010-02-16 15:20 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Christian Sarrasin (reporter) 2010-02-16 13:21:50 UTC
SOFTWARE VERSION:
Maemo 5
2.2009.51-1.203.2

EXACT STEPS LEADING TO PROBLEM: 
1. Select a saved contact, choose their number and select to dial over SIP
2. End the call
3. Immediately select that same call at the top of the call log (notice: the
call entry is adorned with a "SIP" icon in the second to last column)
4. A selection screen appears, offering the following choices: "Phone" or "SMS"
- there is no explicit SIP choice
5. Select "Phone" to redial the call   

EXPECTED OUTCOME:

One would expect the redialed call to go via the same channel as the original
call; or at least to be given an explicit choice of channel (cell or SIP).

ACTUAL OUTCOME:

The call actually always occurs over the cell network; there is no way to
direct the phone to re-dial over SIP.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
This bug only seems to occur for redials to saved contact numbers.  If the call
is dialed manually using the numeric keypad, a subsequent redial correctly
occurs over SIP (note: the number in the call log is prefixed with "SIP:")

Here is the use case: I was talking to someone in continental Europe from the
Far East over SIP with a UK N900 when that call got dropped.  I instinctively
used the call log to redial my contact, expecting the phone to use the same
channel.  Fortunately, I noticed the shenanigan before it was too late - cost
of the bug for 51 secs: £1.98.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.7)
Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Comment 1 Andre Klapper maemo.org 2010-02-16 15:20:16 UTC
Hi Christian, thanks for reporting this! Resetting Severity as per
https://bugs.maemo.org/page.cgi?id=fields.html#bug_severity .

This particular issue has already been reported in our bug tracking system, but
please feel free to report any further bugs you find. Also feel encouraged to
vote for the original bug report if interested.

*** This bug has been marked as a duplicate of bug 8159 ***