Bug 9070 - Autobuilder can't find "sharing-dialog-dev" (the package is in the SDK repo)
: Autobuilder can't find "sharing-dialog-dev" (the package is in the SDK repo)
Status: VERIFIED FIXED
Product: maemo.org Website
Autobuilder
: 5.0
: All Maemo
: Unspecified critical with 21 votes (vote)
: ---
Assigned To: Niels Breet
: repositories@maemo.bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-16 02:58 UTC by Thomas Perl
Modified: 2010-04-26 12:49 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Thomas Perl (reporter) 2010-02-16 02:58:48 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Try to build a package with a build-dependency on sharing-dialog-dev (e.g.
maepad 1.2) in the autobuilder

EXPECTED OUTCOME:

The build works ;)

ACTUAL OUTCOME:

E: Couldn't find package sharing-dialog-dev

https://garage.maemo.org/builder/fremantle/maepad_1.2/armel.root.log.FAILED.txt

REPRODUCIBILITY:
once (right now)

OTHER COMMENTS:

The "sharing-dialog-dev" package is available in the nokia binaries repository.

Might be related to bug 6177.

After you fix it, can you please re-queue the maepad 1.2 build? Thanks :)
Comment 1 Thomas Perl (reporter) 2010-02-18 00:04:02 UTC
Any progress or ETA on this one? I can't really publish new versions of my
application on Maemo.org this way, which is quite annoying.
Comment 2 Andrew Flegg maemo.org 2010-03-08 15:03:09 UTC
Increasing severity as it blocks the publishing of any package with this
dependency.
Comment 3 Niels Breet maemo.org 2010-03-09 11:12:12 UTC
Basically this won't be fixed before PR1.2 is released. Due to the not
backwards compatibility of PR1.1, we can not run that SDK on the builder as
that will create a problem for people with older firmware.

From PR1.2 this issue has been worked around by using a different fremantle-1.2
repository for Extras.
Comment 4 Andrew Flegg maemo.org 2010-04-26 12:47:23 UTC
With the use of the PR1.2 SDK, and .symbol files, this should now be FIXED.
Comment 5 Thomas Perl (reporter) 2010-04-26 12:49:21 UTC
Verifying that this is fixed now. The bug can be closed.