Bug 9057 - (int-154505) Wifi wont connect to Dlink DI-524 using WEP
(int-154505)
: Wifi wont connect to Dlink DI-524 using WEP
Status: RESOLVED FIXED
Product: Connectivity
WiFi
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-15 03:27 UTC by Santiago BG
Modified: 2010-03-15 20:52 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Santiago BG (reporter) 2010-02-15 03:27:52 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Nokia N900
Maemo 5
Version 2.2009.51-1.002

EXACT STEPS LEADING TO PROBLEM: 
1. Received a New N900 yesterday
2. Setup the date, time, and wifi connection to my AP (D-link DI-524 with Wep).
The wifi connection is working.
3. Open the App Manager and search for Updates.
4. Apply the only update found (about 21Mb)
5. After the phone reboots, Wifi reports "Network connection error. Try again?"
6. Tried many more times, however the phone was unable to establish the Wifi
connection.


EXPECTED OUTCOME:
After the update, Wifi should connect to the configured Access Point

ACTUAL OUTCOME:
After the update, the phone can't connect to any Wifi Access Points.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
After this, I installed the Nokia PC-Suite and upgraded the phone to
2.2009.51-1.002. Still, the phone can't connect via Wifi to any Access Points.


OTHER COMMENTS:


dmesg shows:
w112xx spi4.0: firmware: requesting w11251-fw.bin
w11251: 151 tx blocks at 0x3b789, 35 rx blocks at 0x3a780
w11251: firmware booted (Rev 4.0.4.3.6)
w11251: down
w11251: 151 tx blocks at 0x3b789, 35 rx blocks at 0x3a780
w11251: firmware booted (Rev 4.0.4.3.6)
wlan0: authenticate with AP 00:17:9a:f1:xx:xx
wlan0: authenticate with AP 00:17:9a:f1:xx:xx
wlan0: authenticate with AP 00:17:9a:f1:xx:xx
wlan0: authentication with AP 00:17:9a:f1:xx:xx timed out.
The wlan0 messages repeats for about 7 times (the 4 lines of messages), and
then …
w11251: down
Comment 1 Andre Klapper maemo.org 2010-02-15 22:24:15 UTC
Hi Santiago,
Thanks for reporting this.

Is this about WPA TKIP? If so, this is probably the same issue as bug 6173 as
described in bug 6173 comment 29.
Comment 2 Santiago BG (reporter) 2010-02-16 08:03:28 UTC
Hi Andre,

I'm using a Dlink DI-524, however, the Access point is using WEP, not WPA TKIP.
Comment 3 Santiago BG (reporter) 2010-02-17 16:00:58 UTC
Today I updated the firmware to 3.2010.02.8 on my N900. 

Still, no joy. The phone wont connect to the Di-524 using WEP.
Comment 4 Santiago BG (reporter) 2010-02-25 07:13:02 UTC
I still can't connect the N900 to any Wifi network. 

This is a new - expensive device. Isn't this kind of features (like Wifi)
supposed to work out of the box???

I'm very disappointed by Nokia products and support.
Comment 5 ext-jason.rudd@nokia.com nokia 2010-03-09 13:57:55 UTC
3.2010.02.8 is PR 1.1, this fix went into 10.2010.08-5 and will be released as
part of PR 1.2. I have tested with DI-624 and there are no problems. The
release is due anytime now.

Note: The problem fixed can be worked around; delete all APs from the AP list
in "Internet Connections" and reboot N900. Upon reboot, connect to your WEP AP,
you should then always be able to connect to your AP, that is, until you
connect to a WPA AP, then WEP will fail again until you repeat these steps.

As I say the fix we be released in the next Product Release, which is due soon.
Comment 6 Andre Klapper maemo.org 2010-03-10 21:02:01 UTC
This has been fixed in package
osso-wlan 3.0.16+0m5
which is part of the internal build version
10.2010.08-5
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:52:42 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).