Bug 9048 - "Internal Error: Application 'Calendar' closed when importing ics file
: "Internal Error: Application 'Calendar' closed when importing ics file
Status: RESOLVED FIXED
Product: Calendar
General
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: calendar-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-13 23:11 UTC by Matthias B.
Modified: 2010-03-15 20:51 UTC (History)
1 user (show)

See Also:


Attachments
Attempting to import into Calendar crashes the app (804 bytes, text/plain)
2010-02-13 23:12 UTC, Matthias B.
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Matthias B. (reporter) 2010-02-13 23:11:36 UTC
SOFTWARE VERSION:
N900, Maemo 5, 2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Put attached file crash2.ics onto device
2. Open File Manager and click crash2.ics
3. Select any Calendar to import into

EXPECTED OUTCOME:
Calendar entries are imported

ACTUAL OUTCOME:
"Internal Error: Application 'Calendar' closed

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
nothing relevant

OTHER COMMENTS:
I create the ics file by exporting from Oracle Calendar. I deleted entries
until I had isolated the one causing the crash. The result is the file
crash2.ics. The problem seems to be related to the RDATE field. If I delete it,
the crash does not occur.
Comment 1 Matthias B. (reporter) 2010-02-13 23:12:44 UTC
Created an attachment (id=2286) [details]
Attempting to import into Calendar crashes the app

Attempting to import this ics file into Calendar crashes it.
Comment 2 Matthias B. (reporter) 2010-02-13 23:15:57 UTC
If you have any ideas how I can fix Oracle Calendar's ics files to import
correctly (I'm thinking about a sed or perl line), please tell me. This bug is
preventing me from using Calendar which loses a lot of the N900's usefulness
for me.
Comment 3 Andre Klapper maemo.org 2010-02-15 22:04:38 UTC
Thanks for reporting this.

I can confirm that 2.2009.51-1 crashes the Calendar.

Running the internal non-public version 2010.06-13 I could successfully import
this file. It is one event, saying "Urlaub" for 23/12/2009 from 07.00-19.30
plus "Complex repeat. Unable to edit".

Hence this has been fixed in the meantime internally.

A future public update will include the fix. (This is not always already the
next public update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-03-15 20:51:32 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).