Bug 8997 - 3rd party languages shown as "xx_XX" only in Language & Region settings
: 3rd party languages shown as "xx_XX" only in Language & Region settings
Status: RESOLVED WONTFIX
Product: Translations
Localization
: 5.0/(2.2009.51-1)
: All Maemo
: Low enhancement with 1 vote (vote)
: Harmattan
Assigned To: unassigned
: localization-bugs
: http://talk.maemo.org/showthread.php?...
:
:
:
  Show dependency tree
 
Reported: 2010-02-11 17:51 UTC by Zoltan Orosz
Modified: 2012-03-24 11:42 UTC (History)
3 users (show)

See Also:


Attachments
Screenshot of the problem (42.49 KB, image/png)
2010-02-11 17:53 UTC, Zoltan Orosz
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Zoltan Orosz (reporter) 2010-02-11 17:51:12 UTC
SOFTWARE VERSION: 2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 

1. Install the package N900-i18n-hu_HU or issue the command (as root)
"add_remove_language add hu_HU"
2. Go to Settings > Language & Region


EXPECTED OUTCOME: The new language should be shown as "Magyar (Magyarország)"
without the quotes, to match the list.

ACTUAL OUTCOME: The language is shown as "hu_HU" without the quotes.

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED: N900-i18n-hu_HU (but not necessary)

OTHER COMMENTS: Should be fixed in the /usr/lib/locale/locale-archive file

User-Agent:       Opera/9.80 (Windows NT 6.0; U; en) Presto/2.2.15
Version/10.10
Comment 1 Zoltan Orosz (reporter) 2010-02-11 17:53:21 UTC
Created an attachment (id=2269) [details]
Screenshot of the problem
Comment 2 Andre Klapper maemo.org 2010-02-11 18:15:31 UTC
Hi Zoltan, can you explain why exactly this is a Nokia bug and not a bug of
N900-i18n-hu_HU that should provide this string itself?
Comment 3 Zoltan Orosz (reporter) 2010-02-11 18:25:22 UTC
Hi Andre,

Certainly :) AFAIK the country and language names come from the file
/usr/lib/locale/locale-archive. This file is part of the Maemo OS, and is a
binary file, i don't see any way to edit it in its current form. If there is a
way to obtain its sources and recompile it with the missing strings, i could
add that file to the language pack, but i think it's easier for everybody if
Nokia could add those 2 strings to it in the next version, so the language will
be shown correctly in the settings. Please tell me if I missed the point, but I
don't see any way to change that from the user perspective.
Comment 4 Andre Klapper maemo.org 2010-02-11 19:39:42 UTC
@Quim, any idea how feasible this is for the Maemo5 timeframe, and if it's
worth to file an intenal ticket?


(In reply to comment #3)
> i think it's easier for everybody if Nokia could add those 2 strings

Well, this is a general problem, so it's not about adding 2 strings. What if
the next language pack comes? Again add 2 strings? Hmm, that's not a good long
term solution. :-)

http://wiki.maemo.org/Community_localization#Nokia says:
"The language selection dialog in Fremantle uses a hard coded list. This should
be changed in Harmattan. Instead of a hard coded list it should display all
installed translations."
So it *might* be a WONTFIX for Maemo5, but will definitely be available in
Maemo6.
Comment 5 Zoltan Orosz (reporter) 2010-02-12 11:39:01 UTC
I think the best way to handle this would be to add country/language data from
eg. ISO 639, and during bootup check the folder in /usr/share/locale to see
what languages are installed and display the list according to that. However,
this may not fit into Maemo5, so perhaps you should consider the short term
solution of adding them by hand OR releasing the source code of this particular
file with some instructions how to add other languages to it, so the community
can enhance it.
Let me also emphasize that this is only an enhancement with low priority, there
are probably more serious things to work on and this does not affect the
translation at all (it works and I assume that people who buy the phone are
intelligent enough to find their own country's short name in the list) but it
would look definitely better :)
Comment 6 Andre Klapper maemo.org 2010-02-22 15:35:35 UTC
*** Bug 9207 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2012-03-24 11:42:49 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )