Bug 8958 - (int-156830) portrait layout for receiving call shown in landscape mode (-> no Reject button)
(int-156830)
: portrait layout for receiving call shown in landscape mode (-> no Reject button)
Status: VERIFIED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0/(3.2010.02-8)
: N900 Maemo
: Medium critical with 5 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-10 00:58 UTC by Adib
Modified: 2012-10-24 15:05 UTC (History)
8 users (show)

See Also:


Attachments
screenshot (37.94 KB, image/png)
2010-02-10 01:01 UTC, Adib
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Adib (reporter) 2010-02-10 00:58:18 UTC
SOFTWARE VERSION:
51-1

EXACT STEPS LEADING TO PROBLEM: 
At first I am sorry if it is duplicated but i try to found somthing about and
not found...



I dont know exactly but I will try to explane all setting that i have..

1. receiving a phone call

EXPECTED OUTCOME:
answer and reject buttons

ACTUAL OUTCOME:
only answer button..

REPRODUCIBILITY:
dont know

EXTRA SOFTWARE INSTALLED:
some from Extra

OTHER COMMENTS:

that was in land mode..
i have the lunch by turning enabeled. and Display orientation automatic..
I think this happen when the device on back!!

also please give me tips to test all situations..

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.78 Safari/532.5
Comment 1 Adib (reporter) 2010-02-10 01:01:18 UTC
Created an attachment (id=2256) [details]
screenshot
Comment 2 Vladimir Oka 2010-02-10 13:29:44 UTC
I can confirm I've seen this, too, exactly as in screenshot.

Turning control is set to automatic turning, but not to start phone app when
turned upright. I can also confirm that I've seen this with the phone lying on
its back, horizontally. However, I cannot say that it happens always, or never
in other orientations.
Comment 3 Andre Klapper maemo.org 2010-02-10 15:11:09 UTC
Thanks for reporting this.

Looks like the portrait mode layout is displayed in landscape mode.

> EXTRA SOFTWARE INSTALLED:
> some from Extra

Which ones exactly?

> REPRODUCIBILITY:
> dont know

Has this happened only once so far? Or with every phone call? Or just
sometimes?

What are your settings in
* Phone > Main menu > Turning control > Display orientation
* Phone > Main menu > Turning control > Launch by turning
?

When this happens, is the hardware keyboard hidden/collapsed or is it
expanded/available?

Trying to find a pattern for this...
Comment 4 Adib (reporter) 2010-02-10 23:36:37 UTC
Thnks for your attention..

> EXTRA SOFTWARE INSTALLED:
> some from Extra

> Which ones exactly?

about 50 programs should i mention them all??


> Has this happened only once so far? Or with every phone call? Or just sometimes?

no just sometimes...

What are your settings in
* Phone > Main menu > Turning control > Display orientation  ..... Automatic
* Phone > Main menu > Turning control > Launch by turning   ...... enabeled


When this happens, is the hardware keyboard hidden/collapsed or is it
expanded/available?  
it is closed

....

I try today to get that many time...
and i can conferm when that happen with the same configration before..

When the all screen covered but not the sensor, led and front camera ( you got
the idea)also it should be good light there to find a difference, then
receiving a call .. take the cover or if it is on back at the edge of tabel
teurn it,  it will be only the answer bottun.. :)
you can try that with paper putting on the screen..

hopefully thats help.
Comment 5 Andre Klapper maemo.org 2010-02-12 15:32:11 UTC
Thanks. Confirming as per comment 2.
Comment 6 Andre Klapper maemo.org 2010-02-15 13:24:48 UTC
Confirmed internally.
Comment 7 Andre Klapper maemo.org 2010-02-15 14:05:02 UTC
Fixed in the code repository:
http://maemo.gitorious.org/hildon/gtk/commit/5041c20e001c38d88a9077c656c90ac9bf69eb5e
Comment 8 Andre Klapper maemo.org 2010-03-05 15:58:18 UTC
*** Bug 9415 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-03-09 22:44:39 UTC
This has been fixed in package
gtk+2.0 2:2.14.7-1maemo29+0m5
which is part of the internal build version
10.2010.09-3
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 Andre Klapper maemo.org 2010-03-15 20:54:27 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 11 Andre Klapper maemo.org 2010-03-29 12:51:22 UTC
Reopening as this can still be reproduced.
Comment 12 Andre Klapper maemo.org 2010-04-13 17:36:18 UTC
Reason for this has now been found internally, patch is being tested.
Comment 13 Andre Klapper maemo.org 2010-05-19 15:12:13 UTC
This has been fixed in package
rtcom-call-ui 1.20100414+0m5
which is part of the internal build version
10.2010.16-7
(Note: 2009/2010 is the year, and the number after is the week.)

The next public update should include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 14 sole021 2011-09-16 13:10:23 UTC
This bug appeared on my N900 after the last batch of CSSU updates (about a week
or two ago). I tried several things with turning control in phone application
and in cssu configuration but with no success.