Bug 8954 - SMS Sort/Filter/Search does not allow numbers to be entered (Fn key does not work beyond first digit)
: SMS Sort/Filter/Search does not allow numbers to be entered (Fn key does not ...
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-09 20:59 UTC by gauthamn
Modified: 2010-04-27 14:22 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description gauthamn (reporter) 2010-02-09 20:59:28 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

1. In Conversations window, searching/sorting//filtering messages (SMS) using
numbers does not work since it is not possible to enter numbers beyond first
digit.
2. FN key works only for the first digit and does not work thereafter which
means we cannot sort/filter the messages (SMS) using more than one digit which
makes the filtering useless.
3. 

EXPECTED OUTCOME:

Allow complete numbers or more than one digit to be entered to sort/filter the
messages (SMS)

ACTUAL OUTCOME:

Fn key works only for the first digit and fails for the next digit which makes
it impossible to filter messages based on numbers.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

Always

EXTRA SOFTWARE INSTALLED:

None 

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.78 Safari/532.5
Comment 1 Andre Klapper maemo.org 2010-02-12 15:15:42 UTC
Thanks for reporting this, but you are running an old version.
Please update to 2.2009.51-1 before reporting any further reports.

I cannot reproduce this, neither in 2.2009.51-1 nor the internal version
2010.06-3. I press Fn+6, then I press Fn+0 and I get 60 in the search filter.

If this is still an issue for you in 2.2009.51-1 please reopen and provide
exact steps, click by click.
Comment 2 gauthamn (reporter) 2010-02-12 15:50:16 UTC
I seem to have missed entering the correct version but I am running 2.2009.51-1
only.

In the conversations window when you start filtering and start by clicking
Fn+9, I get 9 but for the next digit Fn+0 I get p. Even if I lock the Fn key by
clicking twice the first character only is from the Fn keypad and all
subsequent characters are from the regular keypad which effectively means I
cannot filter by numbers or any Fn keypad characters.

Important to note that it is not just numbers, all the Fn key derived
characters do not work after the first place. So if I start by Fn++ I get + but
the next place is always from the regular keypad fn locked or not!!

Cheers
Comment 3 Andre Klapper maemo.org 2010-02-12 15:52:25 UTC
As written I cannot reproduce this at all.
Wildly guessing, what are your settings for:
* Settings > Text input > Hardware keyboard layout
* Settings > Text input > 1st language
* Settings > Text input > 2nd language
?
Comment 4 gauthamn (reporter) 2010-02-12 18:14:00 UTC
Ok, seems to have solved it

Turning on the virtual keyboard in the Text Input settings resolved this issue.

Thanks
Comment 5 Andre Klapper maemo.org 2010-02-13 01:35:10 UTC
(In reply to comment #4)
> Turning on the virtual keyboard in the Text Input settings resolved this issue.

So this means that it does not work when you have deactivated the Virtual
keyboard?

Can you please answer my questions from comment 3?

What does "resolved" mean here?
Comment 6 gauthamn (reporter) 2010-02-13 14:48:54 UTC
Oops, the bus seems to be present and I had not checked correctly earlier.

Hardware Keyboard Layout - English, Nederlands
Ist language - English (US)
2nd language - not in use (Changed this to English UK)

Turned on Use virtual keyboard and saved the settings.

When I go into conversations window, I am still not able to sort/filter using
the Fn keyboard since only the first character is from the Fn keypad and the
rest are from normal keypad irrespective of the Fn key being locked or not.  

Can you check and reproduce this scenario? Do you want me to post some screen
shots?

(In reply to comment #3)
> As written I cannot reproduce this at all.
> Wildly guessing, what are your settings for:
> * Settings > Text input > Hardware keyboard layout
> * Settings > Text input > 1st language
> * Settings > Text input > 2nd language
> ?
>
Comment 7 gauthamn (reporter) 2010-02-18 11:16:17 UTC
Firmware update to PR1.1.1 also does not resolve this bug. Can someone else
confirm this bug.

Cheers
Comment 8 gauthamn (reporter) 2010-02-19 19:43:39 UTC
I just checked and notice that the same bug exists on phone call logs also i.e
I cannot sort/filter on numbers since Fn key does not work.

Any else can confirm this or is it some setting on my phone?
Comment 9 Andre Klapper maemo.org 2010-03-04 19:52:20 UTC
I'd love to see a second person here confirming this. :-/
Comment 10 gauthamn (reporter) 2010-03-06 09:52:01 UTC
Andre

Can you post your hardware keyboard layout settings, I would like to change
them to your settings and see if the bug still exists

Cheers

(In reply to comment #9)
> I'd love to see a second person here confirming this. :-/
>
Comment 11 Venomrush 2010-03-16 20:54:10 UTC
Confirming 

Filter only search for first digit.
Comment 12 Andre Klapper maemo.org 2010-04-27 14:22:26 UTC
(In reply to comment #10)
> Can you post your hardware keyboard layout settings

Settings > Text input > Hardware keyboard layout is "English, Nederlands" but
should not matter here.

I've tried this both with "Use virtual keyboard" enabled and disabled and it
works in both cases, running a newer internal version here.

So I assume that this has been fixed for the next public release ("PR1.2").
If not, please feel more than free to reopen.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/