Bug 8902 - (EvopeidaSearch) Support evopedia app to do internal search
(EvopeidaSearch)
: Support evopedia app to do internal search
Status: RESOLVED WORKSFORME
Product: TouchSearch
General
: unspecified
: All Maemo
: Unspecified enhancement (vote)
: ---
Assigned To: Brent Chiodo
: general
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-08 00:59 UTC by Alexandro
Modified: 2010-05-28 03:30 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Alexandro (reporter) 2010-02-08 00:59:42 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Widget doesnt have an about -- I think.

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Click on the + of touch search
2. Search for Evopedia term
3. Query on the local folder through the evopedia URL

EXPECTED OUTCOME:

Search for terms within the evopedia repository (http://127.0.0.1:8080)

ACTUAL OUTCOME:

Launch the browser poitning to the term within the Evopedia internal URL
(http://127.0.0.1:8080)

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
10/10

EXTRA SOFTWARE INSTALLED:
Evopedia

OTHER COMMENTS:
Could be a hack, or extra feature, but works toward integration.
http://127.0.0.1:8080

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7)
Gecko/20100110 Mandriva Linux/1.9.1.7-0.1mdv2010.0 (2010.0) Firefox/3.5.7
Comment 1 Alexandro (reporter) 2010-02-08 01:24:15 UTC
Change to enhacement since this is not a bug.
Comment 2 christian 2010-02-08 12:28:47 UTC
Evopedia can be manually added as a search engine using the following steps
(after [1]):

Go into Desktop Edit Mode and tap on the wrench icon of the TouchSearch widget.
Choose "Configure" and the "Add". In the URL field enter
"http://127.0.0.1:8080/?query" and "query" in the Query field. Tap continue and
enter "Evopedia" in the Name field. Note that the "Search Strings" field should
now contain "http://127.0.0.1:8080/?%s". Tap Finish.

Note that Evopedia must be running for the search to work, which is the case if
you used it after the last reboot.

It would be great if someone could make an icon as described in [1] (perhaps
just add "(offline)" to the Wikipedia icon).

[1]
http://www.touchsearch.org/index.php?option=com_content&view=article&id=47&Itemid=30

(note that there is a typo in the alias field of this bug report)
Comment 3 Brent Chiodo 2010-05-28 03:30:16 UTC
Closing as WORKSFORME per Christian's comment.