Bug 8789 - Long, text-only e-mails display incorrectly after a certain length
: Long, text-only e-mails display incorrectly after a certain length
Status: RESOLVED DUPLICATE of bug 5870
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-02 17:57 UTC by Michael Cronenworth
Modified: 2010-02-02 21:49 UTC (History)
1 user (show)

See Also:


Attachments
Screenshot showing display corruption (81.95 KB, image/png)
2010-02-02 17:59 UTC, Michael Cronenworth
Details
Email text from screenshot (56.61 KB, text/plain)
2010-02-02 18:01 UTC, Michael Cronenworth
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Michael Cronenworth (reporter) 2010-02-02 17:57:42 UTC
SOFTWARE VERSION: 2.2009.51-1.002
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Receive a text-only email of at least 25kbytes in length. I will attach an
example.
2. Begin using your finger to scroll down the page.
3. In a 50kbyte email, the screen will start to be corrupted at around 50% of
the email. I will attach a screenshot.

EXPECTED OUTCOME: Legible email.

ACTUAL OUTCOME: Illegible email.

REPRODUCIBILITY: Always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: No add-ons or modifications to modest have been made.

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6)
Gecko/20100107 Fedora/3.5.6-1.fc12 Firefox/3.5.6
Comment 1 Michael Cronenworth (reporter) 2010-02-02 17:59:23 UTC
Created an attachment (id=2196) [details]
Screenshot showing display corruption

This is a screenshot showing when the e-mail display became corrupted about 50%
down the email that I will attach next. If I scroll back up before it becomes
corrupted, the screen scrolls and displays properly. If I scroll back down it
becomes corrupt again. It seems there is a limit of some sort in modest.
Comment 2 Michael Cronenworth (reporter) 2010-02-02 18:01:28 UTC
Created an attachment (id=2197) [details]
Email text from screenshot

This is the exact copy of the e-mail that the screenshot displays.
Comment 3 Lucas Maneos 2010-02-02 21:49:03 UTC
Thanks for the bug report. This particular issue has already been reported in
our bug tracking system, but please feel free to report any further bugs you
find. 

*** This bug has been marked as a duplicate of bug 5870 ***