Bug 8775 - Skype profile based phone numbers with spaces don't identify caller
: Skype profile based phone numbers with spaces don't identify caller
Status: RESOLVED DUPLICATE of bug 6945
Product: Contacts
General
: 5.0/(2.2009.51-1)
: All Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-02 13:24 UTC by Matti Viljanen
Modified: 2010-02-02 22:16 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Matti Viljanen (reporter) 2010-02-02 13:24:50 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Add your Skype account details
2. Receive a bunch of Skype contacts
3. Check that some contact contains a telephone number with spaces in it (the
other user has added telephone number to his/her Skype profile) and that the
number doesn't exist in your other contacts already
4. Dial to that number to confirm that the number is correct (not a Skype call)
5. The name of the user is displayed in the call dialog, end call
6. Now receive a call from the same number (not a Skype call)

EXPECTED OUTCOME:
You see the name and the avatar of the Skype user

ACTUAL OUTCOME:
You only see the number, not the name and avatar

REPRODUCIBILITY:
10/10 with two conditions met:
1. The Skype contact must have telephone number entered in the profile
2. The phone number must have one or more spaces in it (to ease readibility of
the internationally formatted telephone number, I think)

EXTRA SOFTWARE INSTALLED:
Many, but confirmed after a flashing, too

OTHER COMMENTS:
Suggested solution: Strip spaces from the imported phone numbers during the
import process, affecting the "cached" number of the contact.
Comment 1 Andre Klapper maemo.org 2010-02-02 22:16:53 UTC
Thanks for reporting this.

This is actually the same issue as bug 6945 which has been already fixed
internally. See the last comment in that report for more information.

*** This bug has been marked as a duplicate of bug 6945 ***