Bug 8772 - Pulseaudio uses CPU when no sound playing
: Pulseaudio uses CPU when no sound playing
Status: RESOLVED DUPLICATE of bug 6868
Product: Multimedia
Pulseaudio
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: unassigned
: pulseaudio-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-02 12:50 UTC by PeteC
Modified: 2010-02-02 14:45 UTC (History)
1 user (show)

See Also:


Attachments
complete 'lsof ' output (57.51 KB, application/octet-stream)
2010-02-02 12:51 UTC, PeteC
Details
strace -p `pidof pulseaudio` -f -T -tt (3.00 KB, text/plain)
2010-02-02 12:52 UTC, PeteC
Details
ls -thl /proc/`pidof pulseaudio`/fd (5.53 KB, text/plain)
2010-02-02 12:53 UTC, PeteC
Details
output of "ps" (9.50 KB, text/plain)
2010-02-02 12:54 UTC, PeteC
Details
output of "powertop" (3.74 KB, text/plain)
2010-02-02 12:55 UTC, PeteC
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description PeteC (reporter) 2010-02-02 12:50:00 UTC
SOFTWARE VERSION:
2009.51-1

EXACT STEPS LEADING TO PROBLEM:
Hard to determine the cause. This morning I have woken with an alarm and
listened to internet radio via media player, but I've only just noticed the
condition and have an uptime of >3 days.

EXPECTED OUTCOME:
No sounds played so pulseaudio should be idling.

ACTUAL OUTCOME:
pulseaudio is using between 1% and 6% (average ~2.5%) CPU continuously.

REPRODUCIBILITY:
Unknown- this is the first time I've noticed it and I want to keep the
condition 'alive' to investigate. Comment on T.M.O. (see below) suggests it's
rare.

EXTRA SOFTWARE INSTALLED:
forca widget
calendar widget
2g/3g mode selection applet
cpumem-applet
custom operator name widget
extra decoders support
personal ip address (enabled & disabled this morning)
pidgin protocols plugin for conversations & contacts

OTHER COMMENTS:
I can't (yet) pin down what's to blame for this situation.
Can anyone tell from my strace/lsof output what pulseaudio is doing & whether
any process is connected to it?

In my 3 days uptime I have watched videos, viewed flash in MicroB, taken phone
calls, used google talk, listened to internet radio...  I honestly don't know
what could have triggered this.

This comment on T.M.O. is clearly talking about the same problem:
http://talk.maemo.org/showpost.php?p=488511&postcount=6

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.1.7)
Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Comment 1 PeteC (reporter) 2010-02-02 12:51:08 UTC
Created an attachment (id=2189) [details]
complete 'lsof ' output
Comment 2 PeteC (reporter) 2010-02-02 12:52:28 UTC
Created an attachment (id=2190) [details]
strace -p `pidof pulseaudio` -f -T -tt
Comment 3 PeteC (reporter) 2010-02-02 12:53:46 UTC
Created an attachment (id=2191) [details]
ls -thl /proc/`pidof pulseaudio`/fd
Comment 4 PeteC (reporter) 2010-02-02 12:54:29 UTC
Created an attachment (id=2192) [details]
output of "ps"
Comment 5 PeteC (reporter) 2010-02-02 12:55:09 UTC
Created an attachment (id=2193) [details]
output of "powertop"
Comment 6 Andre Klapper maemo.org 2010-02-02 14:07:49 UTC
Thanks for reporting this.

So no call was involved (bug 6868)?
Comment 7 PeteC (reporter) 2010-02-02 14:45:17 UTC
(In reply to comment #6)
> So no call was involved (bug 6868)?
> 

Oh crap, I must have only searched for 'Open' bugs. Yes sorry it's a dupe.

I had taken calls.
running "killall tonegend" (as mentioned in bug 6868) resolved the CPU load and
pulseaudio has now released the sound device.


*** This bug has been marked as a duplicate of bug 6868 ***