Bug 8769 - (Mikael) Screen unlocked at the end of a call
(Mikael)
: Screen unlocked at the end of a call
Status: RESOLVED DUPLICATE of bug 5982
Product: Chat & Call & SMS
Call Application UI
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-02-02 05:51 UTC by Mikael
Modified: 2010-02-03 15:56 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Mikael (reporter) 2010-02-02 05:51:29 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Connect Bluetooth headset (BH-903)
2. Start a phone call
3. Lock the screen with the slider on the side of the phone
4. Put the phone in the pocket or a bag
5. End phone call with the button in the bluetooth headset

EXPECTED OUTCOME:

Phone stays locked when call ends.

ACTUAL OUTCOME:

Screen is unlocked and accepts random presses in the pocket or bag, leading to
unpredictable behavior and reducing bluetooth headset usability.

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:

Nothing running at the time, no bluetooth or phone call related software
installed.

OTHER COMMENTS:

1. This behavior is not consistent with other Nokia phones such as E71.
2. Could happen with wired headset as well, have not tried.

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-GB; rv:1.9.2a1pre)
Gecko/20091127 Firefox/3.5 Maemo Browser 1.5.6 RX-51 N900
Comment 1 Andre Klapper maemo.org 2010-02-02 13:50:59 UTC
Thanks for reporting this.
This particular issue has already been reported in our bug tracking system, but
please feel free to report any further bugs you find. Also feel encouraged to
vote for the original bug report if interested.

Please feel free to search for existing reports first to avoid filing
duplicates.


*** This bug has been marked as a duplicate of bug 5982 ***
Comment 2 Mikael (reporter) 2010-02-03 09:14:03 UTC
I did search for duplicates, and disagree that opening the screen lock at the
END of a call is the same bug as opening it at the start of the call. They seem
to be two completely different use cases - opening lock at the start of the
call might even be justified, but it makes no sense whatsoever at the end of
the call.

In any case, leaving it to your capable hands to decide if this should be
re-opened as a separate bug.
Comment 3 Andre Klapper maemo.org 2010-02-03 14:00:07 UTC
Well, fixing bug 5982 will also fix this bug. :-)
Comment 4 Mikael (reporter) 2010-02-03 15:56:14 UTC
Sorry to be persistent, but to make sure that we are aligned here:

This bug is a bug - to my umderstanding there is no user need to unlock the
phone at the end of the call. Thus this bug can be simply resolved by removing
the unlocking feature (or by making it optional).

The other bug is much more complicated, involving resolution candidates that
would require new features to be implemented.