Bug 8681 - Modest auto-adding unknown email recipients to Contacts upon send should be optional
: Modest auto-adding unknown email recipients to Contacts upon send should be o...
Status: RESOLVED DUPLICATE of bug 4976
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low enhancement with 1 vote (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-30 05:47 UTC by Dawid Lorenz
Modified: 2010-01-30 13:06 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Dawid Lorenz (reporter) 2010-01-30 05:47:04 UTC
SOFTWARE VERSION:
2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Open up Modest and any mailbox within it
2. Find any email sent from a someone who is not stored in Contacts yet
3. Reply to that email, send it
4. Open up Contacts application
5. Find that person's email address is automatically added to Contacts

EXPECTED OUTCOME:
Email client should either:
a) ask user upon sending if it's OK to save recipient in Contacts,
or
b) offer an option in general settings menu which would enable/disable that
feature.

ACTUAL OUTCOME:
Unknown recipient's email address and name (if provided) is stored to Contacts
beyond user's control.

REPRODUCIBILITY:
Always. Since 42-11.

OTHER COMMENTS:
I personally hate having a mess in Contacts, hence Modest currently is very
good in borking perfection of my Contacts list. ;)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.1.6)
Gecko/20100107 Fedora/3.5.6-1.fc12 Firefox/3.5.6
Comment 1 Lucas Maneos 2010-01-30 13:06:42 UTC
Thanks for the bug report. This particular issue has already been reported in
our bug tracking system, but please feel free to report any further bugs you
find.

*** This bug has been marked as a duplicate of bug 4976 ***