Bug 8665 - (int-155194) Media Player violates the RDS specification by abusing the PS field for dynamic text
(int-155194)
: Media Player violates the RDS specification by abusing the PS field for dynam...
Status: RESOLVED DUPLICATE of bug 8396
Product: Media player
General
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-29 19:57 UTC by Martin Grimme
Modified: 2010-02-02 13:37 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Martin Grimme (reporter) 2010-01-29 19:57:49 UTC
SOFTWARE VERSION:
PR 1.1 (2009.51)

EXACT STEPS LEADING TO PROBLEM: 
1. Start Media Player, play a song and enable FM transmitter
2. Use an RDS capable radio receiver to check the result (e.g. FM Radio Player
on a second N900)

EXPECTED OUTCOME:
The RDS specification strictly prohibits the use of dynamic RDS PS text:

IEC 62106:1999 standard, section 3.2.2:
"""
[...] These changes which may occur a few times a day and have a duration of
anything between a few minutes and several hours, are acceptable, but any other
dynamic changes to PS are NOT acceptable and may cause a safety hazard by
distracting a vehicle driver. [...] As a result, dynamic PS and PTYN
transmissions are expressly forbidden.
"""

The 64 character RDS RT field may be used for dynamic text, instead.

ACTUAL OUTCOME:
Media Player violates the RDS specification and endangers vehicle drivers by
abusing the PS field for dynamic text.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2010-02-02 13:37:22 UTC
Same issue as bug 8396.

*** This bug has been marked as a duplicate of bug 8396 ***