Bug 8622 - MADDE Terminal can't be started
: MADDE Terminal can't be started
Status: VERIFIED WORKSFORME
Product: Development platform
Madde
: 5.0-final
: x86 Windows
: Unspecified minor (vote)
: ---
Assigned To: unassigned
: sdk-madde-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-28 20:03 UTC by Bartosz Taudul
Modified: 2010-03-11 14:32 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Bartosz Taudul (reporter) 2010-01-28 20:03:39 UTC
SOFTWARE VERSION:
xmas

EXACT STEPS LEADING TO PROBLEM: 
1. Download MADDE installer for Windows
(http://tablets-dev.nokia.com/MADDE.php?f=install-madde-xmas.exe)
2. Install it using default settings.
3. Try to run MADDE Terminal.

EXPECTED OUTCOME:
MADDE Terminal starts.

ACTUAL OUTCOME:
"The application was unable to start correctly (0xc0000142)." dialog box is
displayed. Terminal can't be opened.

REPRODUCIBILITY:
Machine 1: always
Machine 2: never

EXTRA SOFTWARE INSTALLED:
Machine 1: cygwin

OTHER COMMENTS:
Removing "-rxvt" from MADDE Terminal parameters launches standard Windows CMD
prompt, where everything is working.

Severity blocker, as the random Windows developer wouldn't be able to find the
workaround.
Comment 1 Kristiina 2010-02-01 09:09:42 UTC
Can you give more information about the machines you are using (from the output
of systeminfo command): OS Name, OS Version, System Type.
Also cygwin version installed on machine 1.
Comment 2 Bartosz Taudul (reporter) 2010-02-01 17:39:44 UTC
On the machine that HAS this problem:

OS Name:                   Microsoft Windows 7 Ultimate
OS Version:                6.1.7100 N/A Build 7100
System Type:               x64-based PC

cygwin1.dll: 1.5.25-cr-0x5f1
Comment 3 Bartosz Taudul (reporter) 2010-02-01 19:17:22 UTC
On the machine that DOES NOT have this problem:

Nazwa systemu operacyjnego:          Microsoft Windows 7 Professional
Wersja systemu operacyjnego:         6.1.7600 BRAK Kompilacja 7600
Typ systemu:                         x64-based PC
Comment 4 Bartosz Taudul (reporter) 2010-02-11 17:23:07 UTC
Upgrading cygwin to 1.7.1-1 does not change anything.
Comment 5 Tomi Ollila 2010-02-14 14:23:43 UTC
The reason is probably between windows system and msys (1.0.11) environment.

So far we have not been able to reproduce the problem; we will when we get
suitable virtual machine setup for windows 7 ultimate 64 bit)

Until that, and if you are adventurous you can try whether replacing
msys-1.0.dll from newer MSYS work (Just tried that on Windows 7 Home Premium 
64bit; msys-1.0.dll from MSYS 1.0.13 works fine):

Go to http://sourceforge.net/projects/mingw/files/

and download
http://sourceforge.net/projects/mingw/files/MSYS%20Proposed/msys-1.0.13-2/msysCORE-1.0.13-2-msys-1.0.13-bin.tar.lzma/download

(Under MSYS Proposed and so on, if the above link does not work)

Id you're using MADDE terminal, you can extract the archive with command line:

$ lzma -cd /c/path/to/file.lzma | tar xvf -

At this point, exit madde terminal and start windows terminal (unless using
file manager)

Go to C:\MADDE\0.6.14 (or wherever you extracted MADDE)

move bin\msys-1.0.dll bin\msys-1.0.11.dll

copy path\to\extracted\msys-1.0.13\bin\msys-1.0.dll bin

try launching MADDE terminal with -rxvt -option.

(If the terminal now starts OK we have to schedule msys.dll replacement
creation for MADDE)
Comment 6 Bartosz Taudul (reporter) 2010-02-22 14:33:53 UTC
(In reply to comment #5)
> Until that, and if you are adventurous you can try whether replacing
> msys-1.0.dll from newer MSYS work (Just tried that on Windows 7 Home Premium 
> 64bit; msys-1.0.dll from MSYS 1.0.13 works fine):
Issue still reproducible with a new msys dll.

Note that since beta Windows 7 license is soon to expire, I don't expect to be
able to reproduce this bug anymore.
Comment 7 Tomi Ollila 2010-02-22 14:36:59 UTC
Thanks for the info. 

I hope we'll be able to reproduce this in near future...
Comment 8 Bartosz Taudul (reporter) 2010-02-26 16:39:10 UTC
I have changed my system and now I'm unable to reproduce this bug.
Comment 9 Kristiina 2010-03-04 13:25:19 UTC
Priority changed to minor as problem seems to diasappear with Windows OS
updates/newer versions.
Problem did not appear in Windows 7 Ultimate 6.1.7600, neither in Windows 7
Home Premium. Tested both in 32/64 bit machines.

Bartosz Taudul: can you tell which changes to the system caused the problem to
disappear.
Comment 10 Bartosz Taudul (reporter) 2010-03-04 14:26:43 UTC
Update (reinstall) from Windows 7 RC to Windows 7 final fixed the problem. I
doubt the system change is a real fix though, as reinstall eliminates the
unknown external factors that may have accumulated in the previous environment.
Comment 11 Tomi Ollila 2010-03-11 10:48:07 UTC
Bug report filed when using release candidate version :)

Bug disappared using final version :)

We cannot check MADDE against all external factors that might arise;
If we could recreate the problem and resolve it we could see whether
there is problem in MADDE or in windows environment.

For now I am closing this bug. Reopen/make new one if the problem
reappears (please).
Comment 12 Tomi Ollila 2010-03-11 11:00:32 UTC
Additionally, the page http://wiki.maemo.org/MADDE/KnownIssues
references to this page.