Bug 8585 - N900 won't dial certain valid numbers
: N900 won't dial certain valid numbers
Status: RESOLVED DUPLICATE of bug 5357
Product: Telephony
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium major (vote)
: ---
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-27 20:13 UTC by Conrad Hughes
Modified: 2010-01-27 21:12 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Conrad Hughes (reporter) 2010-01-27 20:13:02 UTC
SOFTWARE VERSION:
5.0/(2.2009.51-1)

EXACT STEPS LEADING TO PROBLEM: 
1. Enter Phone application.
2. Enter the dialler.
3. Dial *#10#
4. Press call.

EXPECTED OUTCOME:
This is the number I dial to obtain my account credit information with O2 UK.
Expected outcome is that I receive an SMS telling me what my call balance is
(that's what happens on my Nokia 6300 for example).

ACTUAL OUTCOME:
The N900 refuses to dial, flashing up an "Invalid number" message.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
none

OTHER COMMENTS:
There are other numbers I can call, so there's a workaround, but I think the
software shouldn't be telling me what I can/cannot dial.  The network should
be what decides this.
Comment 1 Lucas Maneos 2010-01-27 21:12:23 UTC
Thanks for the bug report. This particular issue has already been reported in
our bug tracking system, but please feel free to report any further bugs you
find.

*** This bug has been marked as a duplicate of bug 5357 ***