Bug 8573 - (int-154520) Conversation doesn't respect aspect ratio in avatars
(int-154520)
: Conversation doesn't respect aspect ratio in avatars
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-27 14:25 UTC by Bartosz Taudul
Modified: 2010-04-14 13:31 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Bartosz Taudul (reporter) 2010-01-27 14:25:04 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Externally set non-square avatar (setting avatar on device will crop it to
square) in jabber or skype.
OR
1. Have some person with non-square avatar in roster.
2. Start conversation where at least one avatar won't be square.
3. Observe how avatars are displayed.

EXPECTED OUTCOME:
Avatars in conversation are displayed as in conversation list.

ACTUAL OUTCOME:
Avatars are stretch-scaled to fit into square in conversation window.

REPRODUCIBILITY:
always

OTHER COMMENTS:
See bug 7683.
Comment 1 Andre Klapper maemo.org 2010-01-27 19:13:51 UTC
*** Bug 8534 has been marked as a duplicate of this bug. ***
Comment 2 Andre Klapper maemo.org 2010-02-13 02:35:50 UTC
*** Bug 8823 has been marked as a duplicate of this bug. ***
Comment 3 Andre Klapper maemo.org 2010-02-23 22:42:37 UTC
This has been fixed in package
rtcom-messaging-ui 1.2.21-1.0rtc+0m5
and internal build version 10.2010.06-7.
The fix will be part of the next public update.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-02-24 16:14:58 UTC
*** Bug 9256 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-03-15 20:52:30 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 6 Andre Klapper maemo.org 2010-04-14 13:31:08 UTC
*** Bug 9103 has been marked as a duplicate of this bug. ***