Bug 8500 - (int-154378) Volume buttons do not work as expected when answering a call while in landscape mode
(int-154378)
: Volume buttons do not work as expected when answering a call while in landsca...
Status: RESOLVED WONTFIX
Product: Chat & Call & SMS
Call Application UI
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-25 16:16 UTC by Markus
Modified: 2010-02-02 12:48 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Markus (reporter) 2010-01-25 16:16:47 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Hold the N900 in landscape mode, showing the desktop.
2. Call the N900 from another telephone. The Phone application is automatically
started (in landscape mode).
3. Tap "Answer"
4. Bring the N900 up to the ear (quickly). The display turns off.
5. Turn the volume up by pressing the upper side of the physical volume button
that is behind the front "Nokia" label.

EXPECTED OUTCOME:
Volume is turned up

ACTUAL OUTCOME:
Volume is turned down

REPRODUCIBILITY:
Always if the phone is not brought up to the ear too slowly. The problem can
also be reproduced by bringing the N900 to landscape mode while in a
conversation (for example to check the calendar) and the quickly bring it up to
the ear to continue the conversation.

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:
I believe that problem occurs because the Phone application is not rotated when
the screen is turned off by the proximity detector. Removing the phone from the
ear will re-activate the screen and you can then see that the Phone application
is rotated to portrait mode: The volume keys will now work as expected.

("Display orientation" must be set to "Automatic" in the Phone application.)
Comment 1 Andre Klapper maemo.org 2010-01-25 20:17:23 UTC
Thanks for reporting this.
For the story before see bug 6384.
Comment 2 Andre Klapper maemo.org 2010-01-28 14:18:22 UTC
So this is internally considered as the same issue as bug 6384.
What's been mentioned here won't be changed...

*** This bug has been marked as a duplicate of bug 6384 ***
Comment 3 Markus (reporter) 2010-01-28 15:02:07 UTC
The problem presented here is that the screen does not seem to rotate to
portrait mode if the proximity sensor is active, i.e. when holding the phone to
the ear after receiving a call in landscape mode. The volume buttons are not
swapped as expected for portrait mode.

Bug 6384 was fixed in release 2.2009.51-1, which is the software version where
current bug now exists. It (if verified by others as well) should therefore be
registered somewhere; Either as a failed fix of bug 6384 (i.e. reopen that bug)
or as a new bug here. (Or a somewhat strange WONTFIX)
Comment 4 Markus (reporter) 2010-02-02 10:05:10 UTC
I reopen this bug as I consider it different from bug 6384. Bug 6384 was fixed
in release 2.2009.51-1. This issue is present is release 2.2009.51-1. See also
comment #3.
Comment 5 Andre Klapper maemo.org 2010-02-02 12:48:32 UTC
The behaviour in bug 6384 is the current behaviour and Nokia does not plan
changes here. -> WONTFIX.